Y-Axis not positioning correctly - Problems with Homing

Hey Everyone, I’m having issues with homing my K40 (orion) machine. Please take a look at my youtube video: https://www.youtube.com/watch?v=XGyLD9xTuDI&feature=youtu.be

I’ve tried editing the config file, inverting the Y-dir value, swapping Y min & max values, changing the Home_direction in the endstop configuration. Nothing seems to work. If I switch home direction to min at 0, the y axis doesn’t home at all. Let me know if anyone has a solution to this issue.

Hey Cam. welcome to the forum!

Thanks for the video. We typically ask to see some photos of the board and wiring but I can sort of make it out in the video.

First issue, can you confirm the endstops are working properly? This article will walk you through it:

Now, if you you jog the laser head in LightBurn, does it go the correct direction in X and Y respective to the buttons?

Hey Pete,

The endstops are working properly, I used a multimeter to check their function. The Y direction is inverted, however, if I change the dir value to include a inverse ! for the Y axis, the home button makes the Y axis run into the the bottom left side, instead of homing to the top left where the endstop switch is.

Did you also test the endstops via the console in LightBurn as explained on the page linked above?

If you want to invert the direction of a stepper there are typically two ways to do so. You can unplug the connector from the board and rotate it 180 degrees. (This may not work if the connector is keyed.) Or you can change it in the config file.

Can you post your entire config file as text so we can see what you’ve already changed?

To post the config file in a reply here please surround it with 3 backticks (that’s the key at the top left of your keyboard where the tilde is) like so:

```

paste your config file here

```

It will make the code nicely formatted like this...
beta_step_pin           2.1           # Pin for beta stepper step signal
beta_dir_pin            0.11          # Pin for beta stepper direction
beta_en_pin             0.10          # Pin for beta enable

(Alternatively, you may paste the config file to Pastebin, Dropbox, or Google Drive and provide the link here.)

Stick with stock config for now.

- Make sure homing still works (it looks good in the video)
- Put head in center and make sure that using the move buttons in LightBurn that left jogs left, right jogs right, up moves the head toward the rear of the machine, and down moves the head towards the front of the machine.


Does this apply to you?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.