Y axis not moving

Hi, not sure if this has been addressed in the past but I recently installed my new c3d laserboard and lcd,now for some reason my laser will only move and cut on the x axis. Any help is appreciated.

Hi Justin,

Welcome to the forum! I have upgraded your trust level so that you can now upload pictures.

Please provide pictures of your machine, control panel, board, other electrical components, and wiring.

Thank you, here are the pictures I have.

Hi Justin,

Thanks for the photos.

Trace the X & Y cables to your stepper motors/drivers and confirm that they are plugged into the appropriate axis. Make sure the connectors are properly seated, that each pin is making proper contact, and that the wires are making contact on either end.

Start by issuing a G0 Y10 F600 command via the LightBurn console to see if that moves the Y axis. Does it work?

You may need to invert the Y direction in the board config (beta_dir_pin) by adding or removing a ! after the pin # in the config.txt file on the memory card. Use Sublime Text to make the edits. Power down the board when removing or reinserting the SD card.

Also, if this is a new setup, you’ll want to update the configuration changes to dial in the physics for your machine size, review our Larger Laser Machine Installation Guide.

hi, tried your suggestions nothing worked here is a picture of the board
image

Thanks for the photo, Justin. What are the specs on the stepper motors you are using? Do you have external drivers?

Let’s take a look at your configuration settings. Please provide a copy of your configuration file for review. Copy and paste it in a reply with 3 backticks ``` above and below the content or paste the contents to Dropbox, Google Drive, or Pastebin and provide the link here.

https://drive.google.com/file/d/1KiEtInn9iQRQ7PHBrkPLHYOZ65N3tlfR/view?us

here is the file


image
image
image

Hi Justin,

The file is denying access. Can you change the settings or just copy and paste as mentioned above, please?

https://drive.google.com/file/d/1KiEtInn9iQRQ7PHBrkPLHYOZ65N3tlfR/view?us

config - Copy.txt (28.4 KB)

Hi Justin,

Thanks for providing a copy of your configuration file.

Based on your profile, it looks like you have a larger machine, so there are some additional updates to dial in your settings. These are covered in the Larger Machine Installation Guide previously provided. You can tweak some of the values I lowered on the new file, until you get optimal performance.

I have created a starting point config file attached below for a 600 x 400 bed size. Power down the machine before removing the card and make sure it’s off when you reinsert it. Save the original config file locally to your computer, delete the existing one from the SD card, and upload this one to try out.

The value of 1.2 you entered for the currents is the max, so make sure the stepper motors are not getting hot to the touch. More information: Changing Stepper Motor Currents

config.txt (28.4 KB)

If you still experience issues, check continuity on your stepper motor wiring to make sure the Y axis is getting signal. If you plug this same motor into the X axis header, does it move as expected using the arrow keys in LightBurn? Please provide more details on what exactly you are doing and what the results of those tests are, so I can help you troubleshoot further.

only the x axis moves when i switch it, but that is from using the y axis keys in lightburn i will try the new config and re check the wiring again.

unfortunately nothing has changed, except that the x has now also stopped working. is it possible that it could be a stepper drive issue on the board itself? before i switched to this board my motors worked fine.

Is there anything else I can try.? Is there anyway to exchange the board ?

I tried reinstalling my m2 nano, the laser cutter moves fine so it must be an issue with the board.

Hi Justin,

We’ve been looking over this. Thanks for your patience and for trying the previously provided steps.

Since the configuration file update, if neither of your axes are working, there may be an issue with the file being read by the board. Let’s try again. Confirm that your card is being read properly and refresh the firmware with the stock files for now (we will revisit specific configuration updates for your machine after we test the stepper motors again):

  1. With everything powered down and unplugged, remove the SD card from the LaserBoard.
  2. Plug in the LaserBoard power supply, power on and wait 30-60 seconds.
  3. Review the lights on the board and make note of the LED Sequence and report back what you are seeing before and after the update, please.
  4. Reformat and flash the memory card again from the instructions in the link above.

What is the LED status before and after doing the stock file update?


Once we know the card is being read, we can remap the pins in the config file to try to move the Y axis driver to use Z or A . Below is an example snippet of a configuration remapping Y to Z.

# Stepper module pins ( ports, and pin numbers, appending "!" to the number will invert a pin )

# X axis
alpha_step_pin                               2.0              # Pin for alpha stepper step signal
alpha_dir_pin                                0.5!            # Pin for alpha stepper direction
alpha_en_pin                                 0.4             # Pin for alpha enable pin
alpha_current                                1.0              # X stepper motor current
alpha_max_rate                               24000.0          # mm/min
alpha_acceleration                           2500             # mm/sec²

# Y axis
beta_step_pin                                2.2              # Pin for beta stepper step signal
beta_dir_pin                                 0.20!             # Pin for beta stepper direction
beta_en_pin                                  0.19             # Pin for beta enable
beta_current                                 1.0              # Y stepper motor current
beta_max_rate                                24000.0          # mm/min
beta_acceleration                            2500             # mm/sec²

# Z axis
gamma_step_pin                               2.1              # Pin for gamma stepper step signal
gamma_dir_pin                                0.11              # Pin for gamma stepper direction
gamma_en_pin                                 0.10              # Pin for gamma enable
gamma_current                                1.0              # Z stepper motor current
gamma_max_rate                               24000.0          # mm/min
gamma_acceleration                           2500             # mm/sec²

Disconnect the Y stepper motor and plug the connector into the Z axis port on the board to run further tests.

After making the changes, check to see if your Y axis is moving properly with the below commands, first disabling auto homing in Devices.

In LightBurn’s Laser panel click the Devices button to get to the device configuration screen.

01

Select your laser (most likely named Smoothieware) and click the Edit button.

02

Click Next until you get to the screen where you can turn off Auto home on startup.

03

With the laser powered off, place the head of the laser in the center of the machine, and then power it on. Do not press the Home button or jog the head in LightBurn.

Open the Console and type each of the following at one time, then hit Return after each command.

G1 X50 S0 F600

G1 X80 S0 F800

Let us know the results in detail, please. Did the head move as expected with each command? Does it move as expected if you jog it using the arrows in LightBurn?

Here is an image of the lights that are on.

After following the directions you sent me the head will only move towards the left and when homed it runs into the far left side and doesn’t stop.

Please describe what the lights are actually doing. Which ones are flashing, which ones are staying on?

After the updated files I have three solid green lights 3v3, l4,l1. L2 and l3 are blinking and play led is flashing green.