X and Y wont move

Machine: K40 digital

Board: laserboard

Firmware: _Smoothie

Problem/ Question: Hello i have been trying to get this laser working since before Christmas and am not having any luck… any and all help will be greatly appreciated.

i have upgraded my K40 with the C3D Laserboard and lightburn software and i have checked and rechecked the wiring and am positive it is correct.
the problem seems to be that the board is not sending the signal to the stepper motors. when i first turn the machine on i hear the stepper motor lock up but thats all that happens.
i put the M2 Nano board back in and can run the machine, Works with out issues with K40 wisperer so i know the steppers work.
the laser board has all the correct LEDs lighting up, lightburn recognizes the laser and seems to be sending the commands but the steppers wont move.
im using Windows 10.

its been two months and havent made a thing please help thanks in advance.

 -Matt

Hey Matt,

It’s a long shot, but is the stepper motor wires connected into the right port? There is a “non ribbon” cable installation and “ribbon cable” installation. I think i had the same problem, i had plugged the white motor connector into the wrong plug and it gave me grief.

is the installation documentation. Depends on what cable arrangement you have. The one i had was the ribbon cable. If it is make sure the ribbon cable is plugged in with the contacts facing towards the inside of the board, and the white plug for for the other motor plugs into the Y port.

Anyway, you have probably seen this and tried it all, but i hope it helps.

Ben

thanks yeah i have checked and rechecked i know the wiring is correct but it wont work for some reason thanks for a response!!!

No worries. Anything to do with the config file on the SD card maybe?

lol tried that as well and no go.

1 Like

Please upload pictures of your wiring to the board and to the laser power supply.

I’m having this same issue. No movement and no response in lightburn. Could it be end stop wiring?

im not sure. My stepper motors are getting power (they lock up when power is on) lightburn console says ok after every input put they just won’t do anything. everything works fine when the nano board is installed so i know the steppers work and it definitely isnt a wiring issue.