Woot Woot! Successful(?) Installation

Machine: Chinese K40 blue & white purchased from AliExpress Vevor Specialty Store

Board: LaserBoard

Firmware: “I have a new board and I’m using whatever it came with”

Problem/ Question:
This morning I was successful in installing my new LaserBoard and mA meter. I wanted to install the meter so I can utilize the digital board to set the power, but really know where the power is set with the meter.

I have two questions (for now, I’m sure I’ll be back…):

  1. I plugged everything in and then shut it all down to go eat lunch. I noticed what sounds like air/water running and finally isolated it the stepper motor. I can’t freely move the gantry, so I’m guessing there’s a capacitor somewhere still providing power, or did I screw something up?

  2. When I chose Smoothieware in Lightburn it “found” my board, but set the size at 200mm x 200mm. Can I just make the adjustment in Lightburn, or do I need to modify the Smoothieware config file?

I should have noted that even with everything (except the LaserBoard) unplugged, the gantry won’t move and the I can hear the noise.

Perhaps this is because of the Trinamic stepper motor drivers as referenced here: https://cohesion3d.com/knowledgebase/laserboard-stepper-motor-noise-and-stepper-driver-modes/

But unless I remove power from the LaserBoard I can’t get the stepper motors released. Not really to the solution I was looking for when one switch used to power it all down…

Am I missing something else?

Here’s my LPSU wiring

Hi John,

Thanks for your patience while we reviewed this. Happy to hear you got the board and mA meter installed! Nice shop! :slight_smile:

Can you also provide images of the LaserBoard and stepper motor connections where I can see everything fully, please?

This data is being fed from the config file parameters for your alpha and beta max values. If you have left the default to home to min on the X axis, then you do not need to update it in the configuration file and can just update the value in the LightBurn settings. If you want to see it default to the values in the pop up automatically, then you can update it in the config file, if you like. It is not necessary.

Yes, this could cause the “air” sound you are hearing, but it is concerning that this is occurring with the board powered down.

Let’s test to see if your SD card is being read properly:

  1. Please put the memory card in the computer and verify that there is a firmware.CUR file and a config file on the card. A screenshot of the contents of the memory card can help us confirm that everything is correct.
  1. Follow this guide. Start with turning off auto-homing as it shows in LightBurn as it shows at the top.
    Put the head in the middle of the machine as you had in the video.
    Now when you turn on the machine, the motors/ head should NOT lock.
    You can try to use the jog buttons in LightBurn’s move tab, and try to move the head left/ right and foward/ back.
  2. Finally, follow the rest of the guide to actually test the homing switches in LightBurn.

Please let us know the results of all the items above.

Thanks!

So after the posting yesterday I did more research and ended up modifying the config file. I have full travel along both the X & Y axis.

I did more research across the forum and came to the conclusion that it’s essentially expected behavior that the Laserboard is locking the steppers when I plug it in because of the board having it’s own power source. I also disconnected the 5V and 24V wires from the LPSU to the Laserboard as several posts indicated they are not needed. I also found out that there is a software release button in Lightburn to unlock the stepper motors. So it seems that all is well now? I think I was in a bit of a panic yesterday when composing/troubleshooting.

Unless the Laserboard/Lightburn are supposed to release the lock when Lightburn is powered down? I don’t unplug/switch off the Laserboard as I’m trying to hide the ugly wiring bits behind the cabinet.

Here’s the SD card…the copy file was made by me before I made my modifications.

Yep, with auto-homing disabled and after powering on the machine, the head does NOT lock.

Software buttons all function as expected, and once I unlock the head utilizing the software “Stop” button, I can move the head.

  • “Here is the result of M119 when no switches are being depressed”
    X_min:0 Y_max:0 Z_min:1 pins- (X)P1.24:0 (X)P1.25:1 (Y)P1.26:1 (Y)P1.27:0 (Z)P1.28:1 (Z)P1.29:1
  • “Here is the result of M119 when the X switch is being depressed”
    X_min:1 Y_max:0 Z_min:1 pins- (X)P1.24:1 (X)P1.25:1 (Y)P1.26:1 (Y)P1.27:0 (Z)P1.28:1 (Z)P1.29:1
  • “Here is the result of M119 when the Y switch is being depressed”
    X_min:0 Y_max:1 Z_min:1 pins- (X)P1.24:0 (X)P1.25:1 (Y)P1.26:1 (Y)P1.27:1 (Z)P1.28:1 (Z)P1.29:1

I think I did it right…no stops the head is in the middle of the machine, X reading the head is to the far left of X gantry, Y reading the gantry is pushed all the way to the back of the machine?

Wow, thanks for your help in this and the attention to detail!

Hi John,

It sounds like you have everything in order.

Correct. If they are disengaging when the board is powered off, then you are good to go. If you are not powering down, they will remain engaged if you’ve previously sent data to the laser. Glad you found additional information to help.

Everything looks good in the photos. These come “pre-disconnected” out of the box, but it does not hurt to disconnect them.

Your SD card looks like it’s formatting properly, so this is good. It sounds like everything is moving properly and your endstops are engaging as expected.

You’re welcome! Glad you got it worked out!