Windows Stopped seeing the board and loading the Smoothy driver

Machine: _K40

Board: _Cohesion 3D

Firmware:Cohesion3D LaserBoard v0.2

Problem/ Question:
You guys sent me a new board after having a problem where the USB would not connect at all back in August. I got it working and finished up a project.

Link to old thread.

The laser has been sitting off for a while but when I tried to go in and use it today I am getting an error in Windows “USB device not recognized - The USB device you connected to this computer malfunctioned and Windows does not recognize it”. Unlike before, the device is at least showing up in the device manager but says “Unknown USB Device - Device descriptor request failed”).

  1. Lightburn said there was an update so I updated to 9.16. No change.
  2. Tried loading the FTDI drivers that was an option in loading the Lightburn software. No change.
  3. I tried flashing the SD card and putting on a new copy of firmware but no change.
  4. Checked the status lights on the board. The LED lights on the board show all normal.
  5. Tried different USB cables. Swapped with the one I know was working with my printer. No change.
  6. Everything comes up on the LCD screen fine and can manually home and move gantry with control nob.

One more thing I tried and didn’t work is hooking it up to my Mac instead of the PC. No luck.

Hi Andrew,

Sorry to hear that you are having issues again. Thanks for providing details about what you tested - very helpful!

To confirm, when the device is connected - it does not show up in Device Manager (PC) or System Preferences > Network (Mac)? Can you share screenshots (no cell phone pics, please) of what you are seeing?

Did you happen to install any of the Smoothie drivers previously (i.e., smoothieware-usb-driver-v1.1.exe)? This can cause an issue with Windows 10. If you have any installed, try uninstalling: http://smoothieware.org/windows-drivers

Everything you’ve mentioned points to a USB communication/port issue, driver issues on your computer(s), or electrical interference. Have you gone through all of the steps in our USB Dropouts and Brownouts guide?

I also tried to connect it to my Mac as well, which used to work fine. Please note that the device was working when I first got it then stopped. The PC attached to my laser is only used for the laser so no other software etc. has been loaded or run on that machine. The only changes might have been a Microsoft operating system update. Attached are screen shots of what is coming up.

Sometimes the firmware files can become corrupt. Check that your SD card is flashing properly in FAT32 format and shows firmware.bin formats to FIRMWARE.CUR afterwards when you insert it into your computer to view the contents. Can you provide a screenshot of the card contents? Try this with a different SD card. Did you load the files from this location? https://cohesion3d.com/knowledgebase/laserboard-firmware-config-stock-files-on-memory-card/

I have tried 2 different SD cards, both the same. They were formatted with the official SD card formatting software.
Screen Shot 2020-10-14 at 6.07.04 PM

Getting kind of frustrating here. I had to put back in my old K40 Chinese board and now I can’t use Lightburn.

Hi Andrew,

We understand your frustration and are working to help get this resolved with you. Your patience is appreciated while we were thoughtfully reviewing your concerns to determine a root cause.

Thanks for verifying this. I suspected as much because you were getting the proper LED status lights, but I wanted to confirm.

Code 43 usually means that the Windows driver has lost communication with the drive or the driver has crashed. Have you tried uninstalling and reinstalling the drivers?

  1. On your Windows machine, go to Device Settings > COM & LPT.
  2. When you plug in the device, is a USB Serial Device (COM#) appearing in the list?
  3. If so, right click and go to Properties. Are you seeing any errors?
  4. Go to the Driver tab and update the driver.
  5. In Device Manager, go to Universal Serial Bus controllers.
  6. Find the “Unknown USB Device (Device Descriptor Request Failed)”
  7. Right-click and “Uninstall” it.
  8. Reboot the computer and try to connect the USB again.
  9. Do you hear a ding and/or get a prompt that the computer is attempting to set up the device “Smoothieboard”?

Something with the setup appears to be triggering the COM failure. If none of this works, it’s likely that the USB port was damaged by an environmental issue. Check the continuity on the machine and look for any possible grounding issues that may be interfering with the connection.

Other alternative solutions include:

  1. Connecting a GLCD Control Panel to the board, saving your laser files onto a memory card, loading the card into the screen SD slot, and processing jobs directly from the laser.
  2. Trying to connect to the board via ethernet. The Ethernet Expansion header supports a single 3.3V supply. It receives a LAN8720 module, which can be found on eBay and Amazon.