When homing Y won't zero out

Machine: Ten-High 6040

Board: Had nano2 now Cohesion3D

Firmware: _Smoothie Updated stepper motor current to match my motors, updated bed size to 600x400 (I use inches in Lightburn so 23.622x15.748)

Problem/ Question: When homing X=0 & Y= 15.748. No matter where I set origins or anything I can’t get it to understand home is 0,0. Jogging the laser head around everything goes in the correct direction. Down is down, right is right etc. I’ve read somewhere about using an ! point on one of the Y axis settings but isn’t that going to make my stepper go in the opposite directions?

image
image



image

Hi Matt,

The standard setup has origin in the lower left (0,0). Most machines home to the top left where the endstops are triggered (0,200) at Home A. The max values will be higher, based on your bed size, but below is a visual for the most common setup:

You are telling LightBurn where 0,0 is located in your work area.

image

Make sure your Device Origin is set properly. In LightBurn, Edit > Device Settings and set the ‘Origin’ to the front left (lower) corner.

image

Also, you can set LightBurn to start at different job origin points or positions and even have it finish in the location you want versus going back to the machine origin point. More information: Coordinates and Job Origin

For the configuration changes to dial in the physics for your machine size, review our Larger Laser Machine Installation Guide. Power down the machine and remove the SD card and make sure it’s off when you reinsert it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.