Upgrade of MLE-40 with cohesion board

Cohesion3D LaserBoard
Cohesion3D LaserBoard Power Supply
LightBurn Software - GCode|
Connector Pack for Cohesion3D LaserBoard

I purchased the board to repair an old machine mle-40. I followed this guide to a t.

I have attached the images of the final install. It powers up. Has the light and the chime when connected to the pc. In both Mac and Pc the laser is not seen by lightburn. I downloaded the newest version last week. I am not sure which driver to use and how to troubleshoot the issue. I hope someone can help. I triple checked my connections and made sure there are no shorts. Only the top 4 connections are new. The rest are transfers with no cutting of the lines. Just insert and tighten.

I am looking for some guidance. I purchased the boards at the end of July and really need this machine working. Thank you again.

What version of Windows and Mac-OS do you have?

Did you try using the “Devices, Find my laser” function?

I have a Mac that is High Sierra and a windows 8 machine. I tried the search for machine in light burn. It comes back blank.
I tried just making a manual one. No dice.

I do get the usb chime when I plug it in.

Thank you for the help.

With your windows 8 Machine, install the drivers. For the Mac, we can go back to it if Windows works.

Excellent. I went ahead and rebuilt a Windows 10 machine. I reinstalled everything and attempted light burn again. It did connect. When I attempted to go “home” , I got this information in my console.

Waiting for connection…

Smoothie

ok

Homing

ok

ALARM: Homing fail

ok

[Caution: Unlocked]

ok

ALARM: Homing fail

ok


The first thing I did notice is that when I attempt the manual jogging on the attached screen. If I click the left and right it moves up and down. I assume that the wires for the x and y are crossed. Is that right?

Do I need to now go in and put the bed specs so that it knows the size of the laser bed? Any other configure you recommend to get me there? Thanks a ton for the help. At least I know the board and the joggers are working. Any final guidance would be appreciated.

I would recommend anyone here looking for the first answer to attempt. DO NOT USE WINDOWS 8.

Now unplug and swap each limit switch wire and plug them in one to the right, you have them plugged wrong. Most likely why it won’t home.

As shown here.
image

You also probably need to swap the stepper motor wires from the sound of it.

I believe I got it all worked out. I got it to home, and to correctly do X and Y. It ended up being a mix of both images from the setup.

The last thing to troubleshoot is firing the laser during cut. When I make a square and run the cut command, it does the design, but does not fire the laser. Thank you again.

Can you provide some more photos of the two wires on the board that goes to the power supply? One good shot of the power supply and the board where the wires are?

I assume it is this set.

I also swapped the two plugs on the mle power supply as per the instructions. I will post an image shortly.

Here is the power supply on mle.

Can you get a better pic of the wire order at the power supply, I can’t see the color order where they plug in.

Also, there is a test you can do to determine if the firing is working correctly.

Send some lines as explained here: PWM tuning for Smoothie Firmware such as the G1 X10 S0.8 F600

The head should move while firing. A red LED “Laser Fire Status” in the bottom left corner of the board should turn on.

Tell us exactly what does and does not happen.

1 Like

Ok. I have the laser cutting, the head now goes to the correct home, and I can jog for alignment. I have one last problem. When I go to “frame” the design the y coordinates go in the opposite direction. That doesn’t make since the origin is correct. If I change the wiring for the y it no longer homes correctly.

The issue was the origin. I am now up and running. Thank you.

The only question I have had since getting it up and running is how to figure out my machine origin. When I run the frame, it does not seem to follow the layout in the software.

The origin is 0,0 which is the front left. You need to configure it on the board to know that it is there. Where are the limit switches located on your machine? What is the size of the bed?

Pictures help.

I did the tutorial for LightBurn, and it appears correct. When I run the frame. Command it looks correct, but when I cut, it does not cut from the corner as it is set. I do have the origin set to the front left. I will post some pics shortly.

Have any video of what it’s doing?