Strange disconnect issue

A post was split to a new topic: Post Editing Timeframe

Well, I changed the laser tube and all wires again - same problem!!! so it’s definitely a problem with the LaserBoard! I replaced it again with the old M2 Nano board and everything works fine. I’m really sick of trying solutions and spending money! For me it’s simple: if I use the M2 Nano and everything works fine, with old/new LPSU and old/new laser tube the problem is the LaserBoard.

Thanks to everybody that tried to help me but I think I’m going either to order a new Laser Board or go the Ruida way…

Ordered a Ruida 6442G and everything works fine, but I still would like to find out what is wrong with the cohesio3d laserboard so I also ordered a GLCD.

The strange thing is that if I run cgode from GLCD everything works fine, so the problem is only when I connect the board to the laptop. Any ideas?

Really hard to say at this point as earlier you indicated the LPSU resolved the problem but then it came back the following day. And at one point you indicated it worked fine if the Laptop was on battery power only. Then it seems that changed and began having the problem regardless of how you had the laptop powered. You’ve done a lot of swaps and it seems the only things you haven’t changed are the Laserboard and power brick. I’m not sure how the warranty process works but I’d suggest you use the Contact form and see about sending the board in for diagnosis / repair if needed.

Alin, we know you’ve tried a lot of different things. (Thank you for persevering!)

At this point we might need an update on what is what. Do you have the LaserBoard installed in the machine, using the powerbrick, and running from the GLCD without USB connected? If you do that, does the machine works as expected? The laser fires, jobs complete properly, etc?

There are a lot of variables at play, so details will definitely help.

Pete, yes the board is now installed using powerbrick and works fine if I only use the GLCD. If I connect the usb cable to the laptop it disconnects and I can’t finish any job. It’s something completely random because sometimes it disconnects immediately after i press the start button in Lightburn. and other times it works fine for about 10-15 seconds and after that it disconnects, sometimes works fine for the whole program. I couldn’t find a pattern for this disconnects.

Like I said in previous posts I have changed everything in the k40 case except the motors. (new expensive usb cable, new LPSU, new laser tube, new wires for the buttons, motors and power). With the same setup, the ruida and the m2 nano work fine (maybe this controllers are built differently and the laserboard is more sensitive). But what I don’t understand is why it became so sensitive over time?

Tim S. - I bought my board from k40laser.se and I don’t know exactly but it seams like it’s out of business because everything is out of stock…

What happens if your laptop is on battery when you have it connected?

Same thing. (it doesn’t matter if it’s on battery or power brick)

I also tried with a different laptop and still disconnects.

Alin, let’s take the laser out of the mix.

If you keep the laser powered off, disconnect everything from the LaserBoard except for the USB cable, are you able to run a job from LightBurn?

While the job is “running”, you can watch the progress on the GLCD screen, and obviously LightBurn will show the “busy” progress bar.

Does the job complete okay, or do you still get a disconnect?

(You might need to try this with variations like: laptop on battery/ laptop plugged into power brick… LaserBoard installed in laser, LaserBoard removed and placed on non-conductive surface, etc.)

@raster Pete

  1. With every wire disconnected from the board except the USB cable and GLCD - job completes ok. (laptop on battery or main power connected)
  2. with the GLCD + USB cable + endstops, - job completes ok and never disconnects
  3. with the GLCD + USB cable + endstops + LPSU wires - job completes ok and never disconnects
  4. with the GLCD + USB cable + endstops + LPSU wires + motors - it disconnects randomly at the beginning or after a couple of seconds
  5. with the GLCD + USB cable + endstops + LPSU wires + only X motor - it disconnects randomly at the beginning or after a couple of seconds
  6. with the GLCD + USB cable + endstops + LPSU wires + only Y motor - it disconnects randomly at the beginning or after a couple of seconds

Also I found that pushing the laser test button, or switching the K40 power switch on/off, or plugging anything in the same AC circuit disconnects the board immediately even if it didn’t disconnect for almost a minute (with motors connected)

Seeing all this I thought the motors are the problem so i disconnected the k40 motors and connected 2 Nema17 motors I had from a older project. I placed this motors outside the K40 box . The board behaves the same!

Are you keeping a DVM monitoring the voltage from the power supply?

1 Like

I don’t know if my DVM is very good but tried measuring and it always fluctuates with about 0.1 V nothing special happens when the disconnect appears.

1 Like

I’m trying to connect my external stepper drivers to the board (maybe there will be less noise this way) but the question is: what kind of connectors are used for the external drivers and endstops?
It would be great if there was more info available about this board!

They’re JST connectors for the External Steppers and Cohesion3D sells a pack of them here:

The endstops are Molex KK and Cohesion3D sells a pack of those as well:

what kind? what pitch? sorry but i’m not going to pay Cohesion3D 15 $ for a 10 cent connector and some wires…

2.0 mm pitch, 6 pin. Here’s JST’s online catalog: http://www.jst-mfg.com/product/search_e.php?type=1&id=1&page=1

side note: jesus. could that website be any more 1996?

just wanted to tell you that I found a solution for this problem! :sunglasses:

The LaserBoard seams to be extremely sensitive to any kind of EMI so I built a copper box for it and it never disconnected for almost 2 weeks !

1 Like

Just a quick note before this thread closes,

I had a ‘similar’ issue after adding a second power supply (for new 24v bilge blower). Not as bad as what has been detailed above, but a similar disconnect problem. And, with the blower functioning, the laserboard would not connect at all. My solution was to plug the connected PC into a separate AC circuit and it’s been ok so far (I’ve only used it a few times).

After seeing the solution above, I’m going to try some shielding over the board and see what happens.

Thanks :slight_smile:

Connecting the board power brick and laptop to a different AC circuit is a MUST! Anyway, just as a last conclusion, if you run a laser cutting/engraving business go for something like a RUIDA (not really a plug& play for a k40 but much much reliable).
The Cohesion Laserboard is ok-ish for a hobbyist but I wouldn’t recommend it if it’s the only board or the only machine you have because you’re going to loose money.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.