Strange disconnect issue

Machine: K40

Board: Cohesion3D LaserBoard

Firmware: Latest Smoothie

Problem/ Question: The issue came up about 2 weeks ago: the board started to disconnect only when engraving (about 5 minutes after start). Then started to disconnect also when cutting and now it disconnects in the first second after starting a job. I didn’t change nothing in the wire connection, and it worked perfectly in the last year. I have noticed that the LPSU makes some weird sounds when cutting (like a click but high pitched) Could this mean I need a new LPSU? Any ideas?

tks.

If you are having disconnect issues, the first thing to try is another USB cable. If you are using the one that came with the K40 they are notoriously poor, and often the cause of disconnect issues.

This is also a good resource:

If you swap out your USB cable for a good quality one and still see the disconnect issues we can try to further diagnose things…

I don’t use the cable that came with the k40 I know that cable is crap! If it was a cable problem it wouldn’t have worked for almost a year and then suddenly disconnect. Anyway, I tried with another 2 cables and the problem is still there.

Okay, it’s always worth asking about the USB cable to start with. Can you post some photos of the LaserBoard, laser power supply, and wiring between them? While you’re getting photos it’s worth checking for any wires that may not be secured properly. You can always give a light tug on them to make sure none have come loose.

I checked all the connections, I reconnected the wires on the laser tube (I wanted to be sure that there isn’t any imperfect contact).

I don’t know if it’s ok but I tried testing like this:

  1. I disconnected the 2 wires from the LPSU to the Laserboard. I started a cut program in Lightburn. It ran ok .
  2. With the LPSU disconnected I ran the cut program and started to press the laser test button. Almost every time I press the laser test button the board disconnects and the laser head goes to home. So the issue is reproduced only when the LPSU starts/ stops the lase tube.

The grounds in K40s are notoriously bad. I know you said you went through a bunch of the connections, but pay special attention to the grounding lug at the back of the machine. Make sure all the screws are tight - especially the ones securing the Laserboard and the LPSU. A bad or intermittent ground can cause all sorts of “fun” problems.

It might also not be a bad idea to run a wire from the grounding lug to something that’s actually at earth ground potential to see if that helps.

Another thing you can do is reroute the high voltage wiring (going to the tube) as far away from the mains and low voltage wiring as possible.

I rerouted most of the cables and now the high voltage wire is kind of separated from the other wires but the problem persists. The board disconnects and reconnects immediately after the laser starts firing.

Could you shoot a video of this behavior and post it? Maybe if we hear the sound it will help us figure out what is going on.

I don’t know if you can hear it very well because of the LPSU fan noise. There are some clicks from time to time. I set the laser to cut a continuous line and it clicks randomly while cutting. The sound is now more low pitched but sometimes it’s really high like squeaking. I stopped the video when the laser went to home position without finalizing the cut.

link to video: https://bit.ly/3a8SziW

The only intentional clicking I am aware of with my LPSU is the actual “arming” (presumably a relay) inside. I hear a click, and I am not sure if it is because of the background noise, but a relay gives a more distinct click. Anyways my point here is that I would hear this if my water pump was turned on/ off - there is a water flow sensor, and if water is not flowing, it will turn off the LPSU. This is also on a higher end K40D with an upgraded LPSU, so perhaps it is not relevant, but could still be worth checking.

As far as the root issue being discussed, if you suddenly have a board disconnect every time your LPSU kicks on/ laser fires then you need to investigate your machine wiring, grounding, and even the AC wiring.

For example, the LaserBoard has a power brick - does this plug into the same power strip or wall outlet as the laser itself (with LPSU being part of the laser)? Try plugging the board power into a different outlet entirely, see if the issue persists.

The laserboard power brick is plugged in a different wall outlet (it has been like this since the beginning). I see most of the opinions are about grounding and connections. The question is: what about the laserboard grounding? Should it be somehow connected to the main ground of the case?

I installed the old M2 Nano board and it works fine (not a single interruption in 2 days) Seams like the Laserboard became extremely sensitive in time or there is something broken on the board… i don’t know what to check next. Any Ideas?

1 Like

I see that there is very little support for this board… Can someone please tell me if the board should be grounded or not? If yes how can I do it? Tks.

Hi Alin,

I do apologize for the delay in responding. However, please note that we are in the middle of a global pandemic and life is crazier than usual for many of us. I hope you are ok.

While the LaserBoard is designed to be electrically isolated on the board itself, and it should not make a difference, you can try removing it from the metal frame of the laser, and see if that makes any difference.

So the exact opposite of what you are asking. Have the LaserBoard on a piece of plastic/ cardboard/ wood and not on the metal case.

Please let us know if that changes anything. It shouldn’t, but it is worth checking.

I tried removing the Laserboard from the laser case and now it’s outside. The issue is still present… Sometimes it disconnects when the job starts and sometime it works aprox 30 sec and then it disconnects.

  • I rechecked all the connections and wires and soldered the wires to the switches so there is a perfect connection.
  • I added a EMI filter
  • I checked the grounding with the help of a electrician.
  • The LPSU and Laserbox, now run from a pure sine wave UPS.
  • I changed the motor wires with high performance braided & shielded wires.
  • Changed the endstops to mechanical ones with shielded wires.
  • The USB cable is top quality (golden connectors, double shielded and with ferrite chokes)
  • The laptop only runs on battery, just to be sure no noise will come through it’s power
  • I reconnected the laser tube wires + new silicone (just to be sure that there will be no arching)
  • Took the power supply cover off and cleaned the dust and also ran the laser with cover off and I didn’t observe any arching from the flyback transformer.

The strange thing is that with the M2 Nano Board and K40 Whisperer everything works fine.

Except the laser tube and power supply I changed everything in the K40 box! I really don’t know what to check next…

Have you checked the voltage of the power brick? It should be 24V or slightly over.

I agree with most in possible grounding issue. If I read your comments correctly you had disconnected the Laser Fire & Ground from Laserboard to LPSU, ran a job from Lightburn and it went fine until you manually depressed the test fire swithch. If that’s correct the only thing connected at that point to the Laserboard is the USB, Power Brick, End stops and Servos (unless you have optional accessories) in which case I’d disconnect them for troubleshooting purposes.

With the Laserboard using it’s own dedicated power supply there shouldn’t be noticeable grounding noise unless there is a grounding issue somewhere. But if the Power Brick is beginning to fail you may be low voltage to begin with, even if plugged into a separate outlet the draw from the LPSU when laser is fired may cause a hiccup if those outlets are on the same circuit breaker.

You might try leaving the board outside the case and disconnecting both servos on the Laserboard and the Laser fire & Ground to the LPSU so you only have the Power Brick and USB connected to the Laserboard. Setup a job in Lightburn and start it then manually depress the test fire switch. Nothing will move obviously but if you get an error when depressing the test fire switch it’s most likely not due to noise from the Servos, End Stops or Laser Fire & Ground. If it doesn’t error plug 1 servo back in and test again, keep adding connections 1 at a time to see if you can focus in on which one is causing the problem.

Actually after reviewing your images more closely it looks like you may have connected the Laserboard to the wrong pins on the LPSU. From the Laserboard the Laser Fire pin should go to the LO pin on the LPSU and the Laser Gnd pin should connect to the Ground on the LPSU. Unless you have a different LPSU than I’m familiar with those pins are usually pins 1 & 3 of connection 1 (furthest right) and counting from the right.

Normally the LPSU connector is:
Pin 1: LO
Pin 2: 5Vdc
Pin 3: Gnd
Pin 4: 24Vdc

It looks like you have Laser Fire from the Laserboard connected to Pin 2 which is 5Vdc and it looks like Laser Gnd is going to Pin 4 which is 24Vdc.

5V and 24V from LPSU is not used on the Laserboard connection. You might want to review your connections and verify what pins you are connecting to from the Laserboard to the LPSU.

Thanks for the help Tim! I must have been in a hurry when I took that photo but the wires have been changed since then and they are connected correctly. I double checked.

I tested the board like you mentioned in the earlier post.
I disconnected all the motors/endstops/ laser fire and ground from the Laserboard. and when I fire the laser the board still disconnects if it’s in the same room with the laser. The power brick voltage is 23.7 V

Then I moved the laptop and Laserboard in other room and the disconnect only appears if I plug the charger in the laptop. If I use the laptop on battery, the board works fine.

I talked to a electrician and said that this could happen if the LPSU generates noise and sends it over the whole circuit. Is this correct? What can I do to stop this happening?

Thanks

You could try powering your notebook from a separate circuit that’s on another circuit breaker in your residence / shop. I don’t know if that will change anything though if your LPSU is leaking over to the AC. IDK what the pass / fail voltage is for the Laserboard but I’d think 23.7V would be adequate. Ray or someone from Cohesion3d can most likely answer to that. Mine reads 24.2V.

I’d be interested in knowing if you have the Laserboard (with only USB & Power connected) in the same room with the laptop on battery does it still disconnect? If it does then your talking about RF interference and I cant imagine RF being a problem so I don’t think it should matter which room it’s in if the laptop is on battery only.

Since it seems to work when the laptop is on battery I assume the electrician you spoke with is suggesting the LPSU is putting noise (feedback) on your residential / business AC circuit.

So if your leaking voltage from the LPSU into your AC and it’s only disconnecting when your laptop is connected to 110 I’d probably replace the LPSU. I’d double / triple check all the grounding again first though. You can get a new LPSU from Ebay for around $40, just make sure to get the right one for your existing connectors.