Stepper Motors "stall" when attempting to jog laser head in initial setup/piece-by-piece testing

Machine: SmartDIY Fabool CO2 Laser - open source framework

Board: _custom PCB based on GRBL, uses STM32F205 IC as main CPU, output is controlled by STM32, laser power is adjusted by PWM - see details @ https://hackaday.io/project/161666-open-source-co2-laser-cutter

Firmware: stock board is GRBL-based “I have a new board and I’m using whatever it came with” is also a great answer!

Problem/ Question: Please provide a detailed description and pictures of your machine/ board/ wiring.
I’ve wired stock/pre-existing connections as followed my new cohesion3d board:
-limit/stops - connected the 4 existing end-stop JST ends (two-wire only) to signal + ground pins on C3D board
-laser power - stock 3-wire JST (wire colors: white, black, red) - connected white to laser signal & black to laser ground on C3D PCB - any ideas where/how to wire the red laser power wire? currently there’s a magnetic door open/closed safety setup.

-stepper motors - 4-wire (technically six pins within stepper motors) - using multimeter checked for resistance to identity the pair of wires to separate winding (2) and initially just inserted the wire JST female plug to C3D board male pins labeled for X-axis, hoping they match the “B2-B1-A1-A2” orientation noted in a PCB diagram found in this forum. In testing just this initial part of my hardware/wiring process for correct connection every configuration, change in wiring config for just this connection either results in the motor making noise, small jerks on x-axis but seemingly stuck with opposing forces.

This result was recreated in my connecting of the two stepper motors on the y-axis. For y-axis i shifted the top to “MAP” jumpers to the left to mirror y-axis output to a-axis output (per blog article cited below).

I can provide more pictures as well as documentation from the original PCB wiring info specific to this setup. a blog post I used for helpful tips that documents the upgrade of this machine with a cohesion3d board was: https://www.sodesne.com/blog/2019/6/23/smartdiys-ds-laser-build-and-upgrade

any ideas about resolving the stepper motor lock-out issue?

thank you all

What model stepper motors do you have? If it’s locking up it sounds like one phase may be connected and another not connected. Without seeing what’s going on it’ll be hard to help.

Hi Joe,

Pictures will be good, please show the electronics and how the board is wired up.

Have you made any changes to the board’s config file yet?

In response to questions:

  • Stepper motor model - JK42HS34-1334AC - https://jkongmotor.en.alibaba.com/product/60065855190-800892390/Reprap_3d_printer_Nema17_Stepper_Motor_model_JK42HS34_1334AC_with_Single_Flat_ROHS_CE_ISO.html
  • See link or attached datasheet schematic below
  • As far as I can tell – based on using multimeter to test resistance and using simple test using an LED connected to the pins and manually turning the motor producing light on LED, the phase wires are paired correctly. trial and error of swapping pair polarity on board while issuing ‘jog’ command on both X & Y axis didn’t change the ‘locking up’ result.
  • No changes have been made to firmware.
  • Only changes to board have been shifting top two “MAP drivers” jumpers to the left. The intent of this is to map Y (right Y motor) to A (left Y motor). I’ve seen conflicting information about this config.

Attached are photos of the board as temporarily wired (grounded but not mounted).
Other info: inserting into windows PC the included C3D firmware SD card shows firmware data is on sdcard, existing laser wiring (only ground + signal/fire wires; positive/red wire not connected) connected to power supply relay; existing endstops (4x) connected to signal + ground pins

Thank you!

stepper%20motor

Googling suggested your motors are rated at 1.33 amps.

You’ll want to set the motor currents to 1.2 amps in the board’s config file on the memory card. Then try jogging again. You can jog by using commands such as G0 X10 F600 where 10mm/s is a very reasonable speed. This should get you moving instead of grinding. Keep an eye on the motor too make sure it doesn’t get too hot. But it should be ok and for a moment is fine to see that the motors are moving.

I met the guy from sodesne at ERRF and we talked. I saw the pic of how he set up the drivers slaving. Move the 3rd jumper over as well. Long story.

By the way, even though you’ve slaved the 4th driver, it still gets its own current setting in config, so you’ll want to set alpha, beta, and delta currents to 1.2 in the config file.