Stepper motors not moving

I have the digital k40.When you go to devices it will show my smoothie but when you try to find the device again it can’t find it. The stepper motors will not move with a command on light burn. It tells me waiting to connect, smoothie, ok, home, ok. I click on home and it won’t home, I click left or right and nothing moves
with the command. I have tried 3 new usb cables nothing. I have searched the forum and nothing works. The only thing I found was the board won’t work with a Digital K40. This should not be hard to do. Here is my Order #21911IMG_0347

IMG_0357 IMG_0358

I just added this board to a k40 with digital control. Works fine. When you power on everything, do you hear like a whistling or high pitched sound coming from the machine? The separate power supply looks like it’s plugged in correctly as you’re getting the lights on the board

Also, I know it says “auto” but are there any COM ports listed when you click on that drop-down menu?

Yes I have com port 4 but that don’t work either. I don’t hear any whistling or high pitch sound.

Also you can’t move the stepper motors by hand so that’s telling me that they are getting power

What version of Windows are you running?

I have windows 10

OK, first and foremost, let’s try a couple basic things.

  1. Make sure you have the (correct) COM port manually selected. We’ve seen very, very rare cases in the past where this has been problematic, but we’ll rule out the auto variable this way.
  2. Make sure the SD card is fully seated in the socket.
  3. Verify the LED status on the board, following the procedure in this post:
    Cohesion3D Board Indicator Status LEDs
  4. From the gCode Console in Lightburn, please issue the M119 command and report back if you get a response, and if so, what the response was.

With the above steps completed, we should be in a better place to help troubleshoot this.

Side note - if, in the future, you could ensure your photos are in focus and clear, it’d make it a lot easier for us to see what’s going on :slight_smile:

Ok M119 tells me ok L4 is on
Sorry about the pic

I’m confused one part say L4 should be off and then one part say L4 should be on ???

For the LEDs, you’re looking for the pattern under the, “Normal Operation,” heading in the link above. Is that what you’re seeing, or are the LEDs doing something different? Please tell us exactly what each LED is doing, as described in that link.

As far as the M119 command goes, please show us the full response you get, we are looking to see if you get something like:

X_min:1 Y_max:1 Z_min:1 pins- (X)P1.24:1 (X)P1.25:1 (Y)P1.26:1 (Y)P1.27:1 (Z)P1.28:1 (Z)P1.29:1

The more verbose you are with your responses, the better a picture we can get about what’s going on in your setup :slight_smile:

3V3 Solid Green
L4 Solid Green
L3 Blinking Green Fast
L2 Blinking Green Fast
L1 Solid Green
Here are two pic one on com 4 and one on autoIMG_0361 IMG_0362
This is all I see when I put the Command M119 in and hit enter

It looks like Smoothie is unable to read the config file from your SD card, at first glance. Can you put the SD card in your computer and see if the files config.txt and FIRMWARE.CUR are currently on it? If either of these are missing we’ll need to replace them.

This is what’s on the cardIMG_0363

This is what I see when I it home or try to move the y axisIMG_0364

I got it working we have a bad sd card. So how do I get it replaced?

Very disappointed that once I figured out the problem all responses stop. I have a bad sd card and asked how we could get it replaced
Again no response.

According to this, the computer does indeed see files on the card - is my understanding correct?

I personally flash all the files on the card, so it worked here.

Now, the files you show there do look weird, perhaps it would be worth formatting it (FAT32) and putting fresh files on it: LaserBoard Firmware + Config Stock Files on Memory Card and follow the instructions for flashing in the Cohesion3D Board Indicator Status LEDs article from before.

All that said, a new memory card costs a few bucks.

The delay in responding is my fault, I meant to update the above files link with the new cluster firmware version we are now shipping and then respond. I have not done that yet and overlooked this.

Unfortunately everything is taking me longer right now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.