Stepper Motor and "heavy" Z-Axis? Cabling suggestion?

external-stepper

(Klaus Zimmermann) #1

Hi Guys,
my Y-Axis is powered and wired to a external stepper driver to the C3D LaserBoard.

  1. Now I have another (a second) external stepper driver left and I want to know if I should go for the X-Axis or the Z-Axis?
    I ask this, because the Z-Axis (movable bed) weights 5kg and is attached on 4 sides to a trapezoid thread rod.
  2. Is it more clever to put the external stepper with the motor to the “heavy lifting Z-Axis” or doesn’t it even matter at all?
  3. And if I connect a stepper motor directly to the board, do I have to use the green connectors behind/infront of the 4-pin connector?

Thanks for helping :smiley:
sportklotz33


#2

You should use an external driver for the Z axis, of course.

If you connect a motor to the board directly, you can use either the 4 pin header or the green screw terminal, whatever is more convenient. It is the same electrical connection.


(Isaac Barbary) #3

Definitely put the driver on the Z-axis. Turning those lead screws is a significant load. Swinging the laser head back and forth on the X-axis, not so much and it is well within the capabilities of the Laser Board to drive that motor.


(Klaus Zimmermann) #4

Thanks Buddies!
I will “build” my setup then just like this.


(Klaus Zimmermann) #5


Question: The “L” “N” and “GROUND” on the PSU are clear… but how do I connect the “GND” and “VCC” on the stepper driver to the PSU? One in “+V” and the other in “-V”

Sorry for this stupid question, but I just want to be safe!

Thanks a lot!


(Anthony Bolgar) #6

It is GND to V- and VCC to V+ .


(Klaus Zimmermann) #7

Sounds good so far.
I connected everything and my 24V PSU stars and my GLCD + LaserBoards starts. All is fine.
When i try to jog around a bit to test the motors they are “moving” but only if they are connected directly to the LaserBoard (X-Axis and Y-Axis near those green connectors).
The DualShaft Motor that is connected to the Stepper Driver to the board doesn’t jog.
I can hear the motor is doing a little noise (maybe that’s the power) but it doesnt move.
Whats wrong here?
I just noticed that both LEDs (PWR & ALARM) are on.
Here is a screenshot of the 24V PSU regarding the specifications - maybe there is a mistake?


(Anthony Bolgar) #8

Sound like you have the motor that connects to the external stepper driver wired incorrectly. You need to make sure that you have the correct pairs of wires connected to the AA and BB connections on the stepper driver. To determine what wires are needed, diconnect the stepper from the driver, and try to rotate the shaft. Then short out any 2 wires, if the stepper shaft gets harder to turn, then you have found a pair, and by elimination, the other 2 wires are a pair. If it does not get harder to turn try again with a different combination of wires until it does get harder to turn. Then reconnect to the stepper driver in the correct order.


(Klaus Zimmermann) #9

I already disconnected the motor from the stepper driver.
I found out that, if I connect the stepper driver only to the 24V PSU the PWR and ALARM LED still lighting up.
So does the stepper driver get too much Ampere from the PSU?


(Anthony Bolgar) #10

It will only draw what it needs.


(Klaus Zimmermann) #11

Ok I understand.
But why are the red and green LED lighting up?
Nothing is connected to the stepper driver… its only connected to the PSU… this is weird???


(Anthony Bolgar) #12

With nothing connected it does not have the control signals to tell it what state it should be in, so that may be why the alarm light is on.


(Klaus Zimmermann) #13

I had it connected to PSU only… both LEDs on
I had it connected to PSU & Motor (with matching pair cables) … both LEDs on
I had it connected to PSU & LaserBoard & Motor … both LEDs on
I had it connected to PSU & LaserBoard with no Motor … both LEDs on
None of the scenarios will only light up one LED or even will bring the motor to turn.

I am luck cause I have another stepper motor here, but this motor shows the same “Error”.

So its maybe an PSU to Stepper Driver Issue?


(Cliff Bryans) #14

Have you tested to make sure you have the stepper wired correctly as Anthony had suggested above?


(Klaus Zimmermann) #15

I wired the stepper driver to the LaserBoard exactly as shown here:


The stepper driver and the cables are originally from C3D.
I try this evening again to check where the failure might be, as every single component seems to “work”.


(Klaus Zimmermann) #16

I made some more photos of this situation.
I checked the 24PSU and its fine. LaserBoard runs fine. GLCD runs fine (I can jog around the X-Axis and the Y-Axis. They are connected directly with their 4-Wired-Cable to the LaserBoard.)
The DualShaft Motor (2.5A, 1.8° is making some noise in its housing when its connected to the stepper driver). And last but not least the stepper driver still on a red and green LED.
Not sure what else I can try or what kind of cabling I should check -.-


What about the switches on the stepper driver? Could this be an issue?


(Cliff Bryans) #17

As you have not stated as such, have you confirmed your wire pairs on your stepper motor.

Please test the wires as you can not assume wire colors are correct.


(Klaus Zimmermann) #18

Yes I did this exactly as @Grumpy_Old_Man described. . The Black and Green wire are one pair and the Blue and Red wire are one pair in my scenario.
Does it matter, if I found the correct pair, which of those wires is connected to A+ or A- / B+ or B- ?

Is it possible that the 6-wire cable from C3D needs to be connected differently to the stepper driver?


#19

Try to plug the 6-wire signal cable into a different ports like X or Y and try jogging those. Have you set the DIP switches on the external stepper driver? 1/16 microstepping and 1.0 amp are a good place to start.


(Klaus Zimmermann) #20

@Cohesion3D I just tried to plug the 6-wire signal cable into the X and Y port but still no rotating motor. I even tried different DIP switches settings… nothing. When I try to jog the first time, I can hear how the motor itself gets “powered” or something like that. And after that its making a very low constant noise.

How can I test, that maybe the motor is broken? How can I connect a 4-wire single stepper motor with red blue green and black wire to the stepper driver itself? Which connectors will be left blank?

Or should I open an new topic for this?