Smoothieware driver failure

Machine: K-40
Board: Laserboard large
Firmware: Smoothie

Problem/ Question: I have the machine wired up and I’m ready to go. Windows “dings” when connecting the USB from the laserboard to the PC (Windows 7 home premium 64 bit), but I cannot get the Smoothieware-usb-driver-v1.1 to install. It fails every time.
FWIW, the LED’s look like this, starting closest to the SD card:
-Solid green
-Flashing green
-Flashing green
-Solid green
-Solid green
-Solid red
I realize that the LED’s aren’t connected to the driver issue, but maybe it will be useful in getting this thing up and running if it has a different issue.
Thanks

You will need to manually install the driver.

http://smoothieware.org/windows-drivers

It will involve download the appropriate Zip from that page, which for Win 7 looks like the v1.1, then unzipping, finding the appropriate device in Device Manager and manually installing the driver for it, pointing to the folder you unzipped.

I just attempted that, it says “Windows could not find driver software for your device”
I set up a folder and it only has the smoothieware driver in it.

Please send some screenshots of your board and wiring, and a screenshot of what you just described so that I can take a look.

Driver%20fail


My

I see this on a different forum entry:

SOLUTION

step 1: download latest firmware
directions here

step 2: replace files on SD card

step 3: flash the firmware

step 4: connect USB cable to computer, let OS detect the new USB device.

step 5: open and edit smoothieware.ini
after comments “Vista-64bit Sections”
[DriverCopyFiles.NTamd64]

add line “usbser.sys,0x20”
save file.

I’m sure my firmware is probably fine, so I’ll leave that. Is there any sense in doing steps 4 and 5?
I’ve searched for “smoothieware.ini” but my PC can’t find it.

In your picture I see a black USB cable - I presume this at least isn’t the one that came with your laser? The ones that come with the laser are shit and can cause communications issues and perhaps what you are experiencing. You may still want to try another USB cable to rule out that as the issue. USB Cable should also be not too long - ours are 6ft.

Please follow up regarding the above first. Then, if still a problem:

It would not hurt to replace the files on the memory card with known good ones, then turn the board on and make sure L4 is on - that tells you it is seeing and reading the card.

Step 5 specifically seems to be the voodoo thing that he did that made it work, so yes, you’d have to do that to try that solution.

I can try a new USB cable. The one I’m using is a cable I’ve used for years for my cnc router, and I’ve never had trouble with it. Still, I can’t imagine that it has anything to do with my PC not loading a driver.
Do you know what he’s talking about in step 5? I don’t. I don’t know where that .ini file would reside. If I can find it, do I open it in notepad and make the changes? I don’t want to have to buy a new computer just to load the driver.

Tried a new USB cable with no success (driver install). I unplugged the USB cable and ran the install and it says it worked, finally. Re-plugged the USB, turned on the laser, opened Lightburn and it doesn’t connect through the finder or manually. Console says “waiting for connection”
Device manager has one com device with a warning. Tried to update software, got this:Update%20driver

Also, L4 light is solid green.

Update: With the USB plugged into the back of the PC, the computer will recognize the board as “Smoothie Serial” in Device Manager, with a (!) next to it. Even though I got the driver to install correctly (says Windows), I get this when I click on “driver details”:

So, I click on “update driver” from the same window, go to the folder with the driver, and get this:

Has anyone seen this?

Because this was so much fun, I hunted down a laptop that had windows 10 on it. Now I can run the laser 3 feet from my other computer. I guess I solved it.

1 Like