Slow engrave speeds

Machine: _K40

Board: _C3D NEW IN March

Firmware: _Apprantly newer version

Problem/ Question: Flashed card with new firmware and config file’s, thought I had this problem sorted but still persists,
1, Engrave photo on wood anything over 80mms ties the board in knots, starts hesitating as it runs its task, fast-slow as if it’s fighting to decode the code, ( ? ) can’t handle it tried all the different ones, Newsprint dither etc,
2, Raster engrave will not go beyond 400mms anything over same problem stutters and wanders offline, giving whatever I’m doing a jagged edge.
Video attached tried to show you what the led’s are doing anything else let me know,
Tried to email you back Ray but donotreply email address.
RIGHT HERE
Understand everyone is busy as I am myself, frontline worker,
Brian

Do you have the cluster mode enabled in Lightburn as well? It’s not just the firmware that’s dependent, here.

Go to Edit / Device Settings and make sure it’s turned on:

Yep sure have tried it with it on, and off totally no difference at all.
:+1:

Hi Brian, as I understand it, the main issue you are having is that your K40 is not running engraving (Fill) jobs as fast as you would like it to. Is that correct?

There’s a lot going on in your video, so it’s taking a while to work through it, but I’ll start with a few things.

Here is our Knowledge Base page which describes the behavior of the status LEDs.

From what I can tell in your video, it appears the the LaserBoard is indicating “Normal Operation”. This makes sense as you’ve indicated the board is working.

You mentioned the “play” LED blinking on and off as an indicator of when the laser is firing. You are correct in that assumption, that is what it does.

You said that you installed the latest Cluster firmware. Can you confirm that it flashed to the board properly? You can check that this by putting the SD card in a computer. You should see FIRMWARE.CUR instead of firmware.bin listed.

Your video shows the Device Settings window, and the Basic Settings pane looked fine. (I’ll note that you also showed the Additional Settings pane, but you should know that those settings are used to adjust the preview / simulation timing, and do not affect the controller.)

The video shows some of the settings screens for LightBurn, but I can’t correlate that with what the result of running a job is. Here’s a snippet:

I did notice you have Crosshatch turned on, and you’ve got the Lines per Inch at 259.18. These could be related to your issues, but without more specific information it’s hard to tell.

I’m wondering if you can provide a bit more info and clear screen shots showing and explaining things.

For example, below is a PNG file loaded into LightBurn showing the settings window for the job.

And here’s an SVG file loaded into LightBurn showing the settings window for the job.

Knowing what the source file is, seeing the settings, and the outcome of the job, will help diagnose things.

Cheers Pete leave it with me i’ll post soon as i get time next day or so.:ok_hand:

Ok gents here is a video of settings I’m using on some of the jobs when I line it’s fine Raster engrave is max 400mms, photoengrave is max 80mms, and on the sections that are darker it must process more information, and then it struggles to get the information or code through the board, making the laser gantry stutter and slow down, I have some spare time this weekend so will do some extra videos for you,
Click here


Angel%20job%20001

In general, the speed will be at 8mms and dpi of 404 as this is what I set the pictures to,
line is ok to fill no more than 400mms, I have been bumping it to 95mms but it still struggles with this speed, 85/90mms seemed ok but as it hit the bits with darker sections, it slowed the gantry down, I’ll video it doing this for you.
cheers Brian

Hi Brian, I was able to see your settings by watching the video, and I’m going to post them as images here so we can go through them. They’ll each have a number above them for reference when responding.

Image #1

Type: Image
Speed: 95.0 mm/sec
Power: 50%
Line Interval: 0.063 mm
DPI: 404
Image Mode: Newsprint

For an image like this, you probably are not going to achieve resolution of 404 DPI. You mentioned that some areas of your engraved images are filling in and appearing too dark. For an explanation of this, I recommend the post by Oz (author of LightBurn) about how resolution, line interval, and dot size of your laser (affected by focus, power,and materials) play into this.

The short version is, you’ve probably got your resolution (DPI) set too high to get good results, especially with 50% power on wood.


Image #2

Type: Line
Speed: 20.0 mm/sec
Power: 12.5%

For this one you’ve got the blue layer named FILL (which is fine, you can name it whatever you want) but you have the layer set to Line, which means it’s going to outline the blue text, not fill it in. Your speed and power settings seem okay for a Line layer.

The video did not show what the outcome of running jobs with these setting were, so if you have photos, that correspond, please post them.


Image #3

Type: Line
Speed: 400 mm/sec
Power: 50.00%

You have all Line layers, no Fill layers (though one is named infill). You are asking your machine to run a vector outline of something at 400 mm/sec. That is probably too fast to move and follow the black lines of the text with all the direction changes. How did this one turn out? Do you have a corresponding photo you can post?


Image #4

Type: Image
Speed: 95.0 mm/sec
Power: 50%
Line Interval: 0.063 mm
DPI: 404
Image Mode: Newsprint

Again, for this one resolution is set to 404 DPI, with 50% power. There’s a chance this could work with lower power if that meant a smaller dot size, but it would still depend on a number of factors. A 40 watt laser producing a dot size smaller than 0.07mm may be pushing it, and you’ve got it set to 0.063mm.


A few more things to mention (apologies for this long post!)

LightBurn has a variety of choices for the Image Mode, all of which give different results. It looks like you’re using Newsprint for all the settings in your video. You might want to experiment with other modes as well.

Finally, I’d recommend you make use of the Preview function in LightBurn. It can really help you visualize how your image might come out.

Here are two examples. For each you can see the image and settings, and then the preview. Make note of the DPI I have for the two different examples, and how it affects the preview.

Preview #1

Notice how the first example (above) set to 404 DPI is very dark. Compare it to the one below where the DPI is set to 254. It’s tricky. More resolution isn’t always better, especially if you consider dot spread.

Preview #2

I’ll add just one more link, to a discussion about understanding line interval/DPI for laser engraving. (There’s also a link to a great video that explains even more.)

I hope this isn’t too overwhelming, and that it has been useful. LightBurn and the LaserBoard are a powerful combination, and can produce great results, but it can take a lot of experimentation and trial and error to get exactly what you want.

@raster Awesome you nailed it buddy video coming up just uploading to youtube this evening, DPI was the problem, pics from before quality was not an issue just the speed, i’ll give more depth to the article when I get some time later.
Picture below are from before when it would only do 80mms, at 404 dpi

@raster hello gents here is the video for you to peruse, it took a while for it to upload to youtube for some reason so left it uploading overnight,
Thanks, Pete for the excellent help,
click here

1 Like