Skipping Steps on the X and Y

Machine: K40 ribbon cable setup

Board: LaserBoard_

Firmware: new board

So there is a couple of things here. Since I replaced the board both X and Y are skipping steps. Initially it only happened if I ran over 60mm/s and I was just assuming loose belts but after checking its not. Today the X stepper just started a high pitch squeal when it is stepper active but not in motion. I tried bringing up and down the run current to see if it would make a differences it did not. It both skipped steps and the X also still squealed. So from there I thought it could be the stepper so I took another I had laying around and plugged it into the X where the ribbon cable connects. The squeal went away but it was still skipping steps even under no load. If I went above 60mm/s and with a job that just ran the X back and forth one run would go ok but then the next it would skip half the steps and buzz. So I thought it could be the ribbon cable so I plugged the stepper into the Y and got the same results. So then I tried changing the run current on Y started at .3 and went up to .8 and I got the same results with each.

I am currently out of ideas on what else to try to attempt to narrow down the issue.

Hi Michael,

Welcome to the forum! I have upgraded your trust level so that you can now upload photos.

What is the model and what are the specs for your stepper motors?

Follow the steps in our Configuration Adjustment Guide.

  • If the acceleration is set too high, you will get “chattering” and/or missing steps on your stepper motors.
    • There are three main acceleration settings. One is global and the others axis specific.
    • You want the global setting to be the maximum of all three and the other two to be specific for what works best for your machine physics.

To reduce stepper motor noise, we also have an alternate Stealthchop mode you can run in, but it does not produce as much torque: Stepper Motor Noise and Stepper Driver Modes

Please try the config updates in the first guide and let us know if you experience any other issues. If the issue persists, it would be helpful to see images of the output from the laser for what you are testing.

The high pitch squeal would not have anything to do with stealthchop as the stepper is not in motion as it squeals and does not do it every time either. For example after you home and the stepper is engaged and holding it then has the high pitch. Stealthchop would only effect motion if I understand it correctly.
I did run try slowing down the acceleration all the way down to 500 with no change. I also went up with the amperage to 1.0 nothing seems to be changing. The steppers just seem much weaker than the old board. With the old board when the steppers were engaged and it was almost impossible to move the gantry. The new board take very little force like it has very little hold current.
I have not attempted to change the feed rate yet. I will try it that does not seem to be what the issue I am having is but will try.
The best way of explaining would be a nosey or underpowered signal to the steppers. The config does not seem to do anything. I set the current down to 0.1 which you would think it would not be enough to run but nothing changed and ran like it always had.

Please provide clear pictures of your machine, control panel, board, other electrical components, and wiring with the LaserBoard connected. We need to see how and where everything is connected.

Just figured I would share.

Has your problem been resolved? If not please read Starla’s reply and supply the needed information so that we may help you better.

It looks bigger on the inside! :slight_smile:

No I am still fighting it skipping steps at higher speeds.at this point I am lost. I went through the doc with no luck. If I replace the X stepper the buzzing goes away but I do not have one to reppace the Y laying around. I am thinking it is the steppers causing the issue at this point.

I was having the same issue, I turned down the acceleration in the config and that fixed the issue for me

Can you provide a photo or two of the output from the laser after you run the job that shows the skipping steps? I want to see the manner in which it is producing results.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.