Skipping and posoitioning "Out of Bounds"

Machine: K40
Board: Cohesion 3D Mini (Smoothie)
Firmware: _Smoothie
Problem/ Question:I had a “Skipping” issue on the X-Axis. After replacing the X-Axis belt (the machine was trying to go beyond the bounds of the machine and was chattering quite badly chewing up the belt), the system now seems not to be able to remember co-ordinates. I can usually call out various co-ordinates and the laser head will traverse to those points smoothly, how ever when I try to engrave it is a different story. On the most part it will start and then move more and more left until it hits the gantry and tries to engrave there just burning a dark line. At times when the laser head is moved to let’s say what is supposed to be X = 0, Y = 200, the get position command states the X = -40 (or some other number) and Y = 200. So the question is this, could this be a software (LightBurn) or something with in the control board, purchased and installed, but not used very much. This starter happening with no warning

Hi Mark,

Ensure that your origin is set to front left in LightBurn. Where are your limit switches located?

Start here and see if changing these settings in the config file helps, including reviewing the Bed Size FAQ referenced for more info: Laser Head Crashing into Gantry

1 Like

Hello Starla

Thank you for your reply, my endstops are at the left rear. I have run the M119 command in regards to my endstop settings and in both unpressed and pressed states the result show X = 1 and Y = 1. Also, in used the Jog command to find the limits of my bed and got the following results:

  1. At Upper Left I get a reading of X = -20 & Y = 230
  2. At Upper Right I get a reading of X = 250 & Y = 230
  3. At Front Left I get a reading of X = -20 & Y = 10
  4. At Front Right I get a reading of X = 250 & Y = 10

Is it possible that firmware of the memory board has become corrupted? Or the Config.txt file has become corrupted or both?

Again, when I use the move command, the laser tracks correctly, however when I run a engraving file it move all the way to the left and basically stays there.

Again, thank you

Mark

To be absolutely clear, the way you test the endstops is by holding the switch down while sending the M119 command.

You should have value 0 for each one when it is not pressed and a value of 1 when it is pressed.

Please confirm that you are testing it the way I said, and provide pictures of your machine, board, and wiring.

Hello:

In regards to your question. It does not matter if the endstop is depressed or not, I still receive a value of “1”.

I will have to attached the pictures one and a time, however I installed this new board about 8 months ago, and it worked fine. I stop engraving a few months ago (personal reasons), however when I went to start to engrave again, this is when this issue started.

Picture number 2

Picture number 3

Picture number 4

Hi Mark,

As best as I can tell from this picture, you do not have any endstops plugged into the board. There is typically a cable for that.

Hello:

Thank you for your reply. This does not answer the issue of when this board was installed everything worked fine. Then out of thin air that the unit is now misbehaving when trying to engrave?

Thanks

Mark

Ho

As a follow up, I found a connector that was not connected. I reconnected the connector and tries to cut a square, what I got was a rectangle. The Y-Axis seems to work fine, but the X-Axis will not traverse right to the stop point for the square, it moves a little then goes onto the next cut. I am now more convinced that thee is something wrong with the control board, in regards to sending a file for cutting or engraving to the Laser. The dimensions of the X-Axis (traversing right) are not recognized.

Mark

Yep. That’s an important thing to have connected.

By my count this is now the 8th time you have decided that there is a fault with the board or software, between Facebook groups and the forums.

Can I ask how you’ve determined that there’s a product fault, when by your own admission you’ve just found disconnected wiring that’s essential to the operation of the product? Because your insistence that there is a product fault, instead of providing actually useful information that we can use to debug, makes it much, much harder for me (the person that actually designed the board) to actually help you.

In order for me to be able to help you, please let go of your preconceived determinations such as “there is a product fault”, answer the questions I will ask you about your setup, and do the things I tell you to do one step at a time and without jumping around.

That’s the only way this can work. Feel free to give it some thought.

Cheers

Hello:

We both are becoming frustrated, so bear that in mind. I have worked with computers and light programming for years and as such I may have a tendency to jump ahead. As far the number of posts, being a newbie here I am allowed only one picture post at a time.

Thant being said, I am going to post some screen shots and hopeful a video of gantry movement, and the results of a line cut command, with the associated screen shot. Also, once the cable was re-installed the X and Y stops started to read correctly.

There are other issues in which I will state that lead me to believe that at the very least I have a corrupted “Config” file.

So, the first screen shot

will be in regards to the End-Stops: where neither X or Y are depressed.

I will have to enter the following pictures as separate posts via the restrictions of this group

This second screen shot is with the X end-stop depressed:

The next screen shot is where I have drawn a rectangle for a “Line” cut :

The next post I would like to have reviewed is a MPG file which shows the movement of the Laser Head to the lower left corner of the test cut. However , the system will not let me attach it. Do you have a alternate method in which I can send this file to you?

The last file is that of what the end test cut looks like:

Please understand, the number of posts is due the limitations placed on me. We can use the prior posts as a starting point. One thing though, with the unit resting at “Finished” Position (X = 0 & Y = 200) if I were to re-enter a Go To command of X - 0 & Y = 200, even though it is already there, the unit will try to move there and continue to “Chatter” against the End-Stops for a moment or 2.

Again, thank you for trying to help

Your Y page size is larger than 200mm - is that intentional? A stock K40 is only 300 x 200.

K40’s vary a fair bit on build quality, so you might need to increase the motor current and/or lower the acceleration if it’s skipping. You also haven’t showed the speed you’re trying to run this test cut, so that’s possibly an issue as well.

Hello:

The test cut is done at 350 mm/sec @ 35% power (Line cut). The unit’s finish position is at X = 0, Y = 230. Origin is at X = 0, Y = 0. The lower left of the test cut was located at X = 40, Y = 70. The actual test cut started and somewhat more on both the X and Y axis, and the last cut was from lower right to past lower left.
Thanks