Rotary Setup - Only Rotates ¼ Turn

I feel comfortable enough with the laser and would like to add some variety so I figured it was time to try to engrave mugs. Yesterday I cut the bottom of my K40 to allow me utilize the Cohesion Rotary attachment I purchased last year.

I have a Chineseum K40 with a Cohesion3D Laserboard installed. I have a Cohesion3D rotary with the small wheels installed and I’m running whatever GRBL firmware came on the SD card.

I read the documentation and most of forum posts that seem to apply to my situation and was able to successfully hook up the rotary to the A axis and get it rotate, but only about ¼ of a turn on an old test Yeti (36 oz water bottle). I tried to send the G0 A360 command from the console with the same result - ¼ turn. But then, interestingly or related?, it would no longer respond to the console command.

Here are my #A Axis settings:

delta_steps_per_mm                           17.77           # may be steps per degree for example
delta_step_pin                               2.3              # Pin for delta stepper step signal
delta_dir_pin                                0.22             # Pin for delta stepper direction
delta_en_pin                                 0.21             # Pin for delta enable
delta_current                                1.0                # Z stepper motor current
delta_max_rate                               6000            # mm/min
delta_acceleration                           150             # mm/sec²

The Yeti measures 11 ⅞" in circumference (flat sewing tape on outside) and I have the small wheels installed and set per the documentation I could find. Here are my settings in Lightburn:

Screen Shot 2021-02-11 at 10.34.08 PM

So, here’s the TL;DR
The rotary only rotates ¼ turn before coming back to it’s starting position. Any ideas on how I might resolve this?

Hi John,

Thank you for the helpful information! I was able to recreate the scenario you are describing. In case it’s needed, what operating system are you on and what version of LightBurn are you running? Which inches mode are you using in the LightBurn Settings?

The configuration file looks good. Your LB settings look close. The circumference of the object should be 11.875 for a 11 ⅞" measurement, but that shouldn’t be off enough to keep it from turning that much.

To Confirm:

  • When you use the “Test” button on the Rotary Setup window in LightBurn, it is only turning a fraction of the 360°?
  • When you initially send the G0 A360 command in the console, it behaves the same and only turns partially?
  • If you try to send the command again, nothing happens.

Try this and report back if it turns the full 360° after sending the negative command first:

  • Send the following command in the console: G0 A-360
  • Send the following command in the console: G0 A360
    Alternating these commands will allow you to move the rotary with consecutive commands.

Try a Test Run:

  • Use painter’s tape over your bottle to protect it, if needed.
  • Turn the power down on the machine so that it will only mark the tape enough to see results without burning through.
  • Create a rectangle in LightBurn that is as tall as the circumference and fairly narrow (ex: 11.875 in x 0.20 in).
  • Do the ends meet up when you do the test burn or does it stop before going all the way around?

Please share photos of the results, including your LightBurn screens (no cell phone pics, please).

I should clarify that when I mentioned the ¼ turn, that was for the cup - not the drive wheel. But now I’ll go point by point:

Yes, the drive wheel spins about ¾ to ⅞ of the way around and then returning to it’s starting position.

Yes, it turns the same distance, but then does NOT return to “zero”.

Correct, subsequent console commands have no effect, even though the console reports two “ok”

Sending the G0 A-360 command does move the drive wheel approximately 1-½ turns in the opposite direction. Sending a G0 A360 after that will move the drive wheel approximately 1-½ turns in the “positive” direction.

No, the ends do not meet up and there’s two other issues. When the cup is moving it’s sort of herky-jerky, not at all smooth like I would have expected. This causes an almost dashed line in the engraving. The second issue is the line runs “uphill” - I assume this is because the rotary is not completely parallel with the X axis?

BTW, the mug is 11-13/16", so I used 11.8125" as my decimal. Typo in the first post.

Thanks, John.

I appreciate the photos. I’m looking into this. Can you answer the other initial questions and provide screenshots of your LightBurn settings, please?

Sorry, skimmed right over that part. I’m on Mac OS 10.15.7 running Lightburn 0.9.20

I also just took a look at the gear attached to the stepper motor and when I test from the LightBurn rotary test button it spins 720 degrees. Not sure if that’s helpful, but thought I’d mention it.

Here are the screenshots:

Hi John,

Thanks for the additional info. I did some research and testing today and have a couple of observations.

Make sure the “Start From” drop down is set to “Current Position”. If I had it set to Absolute Coordinates or any other position, I would get an unexpected offset or not get a full rotation of the wheel. Make sure your head clears the rotary and move the laser to the origin point of the design with the pin icon (in this example, lower left).

image

In order to get a full 360° on the wheels, I had to bump up the delta steps per mm to 19.77 in the configuration file. There is some variation in the wheel ring thickness, so if you have calipers, measure yours, as that will need to be reflected in the Rotary Setup > Roller Diameter.

I added some steps to the process on the Rotary Setup guide to elaborate on how to test it and a Troubleshooting section covering things to watch out for. Try it out and make the needed config tweaks to get yours dialed in and let me know.

Thanks for the help Starla!

Not sure if I did, but I will in the future.

I too was experimenting with the steps per mm and landed in the 19.? range. I put your .77 in and the drive wheel does rotate the full rotation and back now. Thanks!

Using those settings I burned a few tests and found a slight issue. It’ll probably only come into play if I’m burning a full wrap, and as of now I’m not, but don’t want to rule it out so I’d like to get this sorted.

I have a Polar Camel 32oz tumbler I’m using for testing now. It’s 288mm in circumference and I entered that in the rotary settings panel. In Lightburn I drew a rectangle the height of my tumbler - 288mm. I then did a burn of that rectangle and it overlapped. I had to change the size of my rectangle to get the ends to match up, but that’s not ideal. I need to be able to measure and then draw. Looking through the Lightburn forum I saw a post by Oz that references drawing two horizontal lines “x” distance apart, where x=circumference, and the second should burn on top of the first. Tried that and it didn’t (as expected), so I tweaked the steps per mm setting until it did which resulted in 19.44.

But double checking the wheel rotation with my pointer reveals an ever so slight miss when testing from the rotary panel. I don’t have any other size tumblers to test on (but I might be able to find a dowel) to see if that setting is indeed correct. Is there any reason I just can’t leave it at .44 going forward?

Hi John,

That test is essentially the same as creating the long thin rectangle we tried and making sure the top meets the bottom. The main reason I recommended this test is because it sometimes presents other settings that need to be dialed in (like dashed lines / low power while rotating).

Like you mentioned, it’s really only apparent at that incremental level when you’re doing a full wrap, so the tape test burn beforehand is a good way to make sure whatever you’re burning is aligning as expected for an actual job (so you can edit it, if needed). What you have set is most likely fine for the majority of cases.

However, if you can get the full wrap dialed in, you shouldn’t have to change your setting again and it should work for everything you engrave on. If you have some, try cutting an empty paper towel roll in half to test it (you may want to avoid the glued areas while engraving). Use a very low power setting and weigh it down inside to keep it from bouncing around.