Rotary connection (older C3d)

Finally working at installing 3rd axis as rotary. No Z table,
All of the instructions refer to either adding a Z axis or both Z and rotary. I’m adding just the rotary.
I have my additional 24 Volt power supply connected and working, I have the extra driver that I bought along with the C3d. two green lights when I power up. Have (as near as I can tell) done corrections to the Config file.
Provided I turn off enable rotary;;,
When I hit “Home” it moves a little in both X & Y. I can draw a circle and frame it, it appears to frame the image pretty good.
I cannot get the rotary stepper to do anything, won’t lock up, won’t turn under it’s own power.
Ideas Please?
Fred

Follow on to rotary install (attempt).
Not finding a category of adding A (rotary) but not Z, I am assuming to choose the 4 axis X,Y,Z,A installation, and just not connect the Z stepper driver.
Modified the Config.txt as indicated on instructions, From link provided, found and copied the new BIN file to the Mini SD card.Connected everything and powered up. Got the C3d LEDs counting and then flashing as described.
Stepper A is power locked (slightly warm but not hot, X&Y free to move under light force. GLCD screen sometimes works and can jog X or Y from knob.
Test button is showing interference if I press the test button. seems to interferebetween laser and x&y
Part times GLCD screen shows correct, part time shows gibberish.
Have verified wiring exactly as pics show.
Need suggestions,
Fred

Progress of sorts, removed regular Z driver and plugged in the header feeding the external stepper driver to feed the rotary stepper. Can now click enable rotary and new stepper rotates as desired, while Y axis stepper stays locked, and X moves mostly correct.
Still having interference, when test button to fire laser is pressed, X moves in stuttering fashion in the negative X direction (to left), Higher power = more interference, and will cause system to lock up and GLCD usually shows garbled. With laser power at zero, can run cut command and motions are pretty much ok. I have verified wiring connections per instructions, I suspect software issues, A bit confusing on software changes config.txt.
Still need help.
Fred

Hi Fred.

Trying to get caught up on some support inquiries from the holiday break now. Happy New Year.

Can you show pictures of how you have all this wired up? Once we confirm that all looks good, I think some different firmware and config files should get you sorted.

No problem. I actually got it working. Gave up on adding just “A” axis for rotary. the instructions talked of adding Z OR Z and A. I ended up using Z to drive the rotary. Found the section on changing Config files. Once that was sorted out, we got it to work. S/till confused about compiling, what is it, do I need to do it (and how to do it).

I did have another interesting event, I had added a temperature controller (JLD612) set to break the small cathode wire. Everything worked EXCEPT as soon as I turned the Ma up to ~4 Ma. the X axis went bonkers stuttering to the left. I disconnected it from the temp control and it worked fine.

Would still like to understand the COMPILE part, what it is and what does it do?

Best Regards

OK, How do I upload a pic? LOL
Fred

There is an upload button in the post editor, or you can google for “discourse upload image”


This shoiuld show my wiring, mounted the C3d board on insulated standoffs, added bulkhead connector for rotary, attempted to neaten the wiring and make some sense of it.
Fred

“temperature controller set to break the small cathode wire” - Do you mean the cathode wire from the laser tube? That should always be grounded. Your laser power supply has a protection circuit (the “laser enable” switch on the main panel is normally connected to these terminals). This is the circuit you should break instead of the high voltage line.

Hi Loather, thanks for the reply, Yes that is what I had done, now it is correct with the cathode end as original. tying the temp control into the laser enable wire. Makes a lot more sense that way.
Thanks.