Rotary Axis setup

Machine: K40

Board: Laserboard

Firmware: Smoothie

Problem/ Question: I am having issues setting up my home built rotary. I have completed the setup based on the rotary document. Adjusted the steps/rotation and lowered the values as suggested. I am using Lightburn and also completed the rotary setup in Lightburn.

The issues I have is the A-Axis speed does not match the desired speed. It rotates slower then what the X-Axis is doing. It also seems to rotate pause and begin again when vectoring. It leaves dashes rather then straight lines. It looks like it is set to perforated but it isn’t.

The stepper motor I am using is a Nema17 with a 1.8steps with 20T gears on all three. I came up with 8.88 steps per mm. Is this correct?

What would cause the stepper to rotate while firing the laser, pause turn off the laser then start to rotate again while firing? It seems to pause when it reaches the corners and does not complete the corners.

  • Tried uploading a photo but is wont let new users upload.

You can post pictures now.

It kind of seems like you’re sending cluster data to a non-cluster firmware. When did you buy your board?

It was just purchased a month or so ago.

I tried swapping it to the Y axis, it connected the lines but you can see that it was pausing even if for a microsecond. It did speed up but considering the setting were not turned down it makes sense. But it wasn’t overly fast.

So looking at the stepper that was purchased, it’s rated at 1.5amps, could this be an issue? I do have a 1.0p stepper on the way to try.

So I tried the new stepper and it does the same thing. I also set it up in the Z axis and it works like it should but I can not adjust the steps per rotation so moved it back to the A Axis. It only does it when using a straight line along the Y-axis/A-axis. I can burn a circle or any other shape but a straight line is always dashed if burned at all.

Could this be a Lightburn issue? I don’t see any settings in Lightburn that would cause this though.

This is absolutely bizarre.

Can you give me some details about how you set it up on the Z port?

To run it on the Z-axis I simply plugged into the z-output. In Lightburn’s Rotary Setup there is options to seclect the output, it has Y-axis, Z-axis, and A-axis. It used the Z-axis but obviously the rotations were off, when you run test it is supposed to do one full rotation and it complete multiple. But I simply wanted to see if it would burn a continues line which it did.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.