PWM Output not matching lighburn Max Power % when Laser Off

Machine: K40
Board: LaserBoard
Firmware: “I have a new board and I’m using whatever it came with”…

Problem/ Question:
So I have a fairly standard K40 machine (came with the % based readout - added a 30mA meter) and upgraded to the Laserboard within about a week of using it (K40Whisperer worked fine but wanted something more). Everything works as it should and have been happily cutting/engraving using the Lighburn Software; the bundle is excellent by the way.
As things go, projects and the like change and I have recently been looking into (also) doing some metal engraving for small to medium sized stainless & steel parts. I’ve tried the moly lube method and have gotten quite good results - but not exactly what I am after. I have a 450nm, 10W diode laser (was previously mounted to a CNC Mill) that I made a mount for and thought this would be an easy add-on for those few times when I want to engrave/label metal parts; simply set the offset for the second laser in the camera view and have at it. All seem to be fine, but the output from the Alternate PWM pins does seem to be what I expected it to be. Prior to blindly (pun not intended, but appreciated) attaching a laser and seeing if it works, I hooked up an oscilloscope to the PWM output pins and only got about a 5% duty cycle despite having the value at 80% in LightBurn. Changing the Max Power % for the layer does not change anything… just a 5kHz pulse.
Here’s the part I am perhaps somewhat confused with and would appreciate your feedback. As I keep the original CO2 laser installed but ‘turned off’ from the original built-in control board, does that have an effect? I would like to be able to use both lasers but preferably not at the same time… How should I go about this? All I need is a clean 5V PWM output that provides a duty cycle based on the setting in LightBurn, irrespective of whether the ‘Laser On’ button on the unit is enabled… otherwise I may need to add a switch in-line with the CO2 power source which I would like to avoid.

Any ideas/feedback?

Thanks,
Ben

P.S. Also tried the L-Gnd approach and it just gives me a constant ~85% output.

Hi Ben,

Welcome to the forum!

Great! We’re kind of keen on it ourselves… not to be biased or anything. :slight_smile:

Depending on your machine setup, the power is adjusted on the control panel using a potentiometer or digital keys. LightBurn then controls a percentage of that. The default Smoothie firmware is capped at 80% max power in the configuration file, so LightBurn is only controlling a percentage of 80% of what the machine is set to.

We recommend starting here and also reading the included link for PWM Control: PWM Tuning

Here is a recent post you may find helpful regarding a similar discussion about dual C02 and Diode laser heads: K40 laser - Diode Laser?

We can circle back around to any remaining questions once you get a chance to review these first.

Hi Starla,
thank you for the reply.
So… this is weird. I took a look through the items you referenced and did not find any new information that I found to be pertinent to the issue… so, before posting a ‘yeah, but…’ reply, I figured I’d better take another look and see if I perhaps missed something, wrong wires, settings or similar. Lo an behold, the output was exactly what I was looking for. Clean PWM on the alternate pins with the duty cycle nicely varying between 0% and 100% based on what was set in LightBurn. I first tried this with the laser PSU unplugged (but the switch in the ‘On’ state on the control pannel). Ran through some quick engraving ranges and all looked good. Repeated with the switch ‘Off’ and the cable plugged in and still it worked. Hooked up the Diode laser and got good performance…
So, not sure what went wrong. Maybe a glitch in the firmware? Issue with my Oscilloscope? Bad wiring? I have no idea, but the end result is that it now seems to work nicely. I’ll blame gremlins if anyone asks…

For anyone else looking into this kind of option, a few quick things to point out:

  • The mount I used for this is (now) available in GrabCAD (search for “K40 Mount for offset Blue Diode Laser”). Just a rough design, but can be 3D printed and used with some M3 hardware. If you use this and modify/improve, please share…
  • PSU needs to be separate (all other topics will say the same). I am thinking I will install this permanently in the case but at the same time the diode lasers have a tendency to fire when plugged in, so I like the manual-pull-it option.
  • In my case the additional weight of the diode laser does not seem to be an issue. It won’t cut quickly anyway but it can do rapid motion to where the engraving/cutting is done.
  • As I am using the camera option to align the cut, I had to manually figure out what the offsets are. In my case I simply drew a circle/crosshair and then first engraved this with the CO2 and then repeated with the Diode Laser. Updating the Camera View then allowed me to manually shift the image around to see what the necessary difference was so that I can rely on the camera rather than the (red) laser pointer. As I still have a few mm play in the mount/case lid this approach is sufficient for my use.

Anyway, thanks again for the community support.

I’m glad to hear that you got it working, Ben! Those pesky gremlins seem to appear in the least desirable ways. :slight_smile:

I would be interested in seeing pictures of how you ended up connecting everything and setting it up. We get these types of questions occasionally, so it might prove useful to others wanting to do the same setup as well.