PWM not working

Machine:K40

Board: _LaserBoard

Firmware: _Smoothie

Problem/ Question: I was previously having some power issues and had temp installed the stock board, after finding out that was not the problem I reconnected the LaserBoard. I am able to fire the laser with the test switch and the laser moves as it should but it will not fire with PWM. It had previously worked,

The laser fire LED is on when it should be. All the wires from the Power supply to the LaserBoard have been checked with a meter.

I direct connected the LPS to the board on the ground and laser terminals and its is working, one major flaw is if the 24v external supply to the board is unpluged and power is to the laser it fires on its own

I reconnected the normal and ran only the laser fire to the screw terminal lung and everything works there must be some wrong with the board or connector.

Hi Derrick,

Thank you for your patience while we looked over your posts.

Testing the Pot

Your potentiometer appears to have corrosion. If this is malfunctioning, it could mean the laser has been firing without a limit. Can you use a multimeter to see if you get a readout when you test the 5V and G pins? It should read within a few ohms of the rated resistance of your potentiometer.

What results do you get if you test between the wiper pin and one of the other pins, rotating the pot knob slowly from one side to the other? One end should have only a few ohms and the other maximum resistance. It should slowly and continually decrease/increase as you turn the knob with no sudden jumps.

The laser power supply unit (LPSU) in your images has corrosion on the screws and a considerable amount of debris around the fan opening. If any of that has gotten inside of the LPSU, it could potentially cause performance issues or worse.


Shorting the Connection

We are going to replicate how the board “talks to” the LPSU, but remove the controller from the equation.

With the machine off, unplug the power from the LaserBoard. You do not need power on the board for this test.

  1. Remove the large white power connector from the board.

  2. Work on the connector somewhere where it will not touch anything conducive.

  3. Power the laser machine back on.

  4. Set the pot / digital keys to a low power setting which is high enough to trigger the laser.

  5. Use a short piece of wire to connect the contact metal of the Laser Fire (L) and Gnd (G) ports on the connector. This simulates completing the circuit.

    image image

Turn the machine power back off, allow the power to discharge before making any further wiring changes.

Is the laser firing when shorting the wires on the connector?

The pot tested well, the ohms changed as they should, it was able to check the voltage also and it seemed correct, it maxed at 5v. the Pot has a bit of corrosion on the case but seems to perform well. Would the available, from the store front, pot be a good replacement?
Is the LPSU grounded from the screws securing it to the enclosure? Is so the bolts need to be cleaned or replaced. I will remove and Clean the LPSU today.

The Laser fires when shorted, but not when commanded from the board, I have moved the L from the plug to the screw in port on the board. The laser seems to work in this configuration but the major issue is the laser will fire if power is removed from the laserboard.


I have done a ton more testing, I swapped the wires in red and the operation remained the same. The laser will not fire when connected to Laser fire it will work when connected to FET-, another note when powered up on both L’s I am getting +4V not negative

I think this has to be a board problem as I installed the stock board M2 Nano and its working. The only thing I can think of is a ground issue but I have ran a wire from one of the screws on the Cohesion to the back of the ground lug where the Main is grounded, the only other thing is maybe a ground from the power supply to the ground lug. At this point I think the board might be dead and cant fire the laser

With only the Cohesion 24v power supply USB and SD card installed, I ohm checked between Laser Fire and Laser Ground and it was open, I ran G1 X10 S1 F600 from LightBurn the laser fire led lit but the connection from laser fire and laser ground remained open.

image

When Connecting the like the picture below the laser works, the only major flaw is if power is removed from the board before power is removed from Laser Power switch the laser will fire.

image

Hi Derrick,

Will you confirm - if you disconnect the 2 wires L and Gnd from the LaserBoard and leave them disconnected for a moment and power on, does the laser fire?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.