Problem with man and inverted movements

Machine: _chinese 4040

Board: Cohesion3D LaserBoard

Firmware: _Smoothie

Problem/ Question: I installed Cohesion3D and I’m having trouble homing. My laser has the homing in the upper right corner. However, the coordinates are in X0, Y400, Z0 when it should be X0,Y0, Z0, correct?. So when I make a move on the Y axis, the move goes to the opposite side of the selected one. Can someone help me please?

Your machine should home wherever the switches are, but 0,0 will always be the front-left corner on a Smoothie machine.

See the following articles:

If you still have problems after reading these and making changes to your machine, come back and we should be able to get you sorted out.

Hi loather, I already tried to do the steps you indicated. However, the sd card had to be formated (no longer read). I had the backup of the config.txt file but not the firmware. I downloaded the firmware and re-installed it. However, now the behavior is being disastrous. Please I ask for help to resolve this issue. I can’t at all set the 0,0 coordinates. My machine’s endstops are on the upper right side.

This is my case, please help me!

please provide some pictures of your machine and wiring. outline where the endstops are and how you have everything connected.

The endstops are located at the rear on the right side.

OK, you’ll likely have to reconfigure your endstops completely in the config file. You’ll need to change the homing directions (both alpha and beta will be set to home_to_max). It’s also likely that you’ll need to swap the values of alpha_min_endstop and alpha_max_endstop but i’d need to verify this on my board (which i don’t have in front of me).

Go through this process before changing anything and let me know what the results are.

Hi, thanks for the support. The result for the command ‘M119’ with the switches pressed is:

X_min:1 Y_max:1 Z_min:1 pins- (X)P1.24:1 (X)P1.25:1 (Y)P1.26:1 ( Y)P1.27:1 (Z)P1.28:1 (Z)P1.29:1

The result for command ‘M119’ without pressure on switches is:

X_min:0 Y_max:0 Z_min:1 pins- (X)P1.24:0 (X)P1.25:1 (Y)P1.26:1 ( Y)P1.27:0 (Z)P1.28:1 (Z)P1.29:1

The result for command ‘M119’ with pressure on switch X is:

X_min:1 Y_max:0 Z_min:1 pins- (X)P1.24:1 (X)P1.25:1 (Y)P1.26:1 ( Y)P1.27:0 (Z)P1.28:1 (Z)P1.29:1

The result for command ‘M119’ with pressure on switch Y:

X_min:0 Y_max:1 Z_min:1 pins- (X)P1.24:0 (X)P1.25:1 (Y)P1.26:1 ( Y)P1.27:1 (Z)P1.28:1 (Z)P1.29:1

Hope it helps to identify the problem.

Thanks

OK, Make sure you have your bed size set correctly, first and foremost.

Next, you’ll need to change a few other settings in the config file:

Swap the values of alpha_min_endstop and alpha_max_endstop.
Change alpha_homing_direction to home_to_max

That should make your machine home correctly. Give those a try and see if it works properly.

Hi loather,
Did not work. Now the laser head has gone to the rear left and is beating.

Change the value of alpha_dir_pin to 0.5! and retry.

Hi loather,
the laser head returned to the rear right side, however, the movements were reversed.
image


Absolute coordinates

  • all movements are inverted
  • Home position is X:410 Y:405
  • laser head position on home is rear right

image


Absolute coordinates

  • the axis X movements are inverted
  • Home position is X:410 Y:405
  • laser head position on home is rear right

I hope it helps.
thanks.

Origin is always the bottom left. Refer to this setup guide.

So set the origin to the bottom left then run the homing cycle and tell me what the machine does. This should help me figure out what to do next.

image
image
When homing, the laser head goes to the rear right. The motions on the x axis are inverted

OK, so it homes to the correct location, but when you command it to go left it goes right and vice versa?

In any origin I put, the homing always goes to the rear right and when a job is finished the laser head goes to the front right. Yes the movements are reversed. In addition, the work is also mirrored

OK, Change the value of alpha_dir_pin to 0.5 and set alpha_homing_direction to home_to_min - try again and let me know how it goes.

It remains the same. I remember that every configuration you indicated at the beginning I changed to do some work.

ok, i’m looking into a few things and will get back to you. i’ll probably have to experiment with a machine i have here and it’ll likely be a couple days before i can get back to you.

Hi loather, do you have news for me?

Best regards