Not homing to endstops

Machine: K40, M2Nano
Board: LaserBoard
Firmware: Smoothie latest version - updated 07/03/19
Bed Size : X = 321, Y = 217
Origin: Front Left
End Stops: Back Left

Problem/ Question:

Issue 1: LightBurn resets the Origin (0,0,0) to whatever location the Head is currently at when the board is powered on, instead of the Front Left.

Issue 2: The Home command is functioning as “return to origin”, sends the head to (0,0,0), not backwards and to the left towards the endstops.

G28 does home as expected(back and to the left untill it reaches the endstops).

Testing the endstops with the M119 command shows that both the X and Y endstops are working properly.

Console Log shows Smoothie being executed before Homing.

Can you take some screenshots of your settings and device settings in LightBurn?

Did you change anything other than size settings in the config file on the SD card?

Hi Jamie,
Thanks for your assistance.

The only changes made in the config file were to resize the bed to bring into agreement with the LB Device Setup Configuration when LB loads.


The Job Origin is set to Center, but this shouldn’t effect either the Machine Origin or the behavior of the Home command.

Turn on return to finish position like this.

Let me know if this works for issue 1, then we’ll work on homing.

The way I read this, you got the latest smoothie firmware from their website. You need to use ours, not that. May as well grab this one:

The homing command here is G28.2 and you can send that via console or just press the home button in LightBurn under the Move menu.

This should move your head to the rear left of the machine. Let’s start there.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.