Non responsive board

Machine: _it will be a full spectrum laser_

Board: Cohesion3d LaserBoard v1.0

Firmware: _ "I have a new board and I’m using whatever it came with!_

Problem/ Question: _After getting my new board everything seemed to be working great on my bench with only the power supply and usb plugged in., and it appeared to be getting a signal from light burn (I had a port and lights blinked on the board ).

Then I realized I needed different connectors for my external stepper drivers in the FullSpectrum laser.

After getting the cables from cohesion 3d I tried again on my bench with one cable plugged in so I could probe voltages, I got the sparks coming from the power supply connector which sounds like a known issue, then all of a sudden everything went black and after cycling the power all I get is a single red led in the led stack, and I no longer get a USB connection. The board never left my bench.

Also, the strip of bare copper on the backside is pretty hot to the touch.

Any ideas on how to fix it? I can do some rework if that’s the fastest way to get it fixed.

Thanks for any help and advice

Google Photos

Hi Troy,

Can you help me better understand what exactly was plugged into the board and how when you plugged the power connector and got the failure?

Next, can you do the tests as outlined here:

That is post 20 and then 2 below, post 22, has more things to check.

Thanks for your response

All, I had plugged in at the time was the power supply that came with the board, the usb cable, and cable plugged into x exp port. Everything was sitting on my bench.

I have been trying to figure out what I might have done wrong and all I can think is I didn’t tape down the ends of the cable coming out of the x exp port and the wires you provided were already stripped. I guess they could have shorted on each other.

Also, there was the sparking coming out of the dc jack. My jack was really stiff to insert at first an I found myself not plugging it in all the way which didn’t help with the sparking.

Tests from previous posts answers in bold:
Place the positive probe on VMOT. You should see a steady 24v. 24.18
Place the positive probe on 5v. You should see a steady 5v. .048v
Place the positive probe on 3.3v. You should see a steady 3.3v 0

VMOT - GND no short
5v - GND yes short
3.3v - GND yes short

Please remove the jumper from the 5v Select Header (should be in the red position) and try to check continuity between 5v and Gnd again. yes short

It seems like the exact same thing as that post.

If its something simple like just replacing the voltage regulator, I should be able to handle that.

Thanks for the help

Can you check if your computer still recognizes the SD card?

No, nothing when I plug the usb in. I can access the sd card with a reader, if that is what you were after.

Yes, that’s the part I wanted to confirm, thank you.

I’ll reply to your email tomorrow to arrange a resolution.

Not sure if its an email issue but I never got the email. Obviously I am not in a huge hurry to get it working.


Hi Troy, I replied to the email you originally sent asking for the shipping address to send the replacement board too. Hadn’t heard back from you.

It looks like your forum email has an s at the end but the order and contact form email do not.

Its the one with an S. I typed it wrong once in Chrome and now it autocorrects to the non S version all the time if I don’t catch it everything is messed up. I tried to find a solution but I am not the only person who hasn’t been able to clear the autocomplete.

I just checked and it now looks like its correct in my account settings for both the site and the forum. But it is wrong in the billing information area from that order.

Sorry for the hassle

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.