No Power To C3D Board - Help needed

Machine: _K40 (Nano)

Board: _Cohesion3d

Firmware: _Smoothie / Lightburn

Problem/ Question: Hi All, I’m at a loss with what could be happening with my board. It currently has no power (no lights showing, memory card installed).

Notes:

  • The C3D board has previously powered on. I swapped the board out for the nano then back again and now it wont power on.
  • SD card is plugged in and has been tested on a laptop, it was recognised.
  • Cables are fully plugged in and not loose (same set up as previously demonstrated with working lights).
  • Tried AC adaptor on multiple plug sockets to no avail.
  • Board doesnt have any fried spots or burn marks.
  • I’ve tried rebooting K40, laptop and closing down application to no avail.

Is there any other steps I can take? Does anyone have any idea what I’m missing.

Any response is greatly appreciated.

Thank you.
James

Did you provide those pictures? We need pictures to understand your setup!

Anyone? Any help is greatly appreciated.

Hi James,

Welcome to the forum! I have upgraded your trust level so that you can now upload photos.

Please provide clear pictures of your machine, control panel, board, other electrical components, and wiring with the LaserBoard connected. We need to see how and where everything is connected, as well as what type of machine you have.

Hi All,

Please see below for the image.

Thank you, James.

Can you help us better understand what exactly was plugged into the board (and how) when you plugged the power connector and got the failure?

If you have a multimeter, we would like to run the below tests to see if there is an issue with the power supply. Please disconnect the board, remove all of the connectors, power brick, USB, and SD card.

Test the Power Supply

For the Cohesion3D power supply, try the following:

  1. Plug the pronged AC end of the power cord into a clean power source. For power strips, ensure it is plugged in, functioning, and turned on.
  2. Make sure power supply green LED light turns on. This means the power brick is receiving power from the outlet (as you mentioned).
  3. Securely plug the “figure-8” end of the AC cable into the brick.
  4. Turn on your digital multimeter and set it to read DC voltage (set to 200, if necessary).
  5. Probe the center of the adapter conductor tip with the positive (red) lead.
  6. Carefully touch the outside of the barrel with the negative (black) lead.
  7. On your multimeter, you should see a reading of the voltage coming from your power supply.
  8. For our 24V power supply, the multimeter should show around “24.30V”.
  9. If you get a negative reading like “-24.30V”, then your probes are attached in reverse and need to be swapped.
  10. If a negative reading happens and you are certain you connected your probes correctly, let us know. Our AC adapters are center positive, so if the polarity is reversed, we need to know.
  11. Unplug or turn off the power source from the outlet or power strip.

Report back with your findings on these tests.


Test the LaserBoard with Power Supply

Connect the Cohesion3D power supply using these steps to test:

​1. Remove the board from the panel and take it out of the machine.
2. Place it on an insulated surface (wooden table, not metal).
3. Connect the DC barrel end of the power adapter into the board.
4. Plug the power cord into the outlet or a power strip and turn it on.

Note: If you plug into the the DC jack on the LaserBoard while the power brick is already energized, it will cause a large inrush current as the capacitors charge on the board, resulting in sparks. This is known behavior. To prevent this, plug into the board first, then the outlet.

Are you getting any lights on the board?

1 Like

Hi,
Thank you for the quick response! I removed the board from its metal framing and placed it on some scrap MDF. In the meantime I noticed that the power supply wasnt lit meaning no power was coming from the adaptor plug. Swapped out the plug and its booted up!

Thanks for your help.

Regards,
James

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.