No fire :(

Machine: K40
Board: C3d Mini
Firmware: _Smoothie
Lightburn

Problem/ Question: After having purchased my C3d mini a couple years back, I finally decided to install it on my second K40 (my first K40 has been running the same card all that time and it works well). Finished configuring my Z-Table and X-Y axies without any problem. Aligned mirrors also without any problems by using the test button on the K40 itself. Quite happy I got everything running… until I tried doing a test engraving in Lightburn… no fire. Everything works (X-Y-Z) perfectly, except for the firing part. Test button works.

Here are pictures of my setup. I did some research on the forum but didn’t find the exact same board (perhaps I didN,t go back long enough in history)… anyhow, let me know what to do. I double-checked my connections, everything is exactly as with my first K40 (the one that works well), I checked the 3 blue cables to make sure they are connected correctly, it all looks good.

Thanks for the help.

Boris

Hi Boris,

Congrats on getting your Z-table installed!

Great! This rules out some potential issues with the LPSU.

The machine was talking to the board previously, based on your prior post, albeit intermittently. What has changed since then that could have caused the disconnect?

image

image

Are the black wires above connected to P+ and G attached to a water flow sensor or meter?
If so, let’s test the signal from the sensor. Remove the black wires from the power supply. Jumper the P and G pins with a piece of wire or jumper connector. If it fires, then you have a bad flow meter or faulty wiring.

What do you have connected to the 5v pin here?
image

I know you mentioned you double checked everything, but make sure the wires are making proper contact inside of the screw terminals for the main power in. This turned out to be my issue in one instance with the Mini, so I reinserted them all the way to the wire insulation and it fixed the problem. Check the terminals at the adapter end as well, just to be sure. Confirm that the power supply is firmly inserted into the adapter.

image

Please answer all of the questions and get back to me with the results.

Hi Starla, here are some answers.

The prior post was related to my other machine (machine 1), although I did have issues with my machine 2 the same (the intermittent problem) after installing the C3d board.

Machine 1, runs smoothly with the same C3d mini board, Z-table enabled and all, no more problems with the intermittent resetting (I wanted to update the post with the resolution but it’s been closed).

Machine 2 is the one I am having issues with now. It was running smoothly with the old Nano board, but needed to install a Z-table to make it the same as machine 1. The board works well except for the firing part, X-Y-Z axis responding all well with Lightburn.

Now for your questions:
Are the black wires above connected to P+ and G attached to a water flow sensor or meter? ==> No Those two wires go to the test button directly. I don’t have a water flow sensor or meter.

What do you have connected to the 5v pin here? ==> That goes to the Z-Axis external stepper driver’s Signal/ENA+ connection (just like on machine 1).

I removed and replugged the main power to the board (see new picture) and it appears contact is being done correctly. I also re-checked at the power supply end and it seems correct as well.

I also rechecked the 3 blue wires that run from the main PSU to the board and they look firmly in place, all 3 of them, on each end.

Thanks

Google Photos

What should I check next ? I’m out of ideas here, need help.

Thanks

Thanks for following up, Boris. I had to dig up some old docs for the Mini and reconnect mine to do some tests. :slight_smile:

Check the Configuration

Are you using the original configuration file that came with the board?

Power down. Put the board’s memory card into your computer, using a MicroSD / SD reader if necessary. Open the config.txt file. Check the parameter for laser_module_enable to see if it is set to false. It needs to be set to true. Save the changes, eject safely, and reinsert the memory card back into the Mini before powering on again.

Send a Test Command

Send a command in the console and hit enter, as explained here: PWM tuning for Smoothie Firmware such as G1 X10 S0.8 F600

Does the laser head move and fire?

Hi Starla, thanks for helping me with this.

The laser_module_enable flag was already set to true. I use a modified version of the config.txt file to enable the z-table, but it’s 99% original. Only the gamma settings have been changed.

The G1 X10 S0.8 F600 command does make the laser head move, but no fire.

Try the following steps to determine if the issue is on the laser end or the board end. We are going to replicate how the board “talks to” the LPSU, but remove the controller from the equation.

With the machine off, unplug the power from the Mini. You do not need power on the board for this test.

  1. Remove the large white power connector from the board.
  2. Work on the connector somewhere where it will not touch anything conducive.
  3. Power the laser machine back on.
  4. Set the pot to a low power setting which is high enough to trigger the laser.
  5. Use a short piece of wire to connect the contact metal of the Laser Fire (L) and Gnd (G) ports on the connector. This simulates completing the circuit.
    image
  6. Turn the machine power back off, allow the power to discharge before making any further wiring changes.

Is the laser firing when shorting the wires on the connector?

That would be my blue 3 wire connector right ?

Which ones are the L and G pins ?

Yes, you’ll have to trace the wires from the LPSU to the other end of the connector to confirm which ones. It should be the second and fourth pin (with the connector lip on top), but double check to make sure since all of your wires are the same color.

LPSU Guide for reference: https://cohesion3d.com/knowledgebase/laserboard-lpsu-connection-guide/

Alright, I think I did this test correctly. It looks like it’s really the 2nd and 4th pins on mine.

NO FIRE
Google Photos
Google Photos
Google Photos

Thanks, Boris.

Just to confirm, the Laser Switch On/Off button was enabled and the power was on when you tried the short circuit? This test needs to work for the controller to be able to talk to the laser.

You mentioned that the test button works - did you mean the one on the control panel (and you used that for aligning the mirrors)? Does the test button directly on the LPSU fire the laser?

Yes, that’s precisely what I meant.

The on/off switch is ON. The jumper wire didn’t trigger the laswer to fire. The test button on the control panel works AND the small test button on the PSU also works. I use the test button to align my mirrors as it’s very handy !

Does that mean that my blue wires are not making good contact ? Sounds like it to me. I’ll re-double-check them right now.

Thank you for confirming.

Yes, it sounds like something is amiss with the connector from the LPSU to the connector for the board. You might need to replace the wires and/or connectors themselves.

Did it ever engrave with the stock board originally?

It did work for a long time with the stock board.
I just checked the wire for conductivity and it’s all good. Could it be my PSU ?

Even the conductivity between pin L and G is good when I have the jumper on it… It’s definitively not the wires

Thanks for checking! Hang tight for a bit. I need to do some research and I’ll follow up with you later.

Hi Boris,

Try one more short test between the L and G directly on the LPSU. This will tell us if it’s specifically an issue at the power supply level.

Remove the 4 pin connector on the right and very carefully jumper the L and G pins. Does the laser fire?

image

Done. Still no fire

This is where I must bid you adieu for now, unfortunately. :slight_smile:

There are some great resources over at the Maker Forums to help you troubleshoot the LPSU end of things for the K40.

Good luck and reach out again, if needed, once you get that end sorted!