New install

Machine: chinese s4040 https://www.toolots.com/dm-16-x-16-inches-laser-co2-engraver-and-cutter-machine-fda-certified.html

Board: m2 nano to cohesion3d

Firmware: smoothie

Problem/ Question: homing issue ! Goes to top of machine will shutter left and right on the way. But won’t go to limit. Get homing fail. Have a video but not sure how to share it. Here is a picture of installed cohesion3d. Thank you in advance for any suggestions !
Barry

Make sure that the x axis is not binding. If this is happening, you may not have enough current to overcome the resistance of movement. Have you tried jogging the machine from lightburn?

Also, try manually touching the x limit switch while it is homing. Does the x axis stop shuttering when the switch is tripped and hold position

I can stop it by touching the limit switch then it is dead in the water. if I set it home manually it will jog a little. I swapped in the original m2 nano and it worked flawlessly. I also must say that the left to right movement is very noisy. Its like it can make up its mind on which direction to go. Here is a link to a startup video.


Thanks again for any advice! really bummed I cant get this thing working.
Barry

Check to make sure the plug for the stepper motor on x is seated correctly. Would not hurt to spray a little contact cleaner in the plug and blow it dry with compressed air. Also spray some cleaner on a paper towel and wipe off the pins on the board. Obviously with the power disconnected. While you are waiting for everything to dry, double check which pins are a+/a- and b+/b- on the board and follow it back to the corresponding pins on the connector. Make sure you have continuity from a+ to a- and b+ to b- in the motor connector. If all is well there we can check the config.txt file for motor current settings and such. I’m not an expert in that area but this link explains most of the config settings.

http://smoothieware.org/configuration-options

SO learning a little here. It appears my up and down (top to bottom) is on the 4 pin connector (y) and the left to right movement is on the ribbon cable (x) ?.. I think that is the correct way to express the axis?? I again re-installed the M2 Nano which appears to be this board UniversalConnector%20(2) . if this makes any difference . it is working as advertised with the M2 nano. I re install the cohesion3d no dice. I am sorry it takes me a little bit of time to get back and forth I am working 60+ hr weeks so time for this is limited. Thank you all again for the help you are giving !
Barry

Can you post pics of the wiring with both nano and C3D please

Topic: K40 with M2 Nano. Converted to mechanical end stops. Need info on C3D end stop connections


Here are the pictures of both boards wired up. While it was hooked up I again ran jobs on m2 nano.
After reinstall of cohesion board got the same results.
Loaded grbl LpC and it homes then freaks out when asked to print.
Thanks Barry
Edit: also tried to hook up LCD screen and get lines and nothing more.
Really starting to think this is a board issue.

The LCD won’t work under GRBL-LPC. It requires Smoothieware.

If it’s jumping around like that it points to the stepper motors and/or the control circuitry.

Put smoothie back on it and edit the config.txt. Set the motor currents for alpha to 1.0 and beta to 1.2. The defaults of 0.4 and 0.6 are a little weak for your typical K40 (note that this is wholly motor-dependent; if you can post your motor model numbers we can fine-tune this a bit more to what the motors are actually expecting). If the motors get unexpectedly hot or start grinding/making loud noise/smoke/etc. then lower the current by 0.2A and try again.

Ok so I flashed back to smoothieware. I gave alpha currant 1.0 and beta 1.2 as suggested. I still have the same issue. The device will not home and I only get shudders left and right. I again re-installed all firmware fresh re-install device in lightburn and I am stuck again. Also not really my major concern right now but lcd still isn’t working. I am not sure what to do at this point. I have tried stock smoothieware and the grbl. I get roughly the same issues with both. I again just to check that the machine it self did not have and issue I reinstalled the M2 Nano started up k40 whisperer and boom works…
Thanks all who have helped
Barry

It’s going to be tough to debug this with the ribbon cable. On the far left side of your gantry where the X stepper lives there should be a 4-pin connector on a small PCB (it will look identical to the connector for the Y motor on the Laserboard). This is the control wire for the X stepper. Disconnect it. If you have some lengths of wire, please extend this so you can directly connect the stepper motor to the laserboard. I’m not saying there’s anything wrong with your ribbon cable - if it works with the nano board clearly it’s functional. This will allow us to do more extended testing and narrow down where the problem actually is.

First, we’ll begin by connecting the X stepper directly to the white 4-pin JST connector next to where you plugged in the Y motor. Retry homing the machine and see if it works. If it is successful, we know there’s a disconnect/intermittent connection between the ribbon cable and the laserboard. Contact cleaner or rubbing the ribbon cable contacts with a pencil eraser may help here.

If it fails to home for any of the following reasons double-check the wiring:

  1. No movement at all on X - indicates the stepper motor coils are cross-wired - ensure A+/A- and B+/B- are on the correct pins
  2. Homes in the wrong direction - indicates one coil in the stepper motor is wired in reverse (swap the polarity of the two wires corresponding to one phase in the motor - it doesn’t matter which one)

If you still get errors homing and you’re sure the wiring is correct, then move the X stepper motor connections to the Z axis port. This is a 4-pin DuPont header on the other side of the Y motor. You will need to edit the config file and swap the alpha_*_pin values with the gamma_*_pin values. This reassigns the X axis to the Z axis port. Don’t forget to increase gamma_current as necessary. Now, retry your homing exercise and see if it works properly.

Good luck!

That video shows a very weird sequence indeed. There’s a particular set of basics I’d like to go through before getting into anything this involved. Currently trying to ship a few more packages before the post office closes today, will be able to respond soon.

We also have a how-to article being written for how to convert a larger machine with an M2Nano that I need to review and hope to release shortly.

Yeah, it’s definitely an odd sequence…

Thanks ! Look forward to more info.

I’ll look into those suggestions. Might take a bit to get a wire and connector setup.

Hi Barry,

The guide is mostly ready, please have a look.

Perhaps back up the config files and put fresh files on the memory card and follow the steps in that guide.

Next, here are the things we care about:

Jogging - turn homing off in LightBurn (device configuration), then try to jog each axis in each direction by itself, and make sure they all move properly.

Do M119 test on each switch to verify your switches are being read correctly, as explained here:

Position the head only several inches away from the limit switches, so pretty close, and send G28.2 command via the console in LightBurn to see if it homes successfully. If there is a problem, power cycle, and try sending G28.2 X0 and G28.2 Y0 one at a time to see if the individual axes home.

The other axis should not move when jogging or homing only one axis.

1 Like

This is the only thing I have been able to come up with. I Re-installed everything. on a plus not the LCD seems to work. I can not get any movement out of the gantry now here is a snip from lightburn debugAnnotation%202019-12-24%20103129 I have noticed in all other pics on web on the web none have y as max . all show it as min. I am lost at this point … Again if I install M2 Nano works perf.
Grr
Barrett. thanks for the article it game me a few things to try

Is there a way to take my x axis off the ribbon and run it on the header on cohesion3d? Or get away from the ribbon all together? Run all axis motors and limit switch etc. Kind of down grade the factory setup to a more traditional k40 setup ?

You definitely should be able to. Do you have a picture of the board at the other end of the ribbon? If it has a 4 pin plug from your motor that is the same as the one on the Y axis but with shorter wires, you would need to extent the wires from your X motor and either add the plug back on and plug into the four pin k40 X-motor connector or you can leave the plug off and put the wires into the green plug next to it. Then just use a mechanical end stop from c3d for the X axis.

Here are pics of ps and secondary board.


The white connector is a 5 pin . Does anyone know where I can find extensions for the motor and stop switches so I can bypass the ribbon cable ?