New Install - No Laser Fire


(Brian Van Heuverswyn) #1

Machine: K40 - arrived with M2 Nano (ribbon cable)

Board: Cohesion3D Mini

Firmware: XYZA Smoothie

Problem/ Question: I apologize if this in in the instructions somewhere, but if it is, I seem to be missing it. I recently installed my Cohesion3d Mini board according to the ribbon cable instructions, and added an external 24v power supply per recommendations. I am unable to get the laser to fire via a job in Lightburn. The laser head moves as expected, but the laser doesn’t fire. However, the laser WILL fire via the test fire button which tells me that my laser hardware (tube, etc) is functioning.

I’ve had people suggest that I have a grounding issue and I’ve seen other posts such as this one that seems to indicate that I need to connect the “Laser Fire” and “Laser Gnd” wires from the original PSU to the Cohesion3D board. Is this true? My controller is one of the original boards that does not have the screw terminals next to the power plug. That said, I’m wondering if I need to connect the original power plug but remove/cut the 24v and 5v wires from the PSU connector? That would seem to be the easiest solution…or I could just add jumper wires between the board and PSU. Thoughts?

I also plan to mount the board to the K40 case using nylon standoffs (to isolate ground from the dirty K40 power) per recommendations in the ribbon cable installation instructions.

TIA.

Brian


(Starla Fox) #2

Please provide pictures of your board, machine, and wiring.

Send some lines as explained here: PWM tuning for Smoothie Firmware such as the G1 X10 S0.8 F600

The head should move while firing. A red LED “Laser Fire Status” in the bottom left corner of the board should turn on.

Tell us exactly what does and does not happen.


(Brian Van Heuverswyn) #3

I’m not at my machine right now. That said, I’m happy to share photos of my board later when I’m near it, but I can’t see why that’s necessary relative to the question? Do I need the “Laser Fire” and “Laser Gnd” wires connected to the board from the Laser PSU? Seems like there should be an answer to that irrespective of my board and wiring.

As mentioned, the laser head is moving but the laser is not firing. I’ll have to report back on the “Laser Fire Status” LED. Thanks.


#5

We do need to see your machine, board, and wiring pictures as Starla asks to be able to understand your machine’s wiring and provide the best personalized assistance. We are looking for a Laser Fire (L) and a Ground wire, yes.

The install is explained here:

https://cohesion3d.freshdesk.com/support/solutions/articles/5000783636-k40-additional-24v-power-supply-upgrade-guide

The “Laser Fire Status” LED is actually on the new LaserBoard, you won’t have that on the C3D Mini so don’t worry about that.

Just the pictures please.


(Brian Van Heuverswyn) #6

Here is my board powered on.

Since I’m new, I can only add one image. What else can I provide? I do not currently have a Laser Fire and Ground wire connected…I’ll try to post that picture in another reply.


(Brian Van Heuverswyn) #7

Here is the K40 PSU and the supplemental 24v power supply.


(Brian Van Heuverswyn) #8

Regarding the 24v power supply installation instructions that you referenced - I don’t see any mention of connecting the Laser and Ground connection to the board…but perhaps I’m missing it.

Thanks.


(Brian Van Heuverswyn) #9

Connected the Laser Fire and Ground from the LPSU to the board. Still no fire. Here is an updated photo. The green wire between the Laser Fire and Ground is disconnected at the other end. The red wire on the left goes to Laser, and the red wire on the right goes to Ground.


(Jamie Richards) #10

Do you have a digital or analog panel? What percentage or mA (current) do you have it set to? Did you try changing the PWM frequency in the config?


(Brian Van Heuverswyn) #11

Analog panel. I have my pot set to ~15mA. I have not tried changing my PWM frequency as I’m not clear on that process (though I will research).


(Brian Van Heuverswyn) #12

As soon as I am able, I’m going to perform the test discussed in this thread.


#13

Different board, different debugging procedure.

When you tested the laser firing after connecting the fire and Gnd wires, was it via the gCode line?

If you disconnect the plug from the C3D and connect the 2 red wires to each other momentarily, does the laser fire?


(Jamie Richards) #14

Awesome, hopefully, that will help get to the bottom of it! With my stock power supply, I had to change the PWM frequency for it to work correctly. Some of these power supplies are very finicky, but my replacement power supply was happy with default.


(Brian Van Heuverswyn) #15

No, I was firing via Lightburn, though I will try via gCode and report back later. I’ll also try touching the 2 wires to attempt to fire. Thanks!


(Brian Van Heuverswyn) #16

Thanks, I need to read up on this and will go through the tuning doc as suggested.


(Brian Van Heuverswyn) #17

I disconnected the plug from the C3D and connected the 2 red wires together. The laser DID fire as expected when I did this.


(Brian Van Heuverswyn) #18

Tried firing via Gcode and does not work.


(Brian Van Heuverswyn) #19

@Cohesion3D Am I just out of luck here?


(Brian Van Heuverswyn) #20

Have also tried changing the PWM Frequency.


#21

I checked our order records, and you were order #121 from November 2016. In other words, you have a C3D Mini from the first batch ever made. Things are going to be a bit different from the latest install instructions you were following.

Grab the latest firmware and config files from “Batch 3” and put those on the memory card instead - it’s in the dropbox at the bottom of the install guide.

You’ll also need to disconnect the L wire from that plug and instead run it to screw terminal #4 along the bottom row: FET1Bed-

We’ll deal with rotary setup later.