New Cohesion board, K40 laser only fires on test switch, not on panel button or through lightburn

Machine: K40, Came with a HT XC ON 9 (very similar, if not identical to the HT master). Used HT master install instructions for Cohesion board.

Board: Laserboard.

Firmware: Smoothie…that’s what it said on it. I don’t know what smoothie is. But it works. :slight_smile:

Problem/ Question:
I am NOT an expert with wiring etc. I’ve tried looking through some similar threads and could not understand half of what is being talked about!! :frowning:

Lasertube and laser psu works. Cohesion board has all the correct lights and suchlike. The “laser firing” light is also on so it thinks its firing the laser.

Lightburn will control laser, and even run a program, but it will not fire unless the test switch is pushed. I can lase like this but I feel like it’s not super safe and it’s 100% inconvenient :frowning:

Sending pictures of the machine, I have bridged the pin things that cover the door switch and water flow sensor, as I wanted to check if they would be the problem, I’ve read that’s a simple usual fix. It is still not firing except with test switch :frowning:
I will put the safety’s back later once I get it working again!!

Is there anything else I can provide that might help us fix it? I’d be really grateful for any support, I run the business off this thing and it’s costing a fortune paying for outside lasering!!!

I hope these are the right pictures. …can’t upload pictures as new user

Just tried something that was suggested on another thread for a similar problem - when i short the two pins for firing the laser (removing the board from the equation), the laser fires continuosly.

Is this good or bad?

that’s a good thing. it means the problem is either with the way it’s wired to the board or the board itself. I’ve updated your account so you can upload pictures now - let’s see how things are wired. Make doubly sure that L+ and GND on your power supply are connected to the right terminals on the board as current won’t flow in reverse.

If you can get a picture of the bottom of the board in the area where the PSU wires connect, that would help as well.


This is the original board…what you said about L+ and GND…would that be the red and black wires that I had to cut and add into the screw terminals? If so, looking at then here (you can see the remains of the wires in the second photo). It looks to me like the red wire went to GND and the black to LO (I assume is L+?) In which case I have wired them into the board the wrong way round…? (Pics of new board wiring below.) Am I correct in saying its the markings that matter, not the colour of the wires? I just saw red and black wires in the demo pic and put my red and black wires in the same place.

If I rewire the C3D board with the wires the other way around and I’m wrong…Will it blow up the board? Or me? Or the machine?

New board…



Bottom of c3d board

Inside

Inside cu

16450459646487667798723903291173
Hope this helps @loather and thanks so much for your time. It’s sincerely appreciated.

Best regards

George

Yes, you are correct in your deduction that the terminal labels matter more than the colors :slight_smile: swap the red and black wires and hopefully it’ll start working. The voltage on those pins isn’t usually high enough to kill the isolator if wired in reverse, thankfully, so unless something else killed it it should function. It looks to be in good shape from your photograph, with no signs of burning or smoke (that’s why I had you take a picture of the back of the board). Give that a try and let me know how it goes.

Thanks Loather. This worked :slight_smile:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.