New board freezes after a minute or so

Machine: K40 M2Nano

Board: Cohesion

Firmware: I have a new board and I’m using whatever it came with

Problem/ Question: I installed the board yesterday and right from the beginning it seems like there were issues. It would randomly freeze up. At one point it did it while cutting wood and the laser stayed on. I got a new USB cable and was able to do a couple of raster engraves. I tried doing some work today and now the board will freeze within a minute after homing. V2 and V3 LEDs appear to be in random states of on of off when it does. This will even happen with no USB plugged in so no commands are going from my PC to the board. I am a new user so I cant upload pictures.

We have upgraded your trust level so that you can now upload pictures. Please provide pictures of your machine, board, other electrical components, and wiring so we can work towards diagnosing the issue.

Let me know if these are good enough or if you want more.

Update on things Ive tried to fix it. Got another USB cable. No change. Tried reformatting the SD card and reloading the firmware/config file, no change. Still freezing at random points. Made it through 1 10min engrave no problems then froze right after, another time it froze right after booting up.

Hi Jesse,

Thanks for the pictures. Can you also take one of the barrel plug for the power brick to the left side of your first image so we can see where it is connected to the board? Also, do you have it plugged into a power strip or directly into its own wall outlet?

Your issues sound intermittent, which is usually indicative of dropouts or brownouts.

Swapping the USB is a good step to take. Confirm that your USB ports and computer are not going into power save/sleep mode. Can you try to plug the C3D power brick into a different outlet or a different circuit in the house entirely?

Take a look at the linked doc above for other potential issues to check for. Let us know if the issue persists after walking through it.

1 Like

Sure, just FYI, I did test it without a USB cable plugged in and it did the same thing. I will try the different plug in a bit. And I did try a different SD card and adapter as you can see. No change.

I went through all the trouble shooting steps that are in the link. I tried unplugging it from the surge protector and plugging it in to its own outlet. There is nothing else on that circuit. I even tried just the machine and board power brick on its own circuit and no change. Im thinking its something other than the USB signaling as the heart beat (L2 and L3) will freeze up even without a USB cable plugged in (unless thats how its supposed to be).

No other ideas? I think at this point Im going to have to switch to my old card and request a replacement for this one. Who would I contact?

Hi Jesse,

We’ve been reviewing your posts and email. Thoughtful support takes time, so your patience is appreciated.

You are getting the laser to fire and engrave, so the board is speaking properly to the laser. The red status LED “Laser Fire Status” in the bottom left corner of the board should turn on when you are sending a test file or command to the laser.

image

Everything you’ve indicated up to this point sounds like an electrical interference or grounding issue.

I noticed on your LPSU there is a jumper on the P+ and G pins and nothing grounded to K- on the unit. Is the machine properly grounded?

Unplug your K40 from the wall to test continuity. Set your multimeter to measure Resistance, then place probes on the earth pin of your power lead wire and any exposed (unpainted) metal on the case of your K40 (other than the ground bolt on the machine). Your multimeter should indicate very low resistance (i.e., under 10 ohms). Also make sure that your LPSU is properly secured to the chassis for grounding.

Do you have any safety switches or water flow meters on your machine? Check all of your wiring, screw terminals, pins, etc. to make sure everything is making contact properly.

Did this last night actually. Every point I tested im getting good conductivity <5ohm. Even on the stand off that the board is screwed to. It looks like the power supply grounds on L- and FG through the big green plug. I could probably rig something to ground it through the pins you mentioned if thats something I should try.

Ran a test today. I turned everything on before I left for work. I had my girlfriend look at it every once and a while. After about 2-3hours of just sitting there, it froze.

Got home and unplugged everything from the board. The only plugged in was the power brick that comes with it. I even took it our of the engraver. It froze up.

Hi Jesse,

Thank you for providing additional photos this morning.

What size memory card are you using? Also, will you confirm if the micro SD card is inserted into the SD adapter?

I’m useing the card that came with it after noticing no change useing my own. I just haven’t swapped the adaptor back to the original. The SD card is inserted. Just fyi the 2 leds will be in random states when it freezes. Sometime both will be off, sometimes 1 will be on and other times both will be on.

Thank you for confirming. We have responded to the ticket you opened to arrange a resolution.

Got my new board and noticed 2 things that were different right away compared to the old one. 1, when the board is being “accessed,” for lack of a better term, the heart beat lights slow down. The old one would just continue to blink quickly. The other thing is that I can access the SD card from my computer while the card is in the board. I couldn’t do that with the other. So far in the 20min or so that I played around with it no issues. Im going to leave it on over night and see how it is in the morning since sometimes it took an hour or 2 to freeze.

This is actually the exact opposite of what we want, the SD access used to cause a lot of stability issues. So if it’s working, I guess that’s a super-good thing.

That’s an older firmware build that the factory uses to flash and test the boards - the latest cluster firmware comes on the SD Card. Since we just shipped you a board and you reused the SD Card, the new board didn’t get flashed with the latest firmware. You should do that :slight_smile: : Improved Raster Speed Firmware Update for Cohesion3D Boards!

I’ll do that when I get home. I left it on over night and it will still blinking away this morning. So that a major plus. Now I just have to figure out why light burn shifts over in the middle of a raster engraving a few times…

That would be why. New speed feature, old firmware.

Ok new firmware in and it still shifts over. Here are some pics. This is at 400mm/s (Ive done up to 600 on the old board and K40whisper). It also seems like while sometimes it has a hard shift (the top left on at some point shifted so far that it hit the limit switch, you can see the line the laser made) it doesnt keep the image straight as you can see farther up the long picture. The only option I have changed is turning off Spreadcycle as the whine was literally giving me a headache. Not sure if this is a board issue, engraver issue or lightburn issue.