My laser isn't homing on power up after I installed the Cohesion3D Board!


#1

The Cohesion3D Boards won’t home the machine when you turn it on, by default. Yes, the stock boards such as the M2Nano and Moshiboard tend to do this, but not everyone is converting from one of these and it’s a safety concern to execute a movement that the user did not explicitly command/ was not expecting.

LightBurn Home on Connection

LightBurn will home the laser head once you connect, provided you enabled this during Device Setup (and you should):

image

Homing on Power Up Workaround

However, if you would still like the board to home on power up, and you are running the provided Smoothie Firmware, create a text file on the root of the board’s memory card called on_boot.gcode with the contents G28.2