Missing steps

Machine: custum 900x600mm with k40 mirror, lpsu and tube

Board: c3dmini

Firmware: smoothie/with clustering

Problem/ Question: hi, im still having problems with my machine still losing steps.
I have a 36v psu dedicated to 3 dm542 and a 24v only for board.
Its not the first time that i ask for help here but im loosing my mind with this.
Basicly ive tried everything that was told to do.
I still have a misalignment when raster engraving and vector cutting.
Here is my wiring that i know that doesnt look good.
Is there any chance that my problem is in the wiring, like interference?

feel free to call me names😁

I finished my machine last week and also had alignment problems with scan engraving and cutting. During a scan engraving the machine lost steps to the left side, with the result that the engraving went diagonal instead of vertical.

First checked all the pulleys, belt tension etc. etc. after some searching i found a topic on the Lightburn forum about this problem.

This solved the problem for me, i put a ! behind the step signal pin in the config file and that was it.

Hi, thanks for the help but i already try that.
Belt and pulleys are ok.
I on this for more than a year and nothing
Are you also using dm543 drives?
I ve already try almost everything,Starla guided me but unfortunately problem persists, and can only see 2 options or the board, or the cabling/wiring.
Can you post a picture of your wiring?

does it also happen if you let the machine run the program with the laser turned off? (first let the machine mark a small square, let it run the program with the laser tube off, and re-run the small square and look if they allign.

i have leadshine stepper drivers, i wired them as described in the documentation.

Never thought about that, let me try ill get back with some feedback.
Thanks

Hi, ive just tried but the misalignment is there.

So you can rule out interference from the HV powersupply (for now)

  • I dont have a lot of experience with ferrite choke’s so i dont know if this way it helps or works against you.

  • Your RFI/EMC filter earth is not connected, i don’t know if this can cause problems, but it would be better if earth is connected. I thought it drains any noise to earth ground trough some resistors.

  • Maybe you could place some terminal connectors for power distribution. This way you have a better overview what wire goes where.

  • Try if it makes any difference if you place " ! " after step pin signal in the configuration file. (if it gets worse you can rule it out)

Thanks ill try that.
I have bought those connectores and a contactor.
Yes and the earth from the emi filter is still disconnected and give a try with it connected.
The ! Makes absulutly no difference.

Damm, ive conected the emi filter and still the same.
I did some ezperiments with acellaration and loweres it to 250 and i got better results.
Should the accelaration be less than this value?
I have a 48v dedicated to the motors. 1600 microsteping

Yup, it’s either acceleration or stepper current causing this problem if the belts are the right tension and everything is lubricated and moving easily otherwise. Acceleration is a factor of your microstep setting, the stepper torque curve, and the weight/friction of the moving assembly (these are the biggest factors). It’s some very complicated math, so it’s better to just play with the values until you get something that works acceptably. If it’s below 250mm/sec^2, then so be it if that’s where it needs to be to get your hardware operating properly.

hi thanks but it seems so slow accelarating…, i bought some bigger motor to make sure they would be up too bigger gantry

Just lowered accel to 150 and i still get a bit of misalignment.

These are my motors

And what are the current settings on your stepper drivers?

I had set 2.36rms /3.31 peak

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.