Mini Board Stuck in Boot up Making LOUD Ringing Noise

I purchased this laser used in 2020 and have been using it on a weekly bases ever since. Today when I went to turn it on for some projects it would not fully boot and is stuck making this awful ringing noise coming from the board area it seems. I checked the LED’s and they are lighting up in the sequence that is normal configuration. I have tried the reset button, I checked the SD card and it still reads correctly. I tried booting from my laptop and that doesnt seem to work either. It wont let me add photos/videos yet but let me know if there is any other info I could provide for possible fixes to this issue

I should add that the glcd screen lights up blue but never boots into the info screen and the led lights I have in the bed area also turns on so I don’t believe it to be any kind of power issue

I have nearly the same symptoms. but on mine, the ringing is from the beeper on the GLCD. I tried a new MicroSD with the config and bin files recopied onto but no success. The strange part is that when it first did this, I removed the MicroSD and used my laptop to read it, the files were gone and it said it was NOT formatted. REquest to format the card resulted in a failed format! I put the two files on a new microSD, installed it, but same symptoms on startup, No display constant squealing.

Im abouit to test a new MicroSD with the firmware reflashed hoping that works as it seems to have solved issue for many others but I really dont see why that would be the issue since my old SD card is reading correctly when plugged into my computer. How long has this been going on for you and have you posted anything on here for support or suggestions?

I broke down and ordered a new motherboard, That way I can hopefully get back in business and later have some time to do some troubleshooting.