Losing step misalignment between engrave and cut

Machine: k40 custom (working area 1000x1000 2 nema 23 for y axis 1 nema 23 for x axis 4 nema 17 for z axis)

Board: cohesion3d with external stepper driver tb6600
Firmware: _Smoothie last upgrade
Problem/ Question: losing step/unaligned between cut and engrave


Hi to all I have this issue between fill scanning and line cut when i scanning at 0°(the lines are horizontal) so I had looking for mechanical desalignament, motor break, or the tension of belt but is everithing ok, so my problem probably is eletronic, or firmware parameter.
I have increased the voltage on motor, and I change the microstepping on the external drive but everything is the same.
I have a great improvement if I increase the line interval in the lightburn fill option but the resolution on a photo is very low


and finally I have change the direction of scanning(in vertical) and also with great resolution I have a good result

I can scan a photo or image perfectly (in vertical) but i need to have also a perfect scanning in horizontal because i need to engrave a vector image and in this situation I have a losing step

so i’m looking for backlash compensation in scanning offset adjoustament but when i try the scan is perfect, there isn’t a difference between the lines

help me please!!! it’s like if the y axis motors can’t make the small and millesimal movement in the same direction (I have 2 nema 23 with 2 external drives for y axis and 1 nema 23 with one external drives for x axis)
thank you all

What speed are you running your image engrave at?

Also, have you upgraded to the new clustering firmware. It is essential you do this if you have not

In vertical fill every speed make the same result, also 5mm/s produce the same effect, in horizontal i can scanning at 110/120 mm/s and the engrave is perfect
So everytime i can engrave in horizontal but when i engrave a vector image with line the problem return

My firmware is upgrade at last version

What version of lightburn are you running

last version with full license

Typically offsets you see like this are speed related. Just for info, turn down your power and cut your speeds way down and see if you still have this issue please

i have just try, also with very lower engrave and cut speed (5mm/s) produce the same result

Are you doing bi-directional scanning or is it only firing the laser in one direction?

Is it repeatable or random? Does it have the same offsets in the same places every time?

bidirectional scanning

I have the same offsets in the same place

Have you tried a different design from a different source? I am neggining to think there may be something wrong with the file itself. Did you create it?

In every case of fill+line process I have this issue, with every geometric form

But only in one axis, not the other. Is that correct?

What if you are lasering in 2d, only X and Y. Same problem? Like if you took this same image and tried engraving in both x and Y. What are the results?

Did you ever figure out the issue I am having similar issues. My K40 runs fills just fine but when it does lines it spazzes going really fast and starts going off course even if I turn the speed way down.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.