Loosing usb connection with cohesion3d smoothieware diy co2 laser

Hi I build a co2 laser this year, I’m using the cohesion3d board (smoothie) with a k40 power unit.

When I’m starting a job everything looks Allright but after like 10 sec the machine stops. Can’t control it via lightburn also no messages in the console. I have to cut the power from the board to be able to move it again.

I tryed 3 different usb cables (even a very short one)
What else can I try?
Thanks :blush:!

Maybe powersupply is too close to the board? I’ll try to enclose it with an aluminium box.

IMG_20201003_145258|666x500

Hi Daniel,

Welcome to the forum! Your trust level is upgraded so that you can now upload additional photos.

Isolating the board could help. There are several known issues that can cause the symptoms you are seeing. Please work through the steps in this article: USB Dropouts and Brownouts

If you continue to experience issues, please provide clear pictures of your machine, control panel, board, other electrical components, and wiring. We need to be able to see how and where everything is connected.

Heya, thanks :blush:.
I tested some more when I disable the laser (doing the job with laser switch off) it finished without problems.
With laser switch enabled it freezes again after 5-10sec of firing.
I have another k40 power unit I could try to connect.

I’m not using the 24v from the k40 laser power unit. Have an extra power supply for all my 24v needs
I’m using the cables from the k40 laser. Just replaced switches but wiring is the same.
My watercooling is running all the time.

That sounds a lot like emi for me?
It’s just like somethings happening when the k40 power unit is working.

A post was split to a new topic: Connection Drop Outs

OK today I replaced the k40 power unit with a spare one and placed it about 30cm further away from the board. It seems better, I had another freeze since then, but I was able to finish a job (impossible before).
I think I will put a aluminum wall in between laser board and psu I think this will also help

So today problems are back worse than before.

I’ve read some old threads I’ve seen some guy solved this issue with a copper box after weeks of troubleshooting(I don’t have the energy and time for this, i expected a quality board for the price tag it has, but I’ve only had problems since I bought it) some people were never able to fix it, or didn’t respond back. I’m out of ideas thinking about selling the board even though I’ll make big loss (taxes)

I’ve an glcd from an old 3d printer I’ll try to make the adapter myself since well expensive to order directly from USA to Europe. Maybe with a glcd I can finish my orders :confused:
I will try to put gcode on the SD card and renaming it to on_boot.gcode, let’s see if that is working…

I’ve found this, are there anymore information on the pins available?
Does the laser board and cohesion3d mini have the same pin layout?

Hi Daniel,

I’m checking into this for you and will get back with you tomorrow.

Hi, thanks a lot.

What I build today:


It’s 3d printed with copper foil ontop

Will test tomorrow.

Hi Dann,

That’s an interesting concept. The cause of this issue is typically something very environmentally specific. Either wiring, grounding, EMI/EMF, or other outside variables causing interference.

Once you get it installed, please provide pictures of your entire electronics compartment, the board with the new setup, and also the LPSU connections. I would like to see how you implement it. Let us know how it goes. Good luck!

I also ordered ferrite cores should arrive tomorrow also got a lot of copper foil left I will make a wall between psu and board.

V2 :grin:

Hi Dann,

great effort of printing a casing! Really curious to your findings and if it works, can you share the STL? Then I can also print it here and wrap it in tape :slight_smile:

Hi, ofcourse I’ll share the stl, but will check for fitment first. My ferrit cores didn’t arrive yet, will wait for them hopefully they’ll be here by tomorrow.

Okay I completely enclosed the board put ferrit cores on every cable leading to the board.
I still got dropouts.

I don’t want to tinker anymore I’ve lost enough money. How can I return the board?

are you using the included power supply or supplying power on your own from a different source? also, i have had issues when i set the speed to high on the steppers, when the stop they overshoot and become tiny generators that feed back to the board and cause issues. This was on a large 3d printer, but the issue could be similar.

Hi Daniel,

Please provide pictures of your entire electronics compartment and LPSU connections. We asked before for photos, as it will help us see what else you have that could be causing interference. Make sure any HV wires are nowhere near the board.

Where is the AC plug from the C3D Power Supply plugged in and is it on a separate circuit? Check if any other electronics nearby could be causing EMF/EMI.

Others have had success with using a powered USB hub. Have you tried this? Recent post with more info: Connection Drop Outs

Hi Dan i have had the same problems over the last day or so and found that if you lower the power the job would complete without any issues, try setting to the lowest power say around 10% and then see if the job completes then do again but at 20% and so on and if like me you will find the machine freezes when you get to around 50% on large scans that take around an hour.
I am changing out the psu with an upgraded one and i will let you know if this sorts the issue.