Lightburn is not recognizing my k40


(Raul Goodnight) #1

Machine: _i have i K40, it came with a M2nano

Board: i replaced it with the cohesion 3d mini

i set it up with all 3, GRBL, GRBL-LPC and smoothie…I have a new board and I’m using whatever it came with it…

i installed the board as shown in the website, however when i search for device in lightburn is not recognizing my machine…could it be the usb cable?


#2

Please provide pictures of your board, machine, and wiring, and screenshots showing what is happening in LightBurn.


(Raul Goodnight) #3


(Jamie Richards) #4

What version of Windows?


(Chris Leitch) #5

You mentioned in the first post that you had a Cohesion3d Mini board but in the pictures you have a LaserBoard. Just want to check that the pictures are correct.

Based on the pictures it looks like you don’t have the SD card in the board. If you switch everything off, insert the sd card that was supplied with the LaserBoard (provided you haven’t changed the contents of the sd card) you should be up and running with the smoothie firmware and be able to connect to lightburn with that configuration.


(Raul Goodnight) #11

I noticed that, my fault, I’m very new to all this and i thought i got the mini, anyway Im running it on Windows 8… I did put the SD card in it and ran it with smoothie but Im not getting anything i even tried a different USB cable


(Raul Goodnight) #12

Im running Windows 8.1


(Chris Leitch) #15

On Windows 8 and below you also need the smoothie driver.


#17

As stated above, please verify that you have installed the drivers:


(Raul Goodnight) #18

Thank you that fixed the issue, I got it working, my problem now is that when i send i job to the cutter for some reason it goes straight to the bottom left corner where the origin is and that’s the only spot it does the job, it also gives me a “cut out of bounds” window no matter where i place the object. if I use the laser positioning in lightburn, it moves to any point freely. I tried turning the machine off and restarting again but it does the same thing.


#19

I’m having difficulty visualizing this, can you provide a screenshot of the LightBurn Window (no cell phone pics please, hurts the eyes) and a video of the machine doing that thing (upload to Youtube or other video service and share the link here)?


(Raul Goodnight) #21

Here’s the video of exactly whats hapening.


#22

Hi Raul,

The combination of that physical behavior and error message suggest that you have some design element outside the bed area in LightBurn. I would recommend restarting the LightBurn Software and the board, and in a clean LightBurn workspace simply draw a square in the middle and try again. You should not have the out of bounds error if everything is good in the design window.


(Raul Goodnight) #23

I did that many times, didnt work…


(Raul Goodnight) #24

no matter what size or where i draw, or how many times i restart the machine or program, it still gives me the same error and the machine behaves the same way.


(Jamie Richards) #25

Can you give screenshots of your LightBurn configurations? Also your config file if you’re back to Smoothie.