Light Burn Camera Problem

K40 with a M2Nano board which has been replaced with a new Cohesion3D laser board. Smoothie firmware running in Windows 10 (64 bit) and using Light Burn version 0.9.22. All hardware was ordered from Cohesion3D.
Hardware and software conversion is working without any problems except for the Light Burn camera. I cannot get the software to run the camera…no image.
I have made the changes in setup suggested by Light Burn and still no image.


Any suggestions as to why no camera image.

Hi Roger,

We are sorry that you are having issues with the camera.

Check that the camera cable is firmly inserted at both ends. Sometimes, they can work loose.

For Windows, in LightBurn > Preferences, at the bottom is a setting for ‘Capture System’:

  1. There are two options - Default and Custom
  2. Change the option from the current selection
  3. Restart LightBurn to register the change
  4. Try testing both options to see if either resolves the issue

Let me know if it the problem is still present afterwards.

I have tried both suggestions. I checked in Windows Device Manager and the camera shows up in the device list so the cable is connected correctly. I have also tried both settings in the Light Burn software and restarting the program after the change with NO luck. I now think there has to be an internal problem with the video sensor in the camera which is not sending a video signal. The software performs as it should with the controller for all other functions. The camera just does not work.

Hi Roger,

There are several potential causes for this, so we’ll walk through them. Windows is notoriously bad for having conflicts with cameras, we’ll work through those possibilities first.

  1. Windows may require you to download a Media Feature Pack. Find the one specific to your OS version.
  2. If you have anti-virus software, confirm that it is not set to block camera access.
  3. Check that your Windows security settings allow apps to access the camera.
    • Click the Start menu, type “camera privacy” and click the ‘Camera Privacy Settings’ entry.
    • Check that ‘Allow apps to access your camera’ is enabled.
    • Scroll down below the list of Windows apps and check that ‘Allow desktop apps to access your camera’ is enabled too.
    • LightBurn should be in the list.
    • You might need to reboot your machine and try again after the settings change.

Check another program which has access to the cameras on your system to see if it is working as expected.

Connect the camera to another computer. Do you have the same results?

1 Like

Thanks! Starla.
You hit it. Buried within Windows10 the security settings were blocking camera access. The camera is working and now all I need to do is figure out how to use it.
Thanks again!
Roger Wetz

Sweet! I’m glad we got it figured out. Some tips for you to help get started:

  1. For general information, please refer to the Camera Calibration documentation.
    • Ensure that your Calibration-Circles file is printed and mounted to a stiff card or foam board to prevent the image from warping.
    • Refer to the Camera Calibration video and note the angle of the card in the “tic-tac-toe” placement.
    • The card angle should match the angle of your camera and fill one of the 9 grid areas with each step of the calibration process.
  2. If you have a honeycomb bed, try covering it up with something of solid color.
    • For the standard K40, an 11" x 14" slim, white painting canvas or material is a great fit to cover everything which the camera can pick up between the gantry rails.

Will check the tips out.
Thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.