Layer/pass glitches, then realigns

Machine: K40 (had M2Nano stock)

Board: LaserBoard

Firmware: Smoothie

Problem/ Question: _What causes some rows to be out of alignment, then recover a few lines after? See images.
I have had this happen a lot with the new LaserBoard, but it never happened when I had the stock board.
Printing at slower speeds, thinking it was speed-related, same issues, but the fact that it “self-corrects” several passes later is bizarre, and makes me think it is controller-related.
Also, the cut in Lightburn was lined with outline of the image and is clearly off by a millimeter+ on both axes. I am not sure what I am dealing with here.

Any assistance is really appreciated.

Hi Eric, have you made any edits to the config file on the SD card? In the config we set the default max speed, acceleration, and motor current optimistically, so they might need some adjusting.

You may need to increase the current and decrease max speed/ acceleration, in that order.

Check the section Updating the Config File in the guide linked below for notes on how to change those values. (You can probably skip steps 9 through 11.)

Once you’ve adjusted things try to run some tests to check the results and let us know if it improves.

I have not adjusted any config settings.
These are running at 100mm/sec (one on right was set for 2 passes unintentionally)
They both exhibit the same glitch/anomaly at the same spot, not showing in the original svg, obviously. Attached is the output showing same

I thought it may be my USB port sending garbage, so each of these are on different USB ports.
I will work with the config settings and do some more tests.

This recent celtic cross test again failed with same issues, layer glitching and the cut nowhere near centered around image as it appears in Lightburn, but also inconsistent pwm control across the engraving, it seems to me

.

This is frustrating.

In your first picture (the one in your first post), that’s certainly stepper motor skipping. That means either your acceleration is set too high or your stepper current is set wrong. Grab your motor model numbers and look for the proper current value and set that in the config file. If it still acts up, then reduce the acceleration setting. Do a search on the forum and you’ll see several posts where we’ve laid out the details on how to do this.

On your picture with the rebel logo, there’s likely an artifact you’re not seeing in the Lightburn workspace. I can’t count the times I’ve done this and wondered wtf was wrong with the software, my machine, or both, only to find out I derped and put a line there by accident and didn’t see it.

On your third I do see evidence of step skipping again. As far as your comment about inconsistent PWM - keep in mind that wood isn’t a uniform medium and you need to expect a fair bit of variance across the grain structure. Repeat the test with a more uniform medium like MDF or acrylic and I bet that problem won’t manifest.

I understand your frustration, but for some machines it’s going to take a fair bit of tweaking to get the acceleration right. Play with it and let us know how it goes.

Eric, as loather said, the issue you are seeing points towards motor skipping. While I provided you with the information to adjust the current and acceleration of your motors, I seem to have neglected to mention the words motor skipping as the issue.

Sometimes a bit of tweaking is needed for the config file to work properly for some machines, so make a few adjustments, do some tests, and let us know if it helps.

OK, I have tweaked some and the current setting seems to work properly at a setting of 1.2.
There is no discernible labeling on my steppers, so this was just trial and error.
I have only modified the speed settings and current settings, as noted.
Thanks for the direction on what needs changing. I still feel it is not optimally set, but will continue to tweak and play. Any further refinement suggestions are appreciated!
I am uploading a copy of this basic working config, as reference to my version of a (generic) Orion Tech K40 laser.config.txt (28.4 KB)

Your config file looks good, hopefully you are getting better results now. 1.2 amps is the maximum current you can set. Make sure your stepper motors are not getting hot. Warm is okay, but overheating them will lead to failure.

The steppers skipped when set to 1.0, so I have no further options, it seems.
Is there any way you know to pull the pertinent data settings from the old M2Nano board?
Thank you.

Eric, you might try to adjust the following settings:

default_seek_rate 18000

You can probably lower that by quite a bit… Try values like 15000, 12000, 9000, etc…

acceleration 2500

Try bringing that down to the 1000 to 2000 range.

Thank you, will keep tweaking with those suggestions!

Also make sure your steppers don’t get hot after increasing the current. They can be warm to the touch, but they definitely shouldn’t be uncomfortably hot (that is, you should be able to hold onto them for a long period of time without getting that, “maybe I shouldn’t be touching this,” feeling). Purely scientific, I know. :frowning:

Other signs of motor overcurrent are grinding noises (again, highly scientific description), unexplained loss of steps (goldilocks and the three bears, i know), and smoke - but if you get to the latter one it’s new motor time.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.