Laserboard driving LightObject Z-table: Z distance off

Machine: K40 with OEM board (replaced with C3D Laserboard)

Board: C3D Laserboard

Firmware: Smoothie

Problem/ Question: I’ve got the LightObject Z-table working so it moves on command using Lightburn. However, the Z movements only move 1/10 the distance set in Lightburn. For example, if the Z-distance value in Lightburn is set to 10mm, the Z-table only moves 1 mm. I’ve edited the Smoothie config.txt as suggested elsewhere on this forum. It’s been suggested to change the steps/mm from its original 316.9 to 3169, but when I do that the stepper motor on the Z-axis just squeals with no movement. I can fine-tune the steps/mm to get exactly 1mm moves when the z-distance is set to 10mm. If there’s no way to get the hardware to respond correctly, I suppose I can set the “z-step per pass” in Lightburn to 10x the necessary distance to get the z-axis to move correctly. Just wondering whether anyone else has suggestions on what to change in the config.txt file or if there are other solutions to this problem. Thanks!

Dave

Hi Dave,

The default value that came on the laserboard config file for Z (gamma axis) was some other unrelated number like 157…

I don’t have a Z table from LightObject personally, but a few people here did comment about getting it to work. I thought 3169 was a typo and 316.9 was the correct figure to use.

Machine: K40 (blue)

Board: C3D laserboard

Firmware: Smoothie

Problem/ Question: I’ve gotten my LightObject Z-table working with my C3D laserboard (LB) running under Lightburn. I thought I’d share how I wired the Z-table to the laserboard. It was complicated due to the fact that the laserboard’s markings for the 4 stepper wires are B2 B1 A1 A2 while the wires on the stepper motor from LightObject are A+ B- A- B+. If there’s a translation on the web somewhere I failed to find it! Anyhow, below is a picture of the final wiring:

motor-orange goes to LB A1
motor-yellow goes to LB B2
motor-brown goes to LB A2
motor-red goes to LB B1

1 Like

I had the same issue as you with the same Z axis. The 3169 number is right, but you have to change the speed to like 1 if using lightburn. I dropped my gamma max speed and acceleration by 1 decimal place in an attempt to adjust for the steps increase and it still screamed at me with speed set to 14.5. Dropped it to 1 and it worked perfect.

Your suggestions worked…thanks! The 3169 value isn’t exactly correct for my Z-table, but it’s very close. I will calibrate it further with a digital caliper.

My gamma_steps_per_mm value ended up to be 3234. I was able to get the Z-speed in Lightburn to 4.0 before the Z-table stepper motor failed to turn properly.

Have change gamma_per_mm 3234 still not working. Not sure about the speed & acceleration settings.
Starting to get a idea on this but don’t understand most of the settings in the config file.

The gamma_per_mm change is in the config.txt file for the C3D board. The Z-speed is done in Lightburn.

image

This has help still seems to stop off & on. Look at the specs for the motor and the parallel phase cur for my type is 1.4A (42HS03) think it parallel as I checked the resistance and it came out at 2.3 ohms. Set the current at .9 in the config file, did help. Just wondering how far I can push this as the rating for this motor is 1.4a

This is a good point. I set my gamma current value to 1.0.