Laserboard Continually Rebooting

Machine: K40
Board: C3D Laserboard
Firmware: Smoothie
Problem: Board continually rebooting during engraving (but not cutting).

First the important stuff, stock Laserboard with no configuration changes. It is plugged into the C3D supplied power supply brick which in turn is plugged into a surge suppressed power strip. I’ve monitored the incoming power using a Simpson analog meter which showed no deflection at time the board reboots. I’ve tried different outlets, cords, and surge suppressors with no impact. The board spontaneously reboots about 30-45 seconds into engraving but as the machine sits idle no re-boot occurs. the only other peripheral that is connected to the board is the C3D LCD graphic display panel. I have used the board for various projects involving cutting and text engraves but am having issues with picture or graphic engraving. I’m currently using Lightburn to control the machine but had the same reboot issue if I try to run directly from the SD card.

I’d like to chase down this issue and any guidance would be greatly appreciated.

Please provide:

  • Pictures of your machine, board, wiring.
  • Computer specs
  • A picture of your full LightBurn window (no cell phone pics please) and confirm what LightBurn version you are running.

I usually try to work through things in a sequential manner, but for kicks, try this first and see if it helps anything: Improved Raster Speed Firmware Update for Cohesion3D Boards!

I would like to have the information asked for above regardless so we know what to chase down later.

Computer Specs:

As you see from the screenshot I had also updated the Raster Speed firmware which had no impact on the issue. Thank you very much for your help on this issue.

I’m going to have to ponder this one.

Can you run the same job with the laser on, and then with the laser disabled, and then with the entire machine turned off, and see if it exhibits the same behavior?

Okay, you’re on to something.

  1. Same job, laser enabled
  • No effect, board reboots 0.5 seconds into first cut.
  1. Same job, laser disabled
  • Job runs normally (I’m assuming) as head moves as expected
  1. Same job, entire machine disabled (except for Laserboard)
  • Job runs normally (I’m assuming) as head moves as expected

I have attempted different computers, USB cables, and power sources but the results mimic the above results. You really have me guessing why the reboot with the laser enabled.

For power, I have a new Cloudray MYJG 40W supplying the HV to the tube and the two leads (Gnd & Laser) to the C3D board. The 24V for the borad is coming from the C3D PSU brick, and I have ensured that everything is grounded (including the K40 chassis.

What’s next?

As a follow-up I ran the attached file through Lightburn

. All of the lettering went first and ran perfectly. When the machine got to engraving the “Straight line flex cut”, the board rebooted. I ran that test twice with the same result.

I see from your pictures that you have metal hardware to mount your C3D board, You may need to look into isolating the board from the chassis using either non conductive hardware or other plastic mount.

Is this the file you used for testing and got the above results with?

Yes among others. All of them contained some “graphic” content. I now have the board electrically isolated using nylon hardware and cannot find any continuity between the board and the chassis. I no have tried three computers and four USB cables with no 100% success. The program runs from 0.5 to maybe 60 seconds before the board spontaneously reboots as indicated on the LCD screen. I have also attempted to make runs without the screen with no impact to the previous results. Where to next?

I’m sorry if I wasn’t clear in my last post but I am looking for the next thing I should try. It does appear that anytime I throw a lot of data at the card is when it reboots.

I understood, I was taking some time to think this over. It’s still a bit tricky to wrap my head around, so I’d like to further clarify:

You have that job file that you run.

If the laser is enabled, the board resets partway thru the job. This has been established.

If you do not have the laser enabled, does the job successfully complete? This is what I thought we established, but I want to confirm if this is correct after reading your 2nd to last post.

I’m trying to determine whether we are pursuing the “something strange is going on when I send this job data to the board” or “the board resets when the laser fires”. Or some possible gray area in between the two…

I’d like to understand your setup more clearly than what I was able to glean from the originally provided pictures, if you could take more pictures for me of your whole machine and wiring, including the C3D power brick and where it is plugged in to AC - the whole picture.

Then a video of the issue happening. More details like this will help - I’ll see if I can catch anything.

If the laser is disabled, the bob runs (or at least appears to). How can I send you a 2.7M file?

At this point I’d like to cut a deal where I buy a new board. If it works I get to return the old one but if it doesn’t I’ll eat both boards.

Dropbox or google drive and post the link here or email it (info at cohesion3d dot com) if you’d like it to remain private.

“Cut a deal” won’t be necessary. But I am trying to see if I can identify any issues in your setup before going down the board replacement route, which is why I asked for the additional information in my previous response.

Thank you, email sent. Sorry about the “cut a deal” remark. No disrespect intended. I’m just motivated to get this up and running the way if should. I do appreciate all of your help in helping me through this issue.

None taken. I was saying that this is not an adversarial process. I am trying to help you, but I have limited information to work with, which makes me feel like I am backed into a corner and unable to fully understand your setup and be able to assist you in the proper, methodical way that it needs to be.

The video you sent does show the board rebooting, yes.

As I have said before, this has usually been narrowed down to a power issue in the past - I tell people to plug the C3D Power Brick into it its own wall outlet (not a power strip), and if that still doesn’t help then to grab an extension cord and route it to yet another outlet (shooting for a different circuit in the house wiring entirely).

While all this may sound far fetched, we have seen our fair share of shoddy house wiring causing these issues and the above solving them.

These things all suggest that the board and software are working properly, and that the issue we need to be focusing on is why the board is resetting when running a job while the laser is enabled and firing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.