Laser won't fire, and can't connect current meter

Machine: Mophorn K40 (blue Chinese), originally with M2 Nano
Board: M2 Nano now replaced with Cohesion3D LaserBoard
Firmware: Smoothie

Problem/ Question:
ISSUE #1: I installed your LaserBoard, and installed/configured LightBurn on my Mac. Both installations went smoothly, I seem to be getting the right LED response on the LaserBoard, and my computer has no apparent issues talking to the engraver. A simple test-design created on LightBurn puts the K40 through all the motions of engraving it, but it never activates the laser. As far as I am able to determine, all connections are solid. The mirrors are correctly aligned, and the laser works; the power supply test-button for the unit gives me a mark in all four corners of the engraving area.

ISSUE #2: Your 30mA current meter arrived as a single component, without wires, plugs, or connectors of any kind to allow me to integrate it into my K40. As far as I can tell, your website offers no installation instructions at all. There is no current meter on my unit, which is why I bought yours! I have a basic competence when it comes to following installation instructions, but I am no technician. Had I known that this required additional components along with expert technical knowledge to install, I would never have purchased it. I still want to install it, but as it stands I have neither means nor knowledge to do so. Can you advise?

I sent this to you via email, and was advised to post here, instead. I am about ready to engrave things with my frustrated glare, alone. Please help.

Hi Michael, let’s get into Issue #1 first…

Can you please provide some pictures of the board and wiring? We always ask for pictures and try to go through some diagnostics first. Since you said you can run a job but the laser doesn’t seem to fire we’ll definitely want to get a photo of the large connector that goes to the LPSU, as that controls the laser firing.

Let’s also get some photos of the LPSU, and any text or labels where the wires connect to it. Confirming everything is wired up correctly is our goal.

For Issue #2, sorry to hear that there was some confusion about the current meter - we show a picture of a raw product, and yes you’ll have to wire it in yourself. Every machine and its wiring can be vastly different.

There are some good guides here:

This area was obscured in the prior photos.

Concerning the current meter, I don’t have the equipment or the skills to be comfortable wiring it in, particularly in light of, “This is no joke, touching this will kill a grown man straight up!”

I wish I had known that this was not an “… and plug it in here” kind of component. That was not clear from the listing. I guess we need to address how you handle returns.

It’s a straightforward installation. There will be a small-gauge wire coming from the cathode side of your tube and terminating either to the chassis or (more likely) to the laser power supply. You will cut this wire, and attach the cut ends to the terminals of the meter. Laser tube side to ‘IN’ and the LPSU to the other.

As I said, I lack the necessary equipment, but more important is I lack the confidence to do that. It was clear from your website that installing the LaserBoard is a straightforward mount-and plug operation, and that was indeed my experience of it (but for my present issue). There was nothing to indicate that it would not be the same for the current meter. I have no doubt that your installation advice is valid, and I still want to resolve that issue with a return.

How do you want to address the laser not firing? That remains my primary concern.

Michael, some lasers have safety interlocks, so make sure your lid is closed and then try the following.

Send some lines to the LaserBoard using the console in LightBurn as explained here: PWM tuning for Smoothie Firmware such as G1 X10 S0.8 F600

The laser head should move while firing. A red LED “Laser Fire Status” in the bottom left corner of the board should turn on.

Tell us exactly what does and does not happen.

Thanks for getting back to me. No safety interlock on my lid, but it was securely closed. I ran various commands from your indicated series via the console. LightBurn accepted them, and the engraving head moved (presumably) as instructed. Laser failed to fire. I went as far as going to the “move” tab and hitting the “fire” button; nothing.

Other things that may be relevant:

• The “laser test switch” on the unit control panel has never worked; but the one on the power supply does work.

• There appears to be a flow sensor in the water line associated with the laser tube. I have heard of issues involving those, and so I mention it here.

Sigh. Never mind that second bullet-point. It’s a thermometer, not a flow sensor. The wire from it feeds into the temperature display on the control panel.

Did the red “Laser Fire LED” in the bottom left corner of the board turn on when you sent the commands?

Here’s an image showing where the LED is located.

We noticed a switch labeled “Laser Switch” on your control panel. Typically that switch enables and disables the laser from firing. We’ll assume you’ve tried pressing it, but since you mentioned the “Laser test switch” has never worked, is there a chance this switch is also not functioning properly?

k40switch

One more question… Did your laser fire properly when running a job with the controller that came installed?

Sorry, I misunderstood; when I ran the series yesterday, I was looking for a display on the LightBurn control panel and not on the LaserBoard. My Clue is now marginally stronger, thanks to your patience.

Yes, the “Laser Fire LED” activates, so the LaserBoard thinks it’s activating the laser on command. It also switches on and off when I click “Fire” on the “Move” screen in LightBurn.

The “laser switch” button on the engraver console appears to function correctly. When pressed, it not only activates and de-activates the laser power display, but also the test-fire button on the power supply.

I never ran a job with the original controller, so I am unable to answer that very good question. I was having enough issues with the software on my old Windows laptop, that I decided to stop fooling with it and just order a big-boy controller that I could use with my iMac, and with LightBurn.

Try pushing the large power plug and wires into the board to make sure that all those pins are making contact. They get loose sometimes thanks to the wonderful Chinese craftsmanship. Then try the test again.

There are some important realities that are worth discussing:

  • If you’ve never run a job or test fired the stock laser, then we don’t have a base line to know whether your laser works to begin with.

  • One of the next debugging steps would be to “pretend to be the controller” and use a section of wire to connect the 2 pins from that large power plug responsible for telling the laser to fire. Do you have a multimeter?

Lasers make high voltages as part of their primary operation. To say that you are uncomfortable with that is close to the same thing as saying you are uncomfortable with the laser that you purchased in general. The K40 is very much a DIY machine that involves a tinkering and problem solving mindset, and there is an element of gambling with whether you will get a working machine or not. Note that DIY stands for Do It Yourself.

You have some work ahead of you. If it works out and you have a working machine at the end of the journey, that’s great! If it doesn’t turn out so well, you had a learning experience that only cost you hundreds of dollars instead of thousands or tens of thousands. A price worth paying every time, in my book (coming from the guy whose learning experiences have cost in the tens of thousands of dollars).

On a final note, our policy is that all sales are final. This is stated in the terms and conditions that you agreed to when placing your order. We sell very specific items that are responsible for controlling dangerous machines.

I hope you take some time to consider the thoughts I have shared with you above and come back to the table with the “lets dig in to this!” spirit. I really want us to be able to help you get your machine operational, but you’re going to have to meet us halfway.

Yes, I have a multimeter.

I unplugged the power plug, and as near as I can tell the wires seem consistently seated within it. I plugged it back in solidly. No change.

As long as I have the means and am sure about what I am doing, I have no problem with tinkering. I am sorry that I gave you the wrong impression. I expected to have to work “under the hood” to some extent, and I am indeed a problem-solver; but I lack the intuitive and layered understanding of electronics and complex circuitry that lets me go much beyond putting Tab A into Slot B. I substitute for that by becoming very, very sure of what actions I need to perform, and the clearer and more basic the instructions, the better. I don’t want to fry either the machine… or the operator! Within those parameters, I am prepared to meet you halfway or wherever else is necessary.

I have had my own expensive learning experiences, but right now “only” doesn’t pair well with “hundreds of dollars.” I need to succeed in this. I am prepared to dig in. Please understand that while I’m not a sow’s ear, neither am I a silk purse.

Ok, good.
I am happy that we are on the same page and can work together to get you up and running.

Remove the large plug from the C3D board side. Trace and identify the 2 pins called L (Laser Fire) and G (Gnd).

image

You’ll want to touch these to each other (probably with a length of wire) and see if the laser fires.
It’s low voltage here.

That will point us to which side the issue is on - the laser or board end of things.

Let me reality-check this. You are instructing me to:

• Remove the plug from the C3D board controller that is adjacent to the ribbon connection, and that feeds into the power supply. This exposes four pins.

• With the engraver powered up, use a wire to make electrical connection between pins 2 and 4 on the C3D board. Either this will fire the laser, or its failure to do so will be informative.

Assuming I am correct, I have some concerns. First, pins 1 and 3, identified on your diagram as “24V From Laser (Unused)” and “5V From Laser (Unused)” both have wires feeding into the plug that I will remove, suggesting that they are not unused. Second, all four pins are in close proximity, and I am concerned about the possibility of making electrical contact with those adjacent pins much like a botched play in the game of “Operation.” Any suggestions or insight would be helpful.

Also, I note that you included a diagram of the power supply connectors without any instructions relating to it. Are you just parking it there for the moment, or did I miss something?

Thanks for your patience and support. I really want to do this right.

No, connect the wires in the power plug, not on the C3D Board.

All this together to say that yes, you can disconnect the wires that are 24v and 5v on the LPSU end to be safe (remove wires from screw terminal).

You make me glad I verify these things when I’m not sure. I disconnected the 24V and 5V lines from the power supply – they remain disconnected – pulled the plug, and with a wire I connected laser-fire to ground within the plug.

Nothing.

Ok, your problem is in the laser side of the equation.

Make sure the enable switch is on, water is flowing, etc. If you’ve said that your test fire button hasn’t worked, that is a pretty good indication of things.

I would recommend the two websites we linked previously with the mA meter install guides, they have some good resources on laser not firing stuff.