Laser will not fire

Machine: 4060 chinese laser 60w (yellow and black)

Board: cohesion laser board

Firmware: _Smoothie “I have a new board and I’m using whatever it came with”

Problem/ Question: Laser will not fire. Red light turns on but no laser fire. Continuity was checked and there was non either on or off. Read a previous thread and followed your instructions. Laser not firing - new laserboard… same results as the individual.

Hi Roger, welcome to the forum!

Can you please provide some pictures of the board, the laser power supply, and the wires running between the two? Pictures of your machine’s control panel, and more info on the specs (manufacturer/ model) might also prove helpful.

We always ask for pictures and try to go through some diagnostics first.

I have tried changing the pwm to 400 then to 800. I have put a multimeter on the power and ground pin on the board screw as well as the pins to check for continuity and nothing when I send a job from lightburn. The red light turns on, on the chip and the laser head moves properly but no fire and no continuity on the pins. I tried jumping the red and ground wires on the connector and I get laser fire. I’ve seen to send this G1 X10 S0.8 F600 and my laser does nothing… Doesn’t move or anything when I send this g-code. I’m not sure what else I can try?

You’ve done most of the tests I have in mind for this situation.

Can you make sure that the wires of the large power plug are pushed in and making contact?

A little back story - we’ve had a few cases (roughly 1% of boards) where the optoisolator component that fires the laser isn’t working properly.

However, with the last 3 people that had a similar issue and were adamant that their board was bad in this way, we replaced their boards and it turned out that this was not the issue.

Given that you are located internationally, and all the current concerns with international shipping, we want to make sure to fully diagnose the issue and reach a proper resolution. (And of course given the laws of chaos, things will turn out in the most “fun” way possible. Of course.)

It’s also worth noting that there are a number of other ways that we can wire up your Laser PSU to the LaserBoard to get it to fire.

Can you make sure that the wires of the large power plug are pushed in and making contact.

I’d start by checking this - they get loose a lot.

I’ll check it out tomorrow after work. Thanks for the input and fingers crossed that it works.

So I’ve checked and checked… All the wires are touching the pins. Still no fire. What other wiring options did you have in mind? I don’t mind trying them as long as the instructions are clear what goes where. I would much rather fix this issue then have to wait another month for a new board.

The 2 pin male header in the lower left corner of the board labeled Alternate PWM Out:

run the + to H and the - to G on your LPSU .

From the “right side up” views like in your pictures, the left pin is + and the right pin is -.

Hopefully you have access to some dupont wires like this to make that connection on the board side:

image

You can now completely disconnect the large power plug from the board, and try the tests again.

Please make sure that your machine is properly and fully grounded, it will be more important now.

Before I try this… Just to be clear I’m basically using just two wires instead of 4?

Yep, the other stuff in the large power plug is not used anyways for our board.

I’m also not seeing H on the LPSU?

TH, the leftmost one.

Success… thanks a million

One more quick question… If I were to move the original red wire on the LPSU from the second spot on the left to the same one u instructed me to and plug back in the original plug would that work also?

I don’t think so… it’s a different signal that we’re using on both ends, H is active high vs L being active low.

Ok. Does the gauge of wire matter? I’m Using pretty small wire.