Laser shifting and loosing lines


(Randy Stockton) #1

Machine: K40

Board: Cohesion3D Laser Board

Firmware: _Smoothie

Problem/ Question: When I am trying to engrave a picture or even a square box, my laser seems to shift. I also lose lines. Anybody have any idea what’s causing this?


(Randy Stockton) #2

You can see on the upper left corner where the laser shifted to the left totally off the tile. On the right where the arrows are, I’m pointing out where the machine is adding or skipping lines as it engraves. The 1st and 2nd arrow from the bottom, it looks like it shifted. Others look like it either skipped a line or didn’t move at all.


(Anthony Bolgar) #3

What speed were you running that at?


(Randy Stockton) #4

I have tried it from 75 to 150


(Randy Stockton) #5

It does not always do it in the same place,


(Ray Webster) #6

I found that increasing the current to the motor, and lowering the acceleration speed stop this from happening.


(Randy Stockton) #7

I changed to current to 1.5 and run it at 75. I am not sure what the max is that I can send to my motors. I can’t see the motors without tearing the machine totally apart. What speed would you suggest?


(Jamie Richards) #8

K40 motors aren’t rated that high, unless you upgraded. Acceleration can cause a lot of missed steps if set too high. Is there a chance the belt needs tightened and it’s jumping a tooth?


(Randy Stockton) #9

The belts were loose when I first got the laser but they are not now… I changed the acceleration all the way down to 500 and it is still having the same issues.

I really have lost, any suggestions would be greatly appreciated.


(Jamie Richards) #10

Do you have any video of it while engraving? Is it jerky or hesitant?

What is your computer? Could it be having problems sending to the laser?

Have you tried GRBL-LPC to see if you get the same symptoms? While testing, you’ll need the screen disconnected if you have one.


(Mike H.) #11

I am having the exact same problem on my K40. How do you increase the current? How can I switch to GRBL?


#12

Take it one step at a time. In Smoothieware, the motor currents are in the config file located on the board’s memory card. I believe the stock values are 0.4 and 0.6 for X and Y in there. You can incrementally increase up to 1.2 amps.

Follow the same guidance here for how to access the config file: