Laser only fires on initial Y axis run

Machine: Shandong Laser Focus FS4060

Board: Cohesion3D Laserboard

Firmware: Smoothieware

Problem/ Question: I am doing initial tests of C3D Laserboard and Lightburn. The first picture is the basic geometries I want to be burned. The second picture shows the result. With each geometry the laser works only for the initial Y axis movement, the top line of the hexagon, the top of the circle, nothing for the line along the x axis, the top of the rectangle. After that the laser head moves well, smoothly, but the laser is not firing. I have not enabled or installed the rotary. I can move the laser head perfectly, it homes precisely. Belts are snug, neither loose nor tight as a guitar string.
Any ideas as to where I should look for a solution?


Correction: the laser only fires along the initial X axis movement, and nothing thereafter.
It is like the laser machine is set up on the rotary, except it is not so set up. Lightburn is not set up to use the rotary, and the rotary connections of the Laserboard are not even installed. Is there anything in the firmware, a switch perhaps, that should be modified to tell the C3D to not use the rotary? I know I’m flailing about here but I just cannot come up with any more possibilities to check. Does any have a clue to offer?

So the gantry moves in the Y direction when it homes, but won’t move when commanded otherwise? 0_o this is a tough one.

Let the machine home, then connect to it with lightburn and open the g-code console. Issue a G0 Y0 command to send it to Y0. Then issue a G0 Y100 to send it 100mm in. If those commands don’t work and move it as it should then we can debug further.

Good to hear from you. Actually, movement of the laser head is not an issue. Just to to sure I did as you suggested and G0 Y all over the bed, via the console, also with Lightburn Move panel. No problem. However, when I start a simple burn test, such as the initial LB screen, then the laser only fires for the initial movement along the Y axis for the top of each geometry; that short dash just to the right of center on the pink paper is the top of the circle. For the remainder of the circle, for example, the laser head moves exactly as directed, a circle, but the laser stops firing. It is as though the laser is set up for a rotary, burning along the X axis, but the machine, via LB, is definitely not set up for a rotary. The four wires for the rotary set up are not plugged into the Laserboard. The four wires, with the M2 nano installed, went to 2 relays that switched on or off theY axis for the rotary function. I simply bypassed the relays so that the wires from the Y axis now go directly to the Y axis on the Laserboard.
Is there anything in the Smoothie Cluster firmware that relates to the rotary functioning; so far I haven’t found anything. And I don’t know where else to look. Thank you for looking at this.

It certainly seems like lightburn is getting confused and thinks a rotary is connected.

Do you have an oscilloscope or logic analyzer? If so, I’d like to see what’s coming off the PUL pin on the A axis during a cut. There is a six pin JST connector on the board between a big capacitor and the ethernet expansion header. The pins you’re interested are the two to the extreme right of the connector. The logic is switched negative with PUL- being pin 5 and PUL+ (+5V) being pin 6. That is, pin 6 will always be at 5V potential and the ground is switched into the circuit on pin 5 during a pulse.

If you get signal between those pins on a move while sending a job, then it’s definitely trying to use the rotary axis instead of Y. I’m not sure why that would be happening if lightburn isn’t configured for a rotary, but hey, stranger things have happened.

Another easier way to do this (seriously why didn’t I think about this before typing all that out above?) is to export the GCode file for the job and look through it for A axis moves, If you see those then you know lightburn has somehow lost its mind.

Here is the G code for the same geometries, although the shapes are slightly rearranged. Geometric shapes.gc (2.9 KB) . I’ve been running a CNC router for 14 years so I am familiar but not expert in G code. The into, G17, G20, G4P1,etc are normal, although I don’t know what G40, cutter compensation does for a laser. The only code that stands out is line 12 M106, turn fan on, from 3D printer use. Is it possible that somehow the C3D board digitally translates this to turn rotary on, causing pin 5 to be switched into the circuit on pin 5 during a pulse? I am still plowing thru the Smoothieware Cluster firmware looking for something that switches A axis on, hence laser, but nothing I can identify yet.

M106 turns the air assist on in the laser mode. Looking through these gcodes, nothing is commanding the A axis to move and Y should be working as normal. Can you post your full smoothieware config file?

The full smoothieware config file. If your tenacity doesn’t resolve this problem then nothing will. Good luck.config.txt (28.4 KB)

The only differences between your config file and the stock config file are currents, steps, accelerations, and max rates - none of which would cause anything weird to go on like this.

Let’s get some detailed pics of your machine, board, and wiring - I want to rule that out as a cause first.

All pictures. Anything missing, let me know.

Apologies if I am behind on any particulars of your setup, George, I was out since last week with a bad cold.

I have 3 possible directions to head in…

  1. G0 Y0, G0 Y100, G0 Y200 does not work and move the head. You said it does, so ignore the below for now.

Can we further rule things out by having you use a completely fresh config file? I understand that as you have a larger machine it needs the higher currents and all those other modifications you made, but even if we have the Y axis grind a little bit, that would be something.

  1. Endstop conflict?

In this last pic, I see both the blue/ black dupont jumper wires connected to endstops, and a 5 pin white JST cable with actually 5 cables in it. It is uncommon for all 5 wires to actually be populated, and we wouldn’t have both of those connected normally - can you clarify what’s up here?

  1. LightBurn check:

Tools --> Rotary setup. Enable Rotary is off? 100% sure?

image

“Save GCode” for a job from LightBurn and we can have a look.

Actually I am surprised to hear from you at all. Seems to me you’ve been a one-armed paper hanger lately. #1 And now for something wierd. I was double checking that I could move the head any where on the bed. I moved it to X300,Y250, hit home, the head moved about a 40 degree angle to home and when the head was at Y400 the laser started to fire and continued to fire until X0, home. #2 I have not experienced any end stop conflict. When I press home, the head does so. The 5 wire white cable was the last wires after I transferred all the other wires from the M2 nano to the Laserboard. I asked on the forum, got no replies, and saw that the 5 wire socket fit the 5 pins, labelled Laser Endstops so I plugged the harness in there even though I have no idea what Laser has to do with Endstops. I just followed by touch the harness back to the Laser PSU. Looking at the photo you pointed to, which is upside down, and numbering the wires in the harness from the left, 1 goes to TL, 4 to WP, 1 to G, 2 to IN and 3 to 5v. G and 5v are very familiar, the other 3 labels are not. #3 Just to be 100.00% sure I once again check LB rotary set up and the switch is off.
Here is the Gcode from the Geometries I have been running from LB to test the laser.


Geometric shapes.gc (2.9 KB) Thank you so much. George Knoll

Uhh, if that’s where the wires on that 5-pin connector labeled, “laser endstop” trace back to, then disconnect this connector completely as it’s undoubtedly interfering. Give that a shot, run a job, and let’s see how this turns out.

I pulled the white 5-wire cable from Laser Endstop. When I plugged in the Laserboard only digital gibberage appeared on the screen. My usual job then ran exactly right except that the laser never fired at all. Without that white cable plugged in then the only wires that are connected to the laser PSU are power wires. Looking at the Laserboard pinouts, pin 1, 5v, connects to TL, pin 2 to WP, pin 3 to 5v, pin 4 to IN and pin 5 to G. I’m stumped. I hope you’re not.

Which of the five wires in the cable to Laser Endstop can I safely disconnect from the Laser PSU, individually or severally?

None of those wires should be in the laser endstop connector at all, ever. With the way you have your machine wired the laserboard should have connection to your L+ (TL on your machine) and GND pins through the large four pin “LASER POWER CONNECTOR” header on the laserboard. The fact that the laser’s not firing now is a little strange - i would expect that to be working perfectly. Check and make sure the wires on that four pin connector go where they should. Only the (Fire/TL/L+) and G connections matter, the ones labeled +24V and +5V aren’t needed on the board and don’t go anywhere outside that connector so it’s safe to leave them completely disconnected.

Right on. I connected the Fire/TL and G pins and the laser fired perfectly. The Laser Endstop connector is history. The only problem so far is that the test patterns all have wriggly lines in any direction.

Is that a software/machine maintenance & and fine tuning only? Is it certain that the issue has absolutely no relation to the LaserBoard?

yeah, this is just fine tuning at this point. Make sure the belts are adjusted properly, the rollers are greased and lubricated, and the gantry is square.

Follow this guide to make sure the steppers have the right current selected:

Try turning down the rates and especially the acceleration values and that should help things as well.

Good luck!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.