Laser not firing - worked fine for first week

Machine: K40 (originally with m2Nano)

Board: Cohesion3D

Firmware: Smoothie

Problem/ Question: Laser Not Firing

I installed the Cohesion3D Laserboard and had everything working properly for several days. Then the laser stopped firing. Everything else about the board still worked (ie, it controlled all X-Y-Z movements appropriately).

I have since re-installed the original m2Nano and all movements and laser firing works using K40 Whisperer.

See below for pictures and troubleshooting steps.

Picture of Original m2Nano board from my K40
image

Picture of my Cohesion3D board installed in K40 with LED lights on:

Picture of my Cohesion3D board with Laser Fire LED light on (X-Y-Z axis all move, but laser not firing):
image

Picture of my laser firing with manual test buttonnto prove that the laser still works:

I followed the troubleshooting steps from your website and had no luck resolving the issue.

====================================================
FORUM #1:


TEST:

disconnect the large plug from the LaserBoard, and check continuity on the Laser Fire and Laser Gnd pins on the LaserBoard while the G1 command is running and the red “laser fire status” LED on the LaserBoard is on, there should be some continuity shown on the meter.

RESULT:

Testing the laser fire terminals for continuity, I measured zero continuity with laser idle and with laser firing commanded (the LED in the control panel turned red, but the laser did not turn on)

Issue test command = G1 X10 S0.8 F600

my result = laser moved but did not fire

=========================================================
FORUM #2:

If you would, disconnect all the laser cables from the board (the SD Card, power brick, and USB cable should remain connected), put your multimeter into continuity mode, and touch the red and black probes as shown here where the red and black wires connect:
image

When you send the G1 X10 S1 F600 line is there continuity? my test result = no continuity

Hi Mark,

Can you please disconnect the board and get us clear pictures of both the top and bottom sides of it please?

I executed the G-Code noted above which I assume over-rides any software settings in Lightburn, but if not, are there any settings I should check?

While your waiting for further instruction you might take a look at the back of your card in the locations I’ve placed red boxes. It’s hard to tell from a picture but what looks like a transistor appears discolored like it may have released the magic smoke and the solder joint on the “Laser Fire” post is also discolored cant tell if it’s bad joint, flux or what. Look at them closely and give them a sniff test maybe you’ll get some clues.

Here are close-ups. It’s hard to take clear pictures. In these pictures/resolution the components look fried but in real life they look ok.

Note:. When the laser fires the “Laser Fire” LED lights up (see photos above)

Well it was just something that I thought warranted looking at closer as the discoloration looked like what I’d expect of a fried component. It’s tough to tell though as like you say it’s hard to get clear pictures. It should look very similar to the chip on the opposite corner though (they’re the same component) so at least you have in hand a comparison to look at.

As to the LED lighting on “Laser Fire” I’m not sure how meaningful that is or what the LED is triggered by so without schematics idk if it’s relevant.

I’m new with a C3D Laserboard so what I’m saying may or may not be of value but if it were mine I’d put a DMM on the Laser Fire and Ground pins and test the outputs at the board. You should see close to 5V while sitting idle and voltage should decrease while being fired. So if you power up you should see something close to 5V and if you send a job with Lightburn at say 50% power you should see the voltage decrease. If you don’t get that I’d think something not right with the board or configuration. If you do get decreased voltage then trace it to the power supply input L and Ground pin to make sure the signal is getting to the power supply. Since you stated the laser fires when you hit the test fire switch I expect the signal’s not getting to the PS as all the Test Fire switch does is take the L pin to ground so I’d think the problem to be upstream of the power supply. Somewhere along the way I’d probably put a new copy of the config.txt and firmware.bin file on the SD card just to make sure it wasn’t corrupted as well if none of the above was helpful.

After reading your post more thoroughly I see you’ve done a continuity test while sending G1 X10 S0.8 F600 and that resulted with “my test result = no continuity”. Since you’ve already done that I think you can disregard the steps I suggested previously with testing the voltages with a DMM. Basically I believe what your testing when you ran the continuity test was to see if the mosfet was opening and closing and when you get no continuity the mosfet is always open as in no connection. If that’s the case the L pin on the PS would not be taken low and never fire which is what you seem to be reporting.

1 Like

Matt, the important distinction here is that the other cases of this either had this symptom since immediately when they received their board, or it happened due to a wiring issue/ external factor.

I don’t see any burn marks in that area suggesting a problem, but I would encourage you to be vigilant - I have seen a few cases of the component being bad, but not of it going bad after working unless there was an issue, so I would encourage you to be vigilant about your wiring/ proper grounding/ machine setup and all that fun jazz.

I’ll need a day or so to personally test a board so that we can get a replacement sent out to you and get the old board back. I’ll reply to the email with RMA instructions.

Tim - your debugging strategies were generally on point with what we would have asked, but yeah, if there’s no continuity across the opto then that’s a closed case. Nice work.

Good to know I wasn’t totally sending him down the wrong path lol. Out of curiosity the chip I was looking at that’s discolored and difficult to read the product part# looks like a 03060 mosfet is that correct and what’s it’s duty?

Ray… understand and agree…if it was bad… you would think it would be bad right out of the box. All I can say is that everything was working well…did some test engravings…got the z table calibrated, focus dialed in, and went to do an engraving project and the laser wouldn’t turn on. The only time I had any “loose wires” poking around was in following the trouble shooting steps in the forum. I know you all are a small business and definitely not trying to take advantage of you in any way.

As to you last comment…check out a board…are you requesting I send my board back for you to check and determine if a credit is appropriate? I’ve not seen any emails with instructions.

Related…I’d like to order the cameras you have back in stock while they are still available…should I just order/ buy

  • new board
  • new camera
    And you can credit me whatever amount when I send the old board back in?

I appreciate that. We’re not going to leave you hanging.

In the interest of expediency, you can simply place a new order now for the camera and whatever other parts you may want, but do not buy another board. I will include a replacement board in that package. You can send back the original board after getting the new one and it is up and running. (Just the board, you’d keep the SD Card and power brick).

Ping back when it’s done and we’ll get it sorted.

LaserBoard has 3 laser control mechanisms including a 5v level shifted TTL output, the opto that fires the LPSU here, and a mosfet to drive a laser diode or relay for a cnc spindle, or whatever else…

Opto should be Lite-On LTV-217-G or equivalent.
MOSFET should be NXP PSMN030-60YS

The MOSFET is waaayyyy overspecced for what it needs to do, if you’re thinking about doing anything “interesting” you need to heed the same warnings as what we discuss for air assist. Air assist has the same mechanisms, a 5v level shifter and the same MOSFET.

Enjoy reading digikey and data sheets, curious to hear your conclusions about this :slight_smile:

Thanks. I was asking mostly out of curiosity, didn’t have any plans in mind. But now that I know I probably will set it up with a relay for my little air pump. Right now I just have a switch wired into the panel to turn it on/off so it would be more convenient to do it programmatically through gcode. Still getting acquainted to the Laserboard and haven’t really looked into all it’s potential yet. Only had it for a week or so but I have built a rotary for it and have been having some fun with that.

I really appreciate it. My new order number is Order number: 27410

Already saw it come in :slight_smile:

Hello,
I just wanted to check in. I’ve not seen any email instructions or information about my order status.
regards,
Matt

Replacement board tested and shipped with your camera order today, once you get that and hopefully everything is working, please let me know and we can arrange for you to ship me back the original board.

Great! Thank you very much. It’s much appreciated.

I am still not getting the laser to fire with the new board.

I’m wondering if I have a configuration issue in Lightburn?

I went all the way to square one.
The laser operates with K40 Whisperer and the original board.
I re-watched the installation videos https://www.youtube.com/watch?v=M285_qlkAxQ&t=609s
I uninstalled Lightburn, deleted the user prefs directory and reinstalled from scratch
I downloaded the latest config and firmware to the SD card and loaded it on the board.
Everything on the board works perfectly except the laser won’t fire. (laser fire LED lights up)
I’ve had it try to engrave a line, issued GCode G1 X10 S0.8 F600 …no luck
I did test fires of the laser using the test fire button on the panel and the test button directly on the power supply.

Any thoughts I what I could check?