Laser not firing using lightburn

Machine: K40 with M2 Nano and controller board

Board: Cohesion3d (LaserBoard)

Firmware: _Smoothie I believe; however, whatever was on the SD card.

Problem/ Question: Like others Im having issues getting the laser to fire using lightburn. I can get the laser to fire using the now semi dead K40 controller board and test button on the PSU. When I tru]y to run the G code from another link it runs the code; however, no laser fires at all. The LED on the control board doesn’t illuminate either. I tried swapping the main board wires from the JST connector to the screw in connector, same results. Also, not sure what happened with the control board, before I connected the cohesion board the control panel numbers illuminated to set the % for the laser power. Now all I get are two red dots below where the numbers illuminated. I can still fire the laser with the test button on the control panel and PSU, but nothing from lightburn. Even upgraded to the newest version of lightburn, same results.

I’ve also sent a work ticket asking about the full graphics lcd adapter as I have numerous lcd screens laying around the shop from 3D printers. No response yet.

New poster so I can’t upload pics.

Please help. I’m trying to do a project for a friend who’s retiring from the Military early next month and need the laser working soonest.

Thanks much
Dan

I now know the cohesion3d board is hooped. While trying to get the board to fire the laser, doing absolutely nothing different from what I was doing before. I began to smell something burning. looked inside the panel to see smoke coming from the cohesion board. hit the master power switch and let it cool off, have a good look at the board, couldn’t see anything on the top at all. The smoke was coming from the edge of the board but no burnt areas. Removed the board from the board mount I made on my 3D printer, flipped the board over and immediately see a burnt area where the power comes into the board from the PSU. I’ve taken photos of the burnt area but can’t upload them because I’m to new of a poster…

I’ll be submitting a ticket on this as well. It sucks, I have a job I have to have done in a week and the laser is now down 100%, no way of recovering it until I get a replacement board. You may pay $40 for expedited service; however, you sure don’t get that service at all. Not Cohesions fault either, USPS/Canada Post.

Hi Dan,

I’m working on processing this information you have provided. In the meantime, you should have the necessary trust level now to post pictures of everything we request, so that I can see the current status of everything. If you have pics of how everything was hooked up when the “event” occurred, that would help too.

Hi Ray,

Here are the photos of the board and wiring. It’s a simple unplug the M2 Nano and plug into the Cohesion board.

Dan

Can you provide a full-resolution picture of the back of the board as well?

As per your request.

Hello there,

Any updates? I need to get a project completed soonest for a friend retiring from 35 years in the Military. I really need a replacement board soonest.

Thanks
Dan

The optoisolator is clearly smoked on this board, which indicates the +24/+5/G/L+ lines were hooked up incorrectly at some point or shorted somehow - I see in the pictures the board seems to be hovering over the LPSU but I can’t tell how far above it is sitting. it’s possible the board was pushed against the LPSU case and something shorted, killing the optoisolator.

The +24/+5 lines aren’t even used by the board and since you have them broken out individually here, there’s no reason to even connect them at all - I’d safe off the ends and just not connect them in the future.

Additionally, your endstop connector may be in backwards - normally on K40-type machines the leftmost pin in the pictures will be empty so let’s verify that isn’t contributing.

In any case, let’s do some tests to see if this thing is still operational.

First, disconnect everything but the USB cable and the barrel connector from the power brick.

Disconnect the board from power, then power it and let us know what the status LEDs are doing:

Once that’s complete, we can move on to some basic continuity tests.

Follow the procedure Starla outlines in this post and report back your results.

I will certainly do as you want. As for the board touching the PSU, not possible. It’s attached to the side of the cabinet which is connected to a 3D printed mount. I even recessed the nuts inside the frame of the mount just so this wouldn’t be an issue.

I did see the two power leads didn’t do anything, but figured as they’re plug and play, just swap one for one. As for the end stops, they work as they should.

I’ll plug it all back in and run your requested tests. I did check all power from the PSU prior to plugging in the cohesion board, like 5v gave me 5volts etc. I didn’t go any further than that though as I’m no electronics expert at all.

I literally only did plug and play swapout, I didn’t add or remove any wires etc, short anything out, well other than trying the two wires that attach to the control board to fire the laser, which it did, then put the wires back in the connector. Tried to run the G1 code posted in the forums, as I said it ran the code but wouldn’t fire the laser at all.

More to follow when I get into the shop and do as you requested.

I’m uploading the board mount I had the cohesion and M2 Nano board attached to. I’ve since made an updated version for more support. Neither of the board mounts touched the PSU case as well. Both hover above the PSU by a couple of mm Pic of old mount is attached.


Ok, I’ve got the board installed again and right now all that’s hooked up is the external power plug and USB cable. The power bank is plugged in and I see a normal status on the LED’s See pics.

I’m going to continue with the other tests and post results soonest!

I’ve hooked up the multimeter and tested continuity, I’m not getting the tell tale beep from the multimeter but readings at the screw in connector of 52.3 Ohm and at the pin connectors around 58.3 ohms; however, they do fluctuate up and down a bit. See pics of the connections and readings. Hopefully I’m not posting too many pics, I just want to be sure what I’m doing is exactly what you want!

As for running the “G1 X10 S1 F600” I get nothing different from the above listed readings and no other indications either, all LEDs appear to be the same nothing changed.
Please let me know what else I can try?

To add to this here is a shot from Lightburn showing Ready status and Ok when running the G1 code.

Something is very odd here! I literally just touched the power brick cable and all of a sudden I heard the bleep of the USB connection disconnect. I looked at the board and the only LED light was the single VMOT RED led light. I unplugged the power, couldn’t smell anything so plugged the brick back in and it went back to full normal LED status.

Hello?

It’s been a few days now and no response. Please folks, I’ve spent allot of money on this board and it hasn’t worked since it arrived.

Hi Dan,

It was a weekend. Quality responses take time, we are very busy and trying to keep up with everything, and the occasional break, at societally accepted times, is much needed to recharge.


Before anything else, we need to figure out why these things have happened. The opto would not fry like that unless it was miswired, as loather points out. The board was tested twice - first at our factory, and a second time at our HQ before it was shipped out to you, and I can assure you it did not do that on its own.

We’ve seen a pretty clear (but thankfully rare) pattern of "K40’s large power plug gets plugged in shifted by 1, 24v gets run through a 5v section of board, and the opto fries, taking the short trace labeled “laser ground” with it. Thankfully, because the opto exists, and sacrificed itself, the rest of the board might be unharmed. The brain activity you are seeing is a good sign.

In this picture, we see the endstop plug with red and black wires. From that orientation, the left slot is occupied, while I believe the right slot is empty. Please confirm if that is correct.
That is the opposite of how we expect it. So either that connector is plugged in backwards, or keyed backwards.

I don’t think that this necessarily contributed to the opto frying, but it would make a short when the switch was pressed, putting the board into a safety state to protect the brain. In short (no pun intended), that plug needs to get flipped 180 degrees, one way or another.


I would encourage you to investigate the wiring inside your machine to find what goes where and identify if anything is mislabeled or connected to a different place than previously expected.

Finally, in the interest of getting you operational more quickly… I’ve enjoyed seeing your wiring and nice tools - do you have any soldering tools, iron or hot air rework?

Hi Ray,

Thanks for the reply, I saw it last night and began reading it; however, I have severe C-PTSD from my Military service and when I began reading your response, well, it sent me into a severe tail spin! I’ve spent more money on this board than I have on allot of things because using the laser for projects for Military and veterans keeps my mind focused rather than in dark places. Sadly dealing with this board and it’s issues has put me back in a dark room!

I bought the board because it’s supposed to be the best of the best, so far my experience doesn’t show that :frowning: it’s a simple plug and play board, another reason I chose it. I have several SKR boards kicking around my shop for my 3D printers, those have shown up guaranteed to be working yet have shown that this isn’t the case at all, we all know that “stuff” happens, wanted to use a different word, but……

I’ve literally done nothing more than swap wire for wire, hence the reason for purchasing a swapout board! As for the end stop connector slot, I did the checks loathed requested and I’ll go back and recheck again, but it’s my experience that those are just simple go-no go switches, should have absolutely no effect on whether a board will fire a laser or not! The gantry homes as it’s supposed to the way it’s wired up, without issue though.

Yes, I can use a soldering iron and heat gun, have 2 soldering stations and one mini heat gun as well as a full size gun as well.

I’m sorry, I find this extremely frustrating! I completely understand issues with Covid and all; however, I’ve paid allot of money for a board that since day one hasn’t worked as it’s supposed to. I have absolutely no issues doing the requested tests, etc. But to take this long to get responses just isn’t what I was expecting at all.

So far the laser has been down for over a month now and it hurts! I received a Service dog through Wounded Warriors Canada and a private donation from the family of a person who had taken their own life in the line of duty. Because of that gracious donation I wanted to try to pay this kind act forward. I reach out to local glass companies for donations of acrylic to make items which I sell then 100% of the profits go directly into a non-profit company that provides service dogs to Military, first responders, kids with autism as well as other reasons. My goal was to try to make enough money to pay for another Veteran to get a much needed service dog. I spoke with the executive director of this non-profit about this and she is 100% onboard. I won’t leave the name here as I don’t want to advertise that. I can provide her name as well as the non-profits name if you’d like privately, if you’d like. Sorry for the rant here. I just wanted to show you that I’m not here trying to rip anyone off at all. I’m trying to do something to help allot of needy folks out. With the M2 board not working as well as this board, well, I’m getting no-where fast!

What more do we need to do to show the board isn’t working as it should? I’m able to move the gantry in every direction, it just won’t fire the laser at all! I can manually fire the laser on the control board as well as the PSU test fire button. I have the control board set to max 32% so I can control the power through lightburn. When I run the G1 code it runs the code but still doesn’t fire the laser.

Please I need this laser back up and running soonest!

Hi there,

I’ve looked at the end stop and how it attaches to the board, it’s as it should be! The open slot on the board is the +5v leg. I flip the board over and the jst connector is connected the right way with the wires. black wire to gnd and red wire to YMX and XMX. The gantry will home just as it should.

I tried to upload a video showing it homing as it should; however, it won’t allow video uploads.

What next?

I’m doing what I can, and can’t do more than that.

Are you familiar with a saying that goes something like “if a fuse blows and you blindly replace the fuse, it’ll just blow again”? You have to find out what caused the fuse to blow and fix that issue, so that things work.

I looked at your pics and identified 2 separate concerns - one being the endstop wiring, and the other being the whole situation with the charred opto. Both would need to be corrected.

I’m trying to get you up and running with what you already have there first. To this end, I would recommend trying to remove the opto from the bottom of the board first. Doing it with a soldering iron would be better, as a general heat gun (as opposed to a specialized hot air rework station for PCBs) might melt or damage other areas of the board.

Then, please try to run G1 X10 S1 F600 and see if the red LED in the bottom of the board lights up now.


You can upload videos to YouTube and provide a link here.


I’m sorry if you can’t see that I am trying to help you. While I respect the frustration that must come with this experience, and what you have described you are going through, repeatedly talking about how much money you’ve spent, how the board came defective despite the fact that very clearly the opto did not come like that and would not have burned unless something very wrong happened outside of the scope of the board itself, and generally trashing me on Facebook/ other avenues, will not make things better.

Case in point, I just had to spend half an hour writing this to diffuse the situation, time that could have been spent helping you and others with actual tech related things.

Hi Ray,

I’ll do as you ask for sure! As for bashing you on Facebook?? I’ve seriously thought about it, but only as a very last resort!

As for the only way damage can occur to the board is only by my error, I’m sorry, I completely disagree with that! They’re electronics and virtually anything can happen with them that we may never see physically ourselves! Being jolted in shipment, being dropped anywhere. Anyone that owns electronics and had one of them crap out clearly knows this. The part I struggle with the most is when people claim it’s never their products fault! Anyways, enough of this, I will do as you ask and go from there.

I would certainly entertain a refund and I’ll send you the board back too though! I wanted something that was plug and play, for me this just isn’t the case. I also see others in this forum that have/had the exact same issues before the opto (no idea what that is either, sorry) popped. I thought the part that blew was a mosfet.

Dan

Dan

Here is the youtube link.

Ok,

I’ve removed the opto? and hooked the board back up. I get a red LED in the corner of the board when I run the G1 code that I’ve never seen illuminate before; however, the laser still doesn’t fire. I also noticed that the only time I can get the red LED to illuminate is when I home the gantry first. I’ve got the control panel set to 10Ma or 29% on my machine too. When I press the test button on the control panel the laser fires, also the same when I push the test button on the PSU. Exactly the same response from my initial post. The gantry moves as it should. I also tried G1 X100 S1 F600 same results. Tried to do my own detective work here and tried to change the laser_module_pwm_period 200 from the 200 to 400 under the help files, same results. Gantry moves but laser doesn’t fire.

Here is another link to see exactly what I’ve done. Apologies as I’m no videographer…

Dan