Laser not firing - new laserboard

Machine: k40, nano m2, digital control panel with an ammeter, HY-T50 psu

Board: LaserBoard

Firmware: “I have a new board and I’m using whatever it came with”

Problem/ Question: I just got my LaserBoard today. After i installed it i fired up lightburn and was able to use the jog controls, using the digital control panel i can test fire and set the power level of the laser. So that all works. I wired up the laserboard with the laser fire to TL on the HY-T50 and tried to run a test cut through lightburn. It will trace the path but the laser will not fire. I enabled the test fire button in lightburn and that won’t fire the laser either. FYI i can wire a button from TL -> GND and the laser will fire when the button is pressed. Not sure what to do.

1 Like

I need pictures of your machine, original board, and wiring to be able to help you.

original board, everything unhooked

new board hooked up
board%201

power supply wiring

My reply here may be of help, can you confirm that you’ve wired it correctly? Help wiring a generic 80w lpsu to LaserBoard

Send some lines as explained here: PWM tuning for Smoothie Firmware such as the G1 X10 S0.8 F600

The head should move while firing.

yeah i doubled checked the wiring, i even unhooked everything except the laserboard
wired
WP -> GND
IN -> 5V
LaserBoard Laser Fire -> TL
LaserBoard Laser GND -> GND

closeup of PSU Wiring

i looked at the pwm settings, changed it to 400, still no laser firing.
I even changed it to 800, no laser firing.
I ran the commands in the linked post. The head moved but no laser firing.

When you send the command, does the red LED “Laser Fire Status” in the bottom left corner of the board turn on?

yes i can see a red led status lighting up

so i stuck a multimeter on the TL and GND with the laserboard hooked up, It reads 4.94 volts. Even when i hit the fire button in lightburn. I ran the macro i made for running the pwm test and it still read 4.94 volts on TL, didn’t see it change any.

I removed the laserboard, and hooked up the nano m2 board and using k40 whisperer i was able to fire the laser and perform cuts like normal. I can only assume that something is wrong with the LaserBoard, unless someone else has some input? How do i get a replacement board?

is there any other troubleshooting to try, or is there some way i can get a replacement board, this one doesn’t seem to work.

I have one last test in mind, I just need to verify it with a board here, and will get back to you shortly.

Thank you for your patience.

If you would, disconnect all the laser cables from the board (the SD Card, power brick, and USB cable should remain connected), put your multimeter into continuity mode, and touch the red and black probes as shown here where the red and black wires connect:

By default is there continuity?

When you send the G1 X10 S1 F600 line is there continuity?

Test results as follows

  1. connected everything as instructed, multimeter set to continuity mode. No beeping from multimeter(no continuity)
  2. Ran command through lightburn, saw ‘Laser Fire status’ LED light up. No beeping from multimeter (no continuity)

Thank you for that info. I’ll reply to your email to arrange the replacement of the board.