Laser not firing - new Cohesion3D Laserboard

Machine: K40 nano m2 digital panel without ammeter

Board: Cohesion3D Laserboard

Firmware: “I have a new board and I’m using whatever it came with”

Problem/ Question: I just got my LaserBoard this week. After I installed, I try cut some paper. Software work good, but laser not, it trace the path but the laser not fire.
I tried different power in control panel and in lightburn.
The light in the laserboard is ON when it fire, but laser didn’t works.
I saw a post about measure continuity in laser pin. In my board, default is open and fire show some continuity. Led in control panel fired, but laser didn’t cut.
When I press test button in panel it cut without problems

Good.

Interesting.

This is a common question.

  • First, please provide pictures of your board, machine, and wiring.

  • The most important detail: how are you attempting to fire the laser?

This is my machine:

The original controller:

New Cohesion 3D Laserboard:

It’s flat cable wiring

Laser LED in panel it’s always lit

When I tried to cut, led shine a little more. But, no matter what power I set, no cuts…

Only cut when I press and mantain the test laser buttom from my laser cut machine

I double check wiring and seems to be OK.

Even when I use the GLCD Panel, It not cut.

When I try the old controller, laser cut is OK.

What do you recomend me?

The proper way to attempt to test fire from the board would be to issue a command such as G1 X10 S0.8 F600 from the console in LightBurn.

I already tried. No luck…

Even with G1 X10 S1 F600…

Let’s back up a little bit to make sure I understood everything correctly.

If you disconnect the large plug from the LaserBoard, and check continuity on the Laser Fire and Laser Gnd pins on the LaserBoard while the G1 command is running and the red “laser fire status” LED on the LaserBoard is on, there should be some continuity shown on the meter.

Separately, if you connect the L and Gnd pins in that large plug to each other for a moment, the laser should fire.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.