Laser not firing issue

I have a K40 with the a newly installed Cohesion3d board running Smoothie using Lightburn software. There are no issues with x and y-axis movement, homing or origin with the default config file setup but the laser will not fire.
The original M2Nano board works fine with the laser.
Here are the photos of the wiring.



Looking through the forum this is what I have checked so far:-
There is continuity on all of the wires from the LPSU terminals to the board plug.
The terminals are seated fully on the C3D laser board pins.
The laser fires if you connect L to GND on the plug.
The laser fires from K40 electronic test switch.
The laser power is set 38% which is 12 mA on the meter.
The board in standby - all LED’s look good.

The board when Lightburn is set to cut a simple square - looks good The Laser moves and traces the square. The K40 control board laser fire light does not light up.

I have tried setting the laser_module_pwm_period to 400 in the config file, the K40 laser fire light does not come on.
I have tried all of the G-code tests, the K40 laser fire light does not come on.
I have tried a new USB cable - no change
I downloaded the laser board firmware, renamed the original files to .old and installed - no change.
There were some other posts on possible solutions which required re-wiring but I don’t wish to try those without advice.
Hope that helps in trying to resolve the issue.
I am in the UK so replies may take a while. In the mean time I will pacify the wife who is chomping on the bit ready to do more projects on the machine.

Hi Alan, thanks for running through all of those tests. Hopefully it will help narrow things down a bit.

Did you connect L to GND on the LPSU end in the first photo, or on the white connector end in the second photo?

On some K40 lasers the “Laser Test Switch” on the control panel ignores the “Laser Switch” and will fire even if it is off. Can you confirm the “Laser Switch” is on? Could you post a photo of the control panel of your laser?

In your fourth photo the Laser Fire LED on the LaserBoard is lit up, which would indicate the board is sending the signal to fire the laser, so at least that part is working.

Is this set on the K40 control panel?

Can you let us know what Gcode commands you sent via the LightBurn console? Did you set the S value high enough? (For instance, did you try S1.0?)

Hi Pete,

  1. Connected L to GND on the end of the white plug.
  2. The K40 I have will not fire the laser or the test switch unless the ‘Laser Power’ switch is on. If the switch is ‘off’ the control panel is dead.
  3. The image shows the control panel board. There is a reason for the name BTW, nothing to do with the control board, this was a really, really bad example!

    This image shows the laser power @9.5 mA (30%) using the test switch. BTW bypassing the digital amp meter makes no difference to any output from the control board, I tried that too.

    And the reverse side.

    I sent the G-codes via the Lightburn console from minimum up to the maximum - G1 Xnn Ynn S1.0 F600.
    Hope that helps.

Alan, thanks for all the clear explanations and photos you’ve provided. I will assume you have a multimeter handy to do some more testing? If so, we’ll work on preparing what we’d like you to walk through and then let you know what to do.

Pete, no problem with testing I have a multimeter.

Alan, what we want to do in general is this:

  • Hook up the L and GND wires going to the LSPU as shown in the photo below - there is a MOSFET to drive other things like a diode that we’ll try to use. Note that this is hooking up to the actual ground plane of the board, so there is no longer protection afforded by the opto and any power spikes/ miswiring/ whatever could damage the board.

if you need more specific details let us know. The goal is to see if the board will fire the laser.

Once you do that try using the console to do the G1 Xnn Ynn S1.0 F600 test again and let us know what happens… and if you need more specific details on any of this, let us know.

Pete, hooked up as shown. (This is for the benefit of others) : -


Fired up the laser and Lightburn. Pasted the G-codes into the console, the laser fires properly with increasing power from bottom to top as expected…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.