Laser not firing after working earlier today

Machine: K40

Board: Cohesion 3D Laserboard
Firmware: I have a new board and I’m using whatever it came with

HI all! I have been succesfully using my K40 with a new Cohesion 3D Laserboard and all has been great until about two hours ago. I moved the laser from my kitchen (where I have been setting it up and testing it) to it’s new home in my workshop. After moving everything and powering up, I cannot get the laser to fire via Lightburn anymore. The laser fires fine when using the test button.
I’ve had a little read around the subject by searching on here and, being a complete electrocnics noob (sorry!), I can’t fathom out a fix. I have checked for continuity over the Laser Fire and Laser Gnd pins (with the big connector unpluged) whilst running G1 X10 S0.8 F600. There was no continuity.

Thanks in advance for any help here,
Alex

I’ve tried to upload some images but it seems I don’t have permission.

Hi Alex,

Welcome to the forum! I have upgraded your trust level so that you can now upload photos.

Please provide clear pictures of your machine, control panel, board, other electrical components, and wiring. We need to see how and where everything is connected.

Make sure all of your electrical connections are firmly making contact (i.e., didn’t come loose during the relocation).

Can you run this test again, please? A red LED “Laser Fire Status” in the bottom left corner of the board should turn on.

image

Tell us exactly what does and does not happen. Is the laser head moving while firing with the LED lighting up?

Hi Starla,
Thanks for the reply :smiley:
I can confirm that the LED lights up and the laser head moves when I send the command.

Pictures of my machine:

Just to add, I’ve re-flashed the SD card with the current firmware - no change.
I’ve also used a short piece of wire to connect the Laser Fire and Gnd ports on the big connector - the laser fired.

I have continued trying to trouble shoot today. All wiring seems secure and in place correctly. I have tried an alternative USB lead from the PC.
Re-fitted the original M2 board but that failed to fire too when commanded (in K40 whisperer).
I did have to put a fresh terminal on the ground for the ammeter, could this have caused problems?

Any help greatly recieved!

Hi Alex,

Thanks for trying the other tests.

If you’ve checked all of your wiring, switches, buttons, and electrical components to confirm that they are properly seated, connected, and/or functioning as designed, you should perform continuity tests to determine where the disconnect is. We recommend having your laser on a dedicated circuit in your home, as other equipment can interfere with the performance of your machine.

It sounds like you are saying the laser is not firing with either controller connected now. Is that the case? If there is any break in the series, then yes, this could cause an issue.

Since your setup has changed since the last time or we have been made aware of other variables, lets start again for some clarity. Please select and quote my questions with your answers so we can keep track:

  1. Does the laser still fire from the red Test button on the LPSU between the 4 pin and 6 pin headers?
  2. Does it fire from the test button on the Control Panel?
  3. Is the mA meter registering the test pulses with a current reading?
  4. Is the tube ionizing (turning pinkish purple) when you do either of the test fire button tests?
  5. Does the still fire laser fire when you remove and short the L and G pins on the power plug connector?
    image image

Thank you for the reply. I have managed to resolved my issue by checking and doubl checking the wiring again. In my haste to get everything up and running again I had connected the test fire/lasr on off switched the wrong way around. So the test fire button was actually turning the laser on and off and the laser on button was causing it to run all teh time or not at all. Apologies for my stupidity! All is working again and I’m super happy.
Now to order a lightburn camera :slight_smile:

I’m happy to hear you got it sorted, Alex!